X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Jerky scrolling, unresponsive

Kuphostiwe

Hi,

Scrolling has become unresponsive (at times a few seconds) and, when it finally scrolls, it does so with a jerk. This happens especially on websites as Rakuten and eBay when there are lots of small images and lots of open tabs. Page loading too is slow.

Please note that I have sufficient throughput as we regularly stream 2 XHD (1080p) movies simoultaneously flawlessly. I experience the problem on my Sony Vaio VPCSA (6GB RAM) running Win7. everything is updated.

Troubleshooting: Deselected hardware acceleration: no improvement. FF in safemode: very slight improvement (but maybe this was only my wishful perception). Disable Add-Ons: I could not test. The tabs "Services", "Appearance" and "Extensions" show this message: "You don't have any add-ons of this type installed" while I do have quite a few extensions installed. The "Plug-ins" tab regularly shows all the correct plug-ins that are installed.

Please advise how to restore smooth and fast scrolling.

Tommaso

Hi, Scrolling has become unresponsive (at times a few seconds) and, when it finally scrolls, it does so with a jerk. This happens especially on websites as Rakuten and eBay when there are lots of small images and lots of open tabs. Page loading too is slow. Please note that I have sufficient throughput as we regularly stream 2 XHD (1080p) movies simoultaneously flawlessly. I experience the problem on my Sony Vaio VPCSA (6GB RAM) running Win7. everything is updated. Troubleshooting: Deselected hardware acceleration: no improvement. FF in safemode: very slight improvement (but maybe this was only my wishful perception). Disable Add-Ons: I could not test. The tabs "Services", "Appearance" and "Extensions" show this message: "You don't have any add-ons of this type installed" while I do have quite a few extensions installed. The "Plug-ins" tab regularly shows all the correct plug-ins that are installed. Please advise how to restore smooth and fast scrolling. Tommaso

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Picasa plugin
  • Shockwave Flash 20.0 r0
  • 5.1.40728.0
  • VLC media player Web Plugin
  • NPWLPG

Isisebenziso

  • Firefox 43.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/43.0/WINNT/en-US/

Izandiso

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0126
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: D [ Gamma: 3600 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200 ] D [ Gamma: 3600 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ]
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedMismatchedVersion']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 9-26-2011
  • driverDate2:
  • driverVersion: 8.862.4.2000
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedMismatchedVersion']
  • numTotalWindows: 1
  • supportsHardwareH264: No; Hardware video decoding disabled or blacklisted
  • webglRendererMessage: [u'blockedMismatchedVersion']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

Continuing from another thread (Rik's Scroll very slow on v.40 and very fast on v.39 /questions/1112023

ascanio1 If you would like to attempt to use Windows own safemode, and try to describe the problem again, then s you still have problems we will continue trying to help you. Please see

Thanks John


ascanio1 Ahh, Sorry. I noticed two questions against your name, but somehow thought one related to this thread when it was in fact your own question thread, but with a few other people in it. Ok so it is best to try to stick to that thread. Please try starting in Windows safemode as was suggested. Note that is fairly easy usually just needing you to press the F8 key about twice a second as you try to boot the computer. It is not in itself anything risky, or permanent it is just a troubleshooting step that helps us rule out (or in ) certain issues you my have with a computer. Also more detail of the problem.
  • How bad is it, what do you mean by not smooth or jerky. I it freezing up or unable to move for a fraction of a second, or stopping for a few seconds.
  • Is it noticeable on all sites, nearly all sites or only on a few, such as ones with a lot of pictures or very long pages.
  • Have you tried to look at CPU and Memory use while you have this problem ?
  • Have you tried with just Firefox open on you computer,an with only a single tab open on Firefox.
Please actually answer this in the other thread, where I will repeat this question. Thanks, and sorry if it is is bit inconvenient and repeating things. I am just trying to make the questions easier to follow.
Continuing from another thread (Rik's ''Scroll very slow on v.40 and very fast on v.39'' [/questions/1112023] '''ascanio1''' If you would like to attempt to use Windows own safemode, and try to describe the problem again, then s you still have problems we will continue trying to help you. Please see * ''How to Start Windows 10 in Safe Mode'' http://www.tenforums.com/tutorials/2304-safe-mode-start-windows-10-a.html Thanks John <blockquote> ascanio1 Ahh, Sorry. I noticed two questions against your name, but somehow thought one related to this thread when it was in fact your own question thread, but with a few other people in it. Ok so it is best to try to stick to that thread. Please try starting in Windows safemode as was suggested. Note that is fairly easy usually just needing you to press the F8 key about twice a second as you try to boot the computer. It is not in itself anything risky, or permanent it is just a troubleshooting step that helps us rule out (or in ) certain issues you my have with a computer. Also more detail of the problem. * How bad is it, what do you mean by not smooth or jerky. I it freezing up or unable to move for a fraction of a second, or stopping for a few seconds. * Is it noticeable on all sites, nearly all sites or only on a few, such as ones with a lot of pictures or very long pages. * Have you tried to look at CPU and Memory use while you have this problem ? * Have you tried with just Firefox open on you computer,an with only a single tab open on Firefox. Please actually answer this in the other thread, where I will repeat this question. Thanks, and sorry if it is is bit inconvenient and repeating things. I am just trying to make the questions easier to follow. </blockquote>
Riksoft 0 izisombululo 13 izimpendulo
Kuphostiwe

In my case smooth scrolling or not the difference is nil: it's so slow that I can't notice the difference. There is a chasm from v39 and v40. It's like the processor is stuck in an infinite loop, but on the contrary it's doing nothing (command top shows only 10% usage). However not a real problem for me, it's only a spare PC I use just for testing/experiments. However I'll try to force the acceleration out of curiosity.

In my case smooth scrolling or not the difference is nil: it's so slow that I can't notice the difference. There is a chasm from v39 and v40. It's like the processor is stuck in an infinite loop, but on the contrary it's doing nothing (command top shows only 10% usage). However not a real problem for me, it's only a spare PC I use just for testing/experiments. However I'll try to force the acceleration out of curiosity.
Krow 0 izisombululo 9 izimpendulo
Kuphostiwe

Since we are on the topic of jerky scrolling, I found this interesting guide on Arch wiki - https://wiki.archlinux.org/index.php/Firefox_tweaks#Jerky_or_choppy_scrolling

I did the steps (except one, for which the option is obsolete) and its pretty AMAZING! This improves NON-smooth scrolling in FF considerably!!

WARNING!! This has not been tested on windows!! Use at your own risk!

Since we are on the topic of jerky scrolling, I found this interesting guide on Arch wiki - https://wiki.archlinux.org/index.php/Firefox_tweaks#Jerky_or_choppy_scrolling I did the steps (except one, for which the option is obsolete) and its pretty AMAZING! This improves NON-smooth scrolling in FF considerably!!''' '''WARNING!!''' This has not been tested on windows!! Use at your own risk!

Okulungisiwe ngu Krow

John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

Hi again Rik

Riksoft said

In my case smooth scrolling or not the difference is nil: it's so slow that I can't notice the difference. ... (command top shows only 10% usage). However not a real problem for me, it's only a spare PC I use just for testing/experiments. However I'll try to force the acceleration out of curiosity.

It's worth remembering this thread is about current Releases (Fx43 in OP Fx45 now) on Windows. I think we are both aware Linux* users may see things differently from the OP. (OMTC was rolled out earlier on Windows)

*

Windows should do better than Linux ! Not only did Windows get the omtc procedure enabled earlier.
There is also not the complication of needing to consider ESR or distro based builds. However there is the downside that the average Firefox user will not test pre-release builds. Also let's hope FlashPlayer related issues have already been ruled out first of all.


ascanio1 Hi, I am Trying to keep you in the discussion loop of your own question thread! command top is a Linux nerd's text equivalent of part of your Task Manager. OMTC is another nerdy term. It relates to the rather complicated method Firefox uses when trying to display things whilst still juggling other tasks.

Hi again '''Rik''' ''Riksoft [[#answer-854400|said]]'' <blockquote> In my case smooth scrolling or not the difference is nil: it's so slow that I can't notice the difference. ... (command top shows only 10% usage). However not a real problem for me, it's only a spare PC I use just for testing/experiments. However I'll try to force the acceleration out of curiosity. </blockquote> It's worth remembering this thread is about current Releases (Fx43 in OP Fx45 now) on '''Windows'''. I think we are both aware Linux* users may see things differently from the OP. (OMTC was rolled out earlier on Windows) * <sup>'''Windows''' should do better than '''Linux !''' Not only did Windows get the omtc procedure enabled earlier. <br> There is also not the complication of needing to consider ESR or distro based builds. However there is the downside that the average Firefox user will not test pre-release builds. Also let's hope FlashPlayer related issues have already been ruled out first of all. ------ '''ascanio1''' Hi, I am Trying to keep you in the discussion loop of your own question thread! ''command top'' is a Linux nerd's text equivalent of part of your Task Manager. OMTC is another nerdy term. It relates to the rather complicated method Firefox uses when trying to display things whilst still juggling other tasks.
John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

Krow said

Since we are on the topic of jerky scrolling, I found this interesting guide on Arch wiki - https://wiki.archlinux.org/index.php/Firefox_tweaks#Jerky_or_choppy_scrolling I did the steps (except one, for which the option is obsolete) and its pretty AMAZING! This improves NON-smooth scrolling in FF considerably!!

Hi Krow, We usually recommend Firefox users stick to the standard settings, unless you or someone else are able to provide a good reason why that is incorrect. In which case we will consider changing our advice; and if necessary, even the default settings.

If you do wish to suggest that it would be best to start a new thread, and also to test out whether any such suggestion also applies to Windows users ? (This question thread is about Windows ! )

''Krow [[#answer-854479|said]]'' <blockquote> Since we are on the topic of jerky scrolling, I found this interesting guide on Arch wiki - https://wiki.archlinux.org/index.php/Firefox_tweaks#Jerky_or_choppy_scrolling I did the steps (except one, for which the option is obsolete) and its pretty AMAZING! This improves NON-smooth scrolling in FF considerably!! </blockquote> Hi Krow, We usually recommend Firefox users stick to the standard settings, unless you or someone else are able to provide a good reason why that is incorrect. In which case we will consider changing our advice; and if necessary, even the default settings. If you do wish to suggest that it would be best to start a new thread, and also to test out whether any such suggestion also applies to Windows users ? (This question thread is about Windows ! )
Krow 0 izisombululo 9 izimpendulo
Kuphostiwe

John99 said

If you do wish to suggest that it would be best to start a new thread, and also to test out whether any such suggestion also applies to Windows users ? (This question thread is about Windows ! )

Hey John!

You are right! I apologize - got carried away there. Also forgot to test those settings on windows. Will give it a go on windows and post my feed back. Mean while I will put a warning on the initial post.

Thanks for suggestion regarding opening a separate thread. But perhaps it will be better to wait for the release of FF 46 and see what scrolling improvement it will bring.

''John99 [[#answer-854562|said]]'' <blockquote> If you do wish to suggest that it would be best to start a new thread, and also to test out whether any such suggestion also applies to Windows users ? (This question thread is about Windows ! ) </blockquote> Hey John! You are right! I apologize - got carried away there. Also forgot to test those settings on windows. Will give it a go on windows and post my feed back. Mean while I will put a warning on the initial post. Thanks for suggestion regarding opening a separate thread. But perhaps it will be better to wait for the release of FF 46 and see what scrolling improvement it will bring.
John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

Hey Krow!

Thanks for suggestion regarding opening a separate thread.
But perhaps it will be better to wait for the release of FF 46 
and see what scrolling improvement it will bring.

No need to wait !

I am certainly not trying to stop any discussion that will help with the problem raised. Our guidelines suggest keeping each thread to single problem & I generally agree that works best. It is also easy to cross link threads, I would even encourage that whenever it is applicable.

If you have found a true and reproducible bug it is something that will need a formal bug filed for. Reporting such a matter here is not sufficient HOWEVER this may be a useful place to discuss such matters. We will try to help you. If it helps we will try to advise you on whether it is necessary or applicable to file a bug. If it is easier and we can understand & see the problem we will either take care of filing the bug ourselves or help you to do so.

I said no need to wait. You do not need to wait for the Fx46 Release. You can go one better and try right now with Fx47, because it is on a pre release channel. You may download and use that right now as an additional Firefox browser with its own profile. That does not affect your current Firefox browser. (Its even possible to run them both at the same time side by side.)

Hey Krow! Thanks for suggestion regarding opening a separate thread. But perhaps it will be better to wait for the release of FF 46 and see what scrolling improvement it will bring. No need to wait ! I am certainly not trying to stop any discussion that will help with the problem raised. Our guidelines suggest keeping each thread to single problem & I generally agree that works best. It is also easy to cross link threads, I would even encourage that whenever it is applicable. <sub>If you have found a true and reproducible bug it is something that will need a formal bug filed for. Reporting such a matter here is not sufficient HOWEVER this may be a useful place to discuss such matters. We will try to help you. If it helps we will try to advise you on whether it is necessary or applicable to file a bug. '''If''' it is easier and we can understand & see the problem we will either take care of filing the bug ourselves or help you to do so. </sub> I said no need to wait. You do not need to wait for the Fx46 Release. You can go one better and try right now with Fx47, because it is on a pre release channel. You may download and use that right now as an additional Firefox browser with its own profile. That does not affect your current Firefox browser. (Its even possible to run them both at the same time side by side.) * Download https://www.mozilla.org/firefox/channel/#developer * Features & info <s>https://www.mozilla.orgfirefox/developer/ </s><br>https://www.mozilla.org/firefox/developer/

Okulungisiwe ngu John99

Umnikazi wombuzo

Krow said

@ascanio1: Do you use smooth scrolling? If yes, read on - Important!
  1. The "solution_2" might work but also might not. Since it depends on the type of hardware you have. And even if it works, in my experience it is still a bit laggy. So I suggest you use the first option.
  2. Also Firefox will be issuing a fix for the lagging scroll in v46, see here.
So again, you can just disable the smooth scroll (solution_1) for now and enable it after the release of version 46 (released in April). SOLUTION 1 Disable smooth scrolling -
  • Preferences -> Advanced -> Use smooth scrolling (uncheck the check-box).
  • You can also enable Use hardware acceleration when available now (as this has no effect on normal scroll).
SOLUTION 2 If you like smooth scrolling and dont want to disable it, first check if your Firefox windows are accelerated -
  • press <Alt>,
  • choose from the menu: Help -> Troubleshooting Information. Find the following - GPU Accelerated Windows (see attached image).
The "GPU Accelerated Windows" will show either "0/1 ****" or "1/1 ****". The first one means that acceleration is disabled. You have to update your GPU drivers to the latest version to enable this.
  • Use this guide to do so.
  • Then enable Use hardware acceleration when available option if you disabled it (restart the browser after this).
  • Check again the "GPU Accelerated Windows". It should now show "1/1 ****"
Hope this helps! If you run into trouble dont hesitate to ask.

Hello Krow,

First of all THANK YOU for the time and effort to try to help: I really do appreciate it.

I tried to follow the instructions but got rubber walled as usual... Intel update tool found 3 updates necessary: chipset (did not install) wifi (installed but failed as I need to hand delete the previous - I'm too scared to do this) bluetooth (successful)

I also verified the other stuff and my FF: "GPU #2 Active false GPU Accelerated Windows 0/1 Basic (OMTC) Blocked for your graphics driver version mismatch between registry and DLL."

How can I move forward from here as I cannot update the intel drivers? By the way, I also run an AMD Radeon driver detector app and the result was that I don't have any AMD graphic card on my laptop. Sony Vaio VPCSA

Again thanks for the help but... still nothing!

''Krow [[#answer-854298|said]]'' <blockquote> @ascanio1: Do you use smooth scrolling? If yes, read on - '''Important!''' # The "solution_2" might work but also might not. Since it depends on the type of hardware you have. And even if it works, in my experience it is still a bit laggy. '''So I suggest you use the first option.''' # Also Firefox will be issuing a fix for the lagging scroll in v46, [https://hacks.mozilla.org/2016/02/smoother-scrolling-in-firefox-46-with-apz/ see here]. So again, you can just disable the smooth scroll (solution_1) for now and enable it after the release of version 46 (released in April). '''SOLUTION 1''' Disable smooth scrolling - *''' Preferences -> Advanced -> Use smooth scrolling''' (uncheck the check-box). * You can also enable '''Use hardware acceleration when available''' now (as this has no effect on normal scroll). '''SOLUTION 2''' If you like smooth scrolling and dont want to disable it, first check if your Firefox windows are accelerated - * press '''<Alt>''', * choose from the menu: '''Help -> Troubleshooting Information'''. Find the following - '''GPU Accelerated Windows''' (see attached image). The "'''GPU Accelerated Windows'''" will show either "'''0/1 ****'''" or "'''1/1 ****'''". The first one means that acceleration is disabled. You have to update your GPU drivers to the latest version to enable this. * Use [https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration#w_search-for-and-install-new-graphics-drivers this guide] to do so. * Then enable '''Use hardware acceleration when available''' option if you disabled it (restart the browser after this). * Check again the "'''GPU Accelerated Windows'''". It should now show "'''1/1 ****'''" Hope this helps! If you run into trouble dont hesitate to ask. </blockquote> Hello Krow, First of all THANK YOU for the time and effort to try to help: I really do appreciate it. I tried to follow the instructions but got rubber walled as usual... Intel update tool found 3 updates necessary: chipset (did not install) wifi (installed but failed as I need to hand delete the previous - I'm too scared to do this) bluetooth (successful) I also verified the other stuff and my FF: "GPU #2 Active false GPU Accelerated Windows 0/1 Basic (OMTC) Blocked for your graphics driver version mismatch between registry and DLL." How can I move forward from here as I cannot update the intel drivers? By the way, I also run an AMD Radeon driver detector app and the result was that I don't have any AMD graphic card on my laptop. Sony Vaio VPCSA Again thanks for the help but... still nothing!

Umnikazi wombuzo

Guys,

I am really grateful to all for the help offered and I don't want you to misunderstand me but I'm getting super confused here. I'm a very non proficient user of computers and I am struggling to follow: I really need to solve this issue as I hate IE and I don't want to have to revert to it, so I need to focus with attention on your advice. It would really help if you could use simple language, without jargon and without collateral and accessory advice. Krow's advice I could barely follow as it required opening other sites, downloading stuff, installing stuff, etc etc... but I did my best to follow...

Guys, I am really grateful to all for the help offered and I don't want you to misunderstand me but I'm getting super confused here. I'm a very non proficient user of computers and I am struggling to follow: I really need to solve this issue as I '''''hate''''' IE and I don't want to have to revert to it, so I need to focus with attention on your advice. It would really help if you could use simple language, without jargon and without collateral and accessory advice. Krow's advice I could '''''barely''''' follow as it required opening other sites, downloading stuff, installing stuff, etc etc... but I did my best to follow...

Umnikazi wombuzo

John99 said

Continuing from another thread (Rik's Scroll very slow on v.40 and very fast on v.39 /questions/1112023 ascanio1 If you would like to attempt to use Windows own safemode, and try to describe the problem again, then s you still have problems we will continue trying to help you. Please see Thanks John
ascanio1 Ahh, Sorry. I noticed two questions against your name, but somehow thought one related to this thread when it was in fact your own question thread, but with a few other people in it. Ok so it is best to try to stick to that thread. Please try starting in Windows safemode as was suggested. Note that is fairly easy usually just needing you to press the F8 key about twice a second as you try to boot the computer. It is not in itself anything risky, or permanent it is just a troubleshooting step that helps us rule out (or in ) certain issues you my have with a computer. Also more detail of the problem.
  • How bad is it, what do you mean by not smooth or jerky. I it freezing up or unable to move for a fraction of a second, or stopping for a few seconds.
  • Is it noticeable on all sites, nearly all sites or only on a few, such as ones with a lot of pictures or very long pages.
  • Have you tried to look at CPU and Memory use while you have this problem ?
  • Have you tried with just Firefox open on you computer,an with only a single tab open on Firefox.
Please actually answer this in the other thread, where I will repeat this question. Thanks, and sorry if it is is bit inconvenient and repeating things. I am just trying to make the questions easier to follow.

@ John99,

  • How bad is it, what do you mean by not smooth or jerky. I it freezing up or unable to move for a fraction of a second, or stopping for a few seconds.

It does NOT freeze. It takes a few seconds to scroll and then it does not stop where I want it (probably because I hit the key repeatedly while it was not moving).


  • Is it noticeable on all sites, nearly all sites or only on a few, such as ones with a lot of pictures or very long pages.

It happens when I open many tabs. It happens much much much more if these website tabs are eBay, Amazon and similar shopping sites.


  • Have you tried to look at CPU and Memory use while you have this problem ?

No. I will do and revert.


  • Have you tried with just Firefox open on you computer,an with only a single tab open on Firefox.

Yes. scrolling is ok.

Re: Windows in safe mode. I do NOT experience the same problem with IE and Chrome. Do you still want me to try with Windows in safe mode? I am not a technician so I may say something silly here but logic would want that if it were a Win problem then also other software would display the same issues. Probably FF is not compatible with Win but that would be a general issue for all users, not only for me. Apologies if I made stupid assumptions. As I said I'm not computer savvy at all...

:-(

OT: Anyway, thank you for devoting your time and expertise to my problem and thank you for explaining what Riksoft meant. I really appreciate this community and how everyone is trying to help and I feel guilty that I am unable to appreciate the technicalities that you are all offering. I wish there were similar people in the MS world... I have a problem with Outlook and the MS forum is so full of arrogance, dogma and general boorishness that I have given up... can you advise a few alternatives to MS Outlook (if you're allowed to do that here, I don't want to start a legal quarrel from MS against the Mozilla Forum)?

''John99 [[#answer-854313|said]]'' <blockquote> Continuing from another thread (Rik's ''Scroll very slow on v.40 and very fast on v.39'' [/questions/1112023] '''ascanio1''' If you would like to attempt to use Windows own safemode, and try to describe the problem again, then s you still have problems we will continue trying to help you. Please see * ''How to Start Windows 10 in Safe Mode'' http://www.tenforums.com/tutorials/2304-safe-mode-start-windows-10-a.html Thanks John <blockquote> ascanio1 Ahh, Sorry. I noticed two questions against your name, but somehow thought one related to this thread when it was in fact your own question thread, but with a few other people in it. Ok so it is best to try to stick to that thread. Please try starting in Windows safemode as was suggested. Note that is fairly easy usually just needing you to press the F8 key about twice a second as you try to boot the computer. It is not in itself anything risky, or permanent it is just a troubleshooting step that helps us rule out (or in ) certain issues you my have with a computer. Also more detail of the problem. * How bad is it, what do you mean by not smooth or jerky. I it freezing up or unable to move for a fraction of a second, or stopping for a few seconds. * Is it noticeable on all sites, nearly all sites or only on a few, such as ones with a lot of pictures or very long pages. * Have you tried to look at CPU and Memory use while you have this problem ? * Have you tried with just Firefox open on you computer,an with only a single tab open on Firefox. Please actually answer this in the other thread, where I will repeat this question. Thanks, and sorry if it is is bit inconvenient and repeating things. I am just trying to make the questions easier to follow. </blockquote> </blockquote> ---------------------------------------- @ John99, * How bad is it, what do you mean by not smooth or jerky. I it freezing up or unable to move for a fraction of a second, or stopping for a few seconds. It does NOT freeze. It takes a few seconds to scroll and then it does not stop where I want it (probably because I hit the key repeatedly while it was not moving). * Is it noticeable on all sites, nearly all sites or only on a few, such as ones with a lot of pictures or very long pages. It happens when I open many tabs. It happens much much much more if these website tabs are eBay, Amazon and similar shopping sites. * Have you tried to look at CPU and Memory use while you have this problem ? No. I will do and revert. * Have you tried with just Firefox open on you computer,an with only a single tab open on Firefox. Yes. scrolling is ok. Re: Windows in safe mode. I do NOT experience the same problem with IE and Chrome. Do you still want me to try with Windows in safe mode? I am not a technician so I may say something silly here but logic would want that if it were a Win problem then also other software would display the same issues. Probably FF is not compatible with Win but that would be a general issue for all users, not only for me. Apologies if I made stupid assumptions. As I said I'm not computer savvy at all... :-( OT: Anyway, thank you for devoting your time and expertise to my problem and thank you for explaining what Riksoft meant. I really appreciate this community and how everyone is trying to help and I feel guilty that I am unable to appreciate the technicalities that you are all offering. I wish there were similar people in the MS world... I have a problem with Outlook and the MS forum is so full of arrogance, dogma and general boorishness that I have given up... can you advise a few alternatives to MS Outlook (if you're allowed to do that here, I don't want to start a legal quarrel from MS against the Mozilla Forum)?

Okulungisiwe ngu ascanio1

John99 971 izisombululo 13138 izimpendulo
Kuphostiwe

Hi again ascanio1

It may be worth trying Windows safe mode still. It is relatively easy to do that and it may give us some clues as to what the problem is or is not.

From your additional description it seems you do not have a problem as bad as the type Rik describes.

I am also wondering from that description if it may be mainly a case of your computer struggling to cope with the handling of many open tabs in Firefox, especially if they are complex and graphics heavy pages that you are looking at.

I've just noticed I gave a link about windows safe mode in Windows 10 but you are using Windows 7 so this link is better

  • Have you tried Firefox with just a handful of tabs open ?
    • Do matters improve then ?

If they do this pair of articles may help you

The task manager may be opened by right-clicking the taskbar, on the bottom edge of your screen, and then clicking Start Task Manager. Or by using the keyboard shortcut Ctrl+Shift+Esc. See also

What you are looking for is does the CPU use graph show very high use of the CPU over 75% when you have problems, or are you using a lot of memory (Try to work out if the page file is in use - that slows things down).

Hi again ascanio1 It may be worth trying Windows safe mode still. It is relatively easy to do that and it may give us some clues as to what the problem is or is not. From your additional description it seems you do not have a problem as bad as the type Rik describes. I am also wondering from that description if it may be mainly a case of your computer struggling to cope with the handling of many open tabs in Firefox, especially if they are complex and graphics heavy pages that you are looking at. I've just noticed I gave a link about windows safe mode in Windows 10 but you are using Windows 7 so this link is better * ''Starting your computer in safe mode'' <br> http://windows.microsoft.com/en-gb/windows/start-computer-safe-mode#start-computer-safe-mode=windows-7 * Have you tried Firefox with just a handful of tabs open ? ** Do matters improve then ? If they do this pair of articles may help you * [[Firefox uses too many CPU resources - How to fix]] * [[Firefox uses too much memory (RAM) - How to fix]] The task manager may be opened by right-clicking the taskbar, on the bottom edge of your screen, and then clicking Start Task Manager. Or by using the keyboard shortcut Ctrl+Shift+Esc. See also * https://en.wikipedia.org/wiki/Task_Manager_%28Windows%29#User_interface * Bleeping Computer's tutorial '''''How to use the Windows Task Manager''''' http://www.bleepingcomputer.com/tutorials/how-to-use-the-windows-task-manager/#performance What you are looking for is does the CPU use graph show very high use of the CPU over 75% when you have problems, or are you using a lot of memory (Try to work out if the ''page file'' is in use - that slows things down).
Krow 0 izisombululo 9 izimpendulo
Kuphostiwe

ascanio1 said

Again thanks for the help but... still nothing!

Happy to help!

I have seen the replies that you posted to Johns questions. What you are describing (lagging/jerkiness of the tab used, when other tabs are loading) has been a long problem for Firefox. "GPU accelerated windows" can help but not completely. BUT this problem will be resolved with the arrival of e10s. Which should happen in a couple of months. (I have installed Firefox 48 alpha to test this and it actually does perform way better).

Although it is strange that scrolling lags when amazon and ebay are just open in the background. Try these things first. It is not a solution, but might lessen the lagging -

  1. Install an ad-blocker addon (if you have not already). This is very important since the sheer number of adverts can bog down Firefox, specially when not GPU accelerated. I suggest uBlock Origin. But use only 1 adblocker, more than one can cause problems.
  2. Disable flash - Flash is pretty laggy and should be already set to "ask to activate" by default. Just to be sure, to the Addons tab:
    1. Press Ctrl+Shift+A on your keyboard -> choose Plugins and set (shockwave or adobe) flash to Never activate (you can re-enable it later if necessary).
    2. Also, disable (set to "Never activate") all the other plugins - for testing purposes.
  3. Now clear all "Cache" and "Offline website data". Use this guide. And restart the browser.

Check now how is the scrolling working.


We should also get hardware acceleration up and running, if it is possible. For that I need hardware info of your PC/Laptop so I can suggest drivers to install/reinstall. Follow these steps -

  1. Download a program called HWiNFO. It will give the necessary information about your PC. Use this link - http://www.fosshub.com/HWiNFO.html/hw32_520.zip
  2. Extract it, and start it. A small window will pop-up - press Run.
  3. You will see something like this - see image 1 attached.
  4. Close all the windows except that last one - see image 2.
  5. In this last window, press save report - see image 2.
  6. A dialog box will pop-up, follow the steps on - image 3.
  7. A text report of your system will popup.

You can either copy-paste its contents here or attach a screen shot.

''ascanio1 [[#answer-854912|said]]'' <blockquote> Again thanks for the help but... still nothing! </blockquote> Happy to help! I have seen the replies that you posted to Johns questions. What you are describing '''(lagging/jerkiness of the tab used, when other tabs are loading)''' has been a long problem for Firefox. "GPU accelerated windows" can help but not completely. '''BUT''' this problem will be resolved with the arrival of [https://wiki.mozilla.org/Electrolysis e10s]. Which should happen in a couple of months. (I have installed Firefox 48 alpha to test this and it actually does perform way better). Although it is strange that scrolling lags when amazon and ebay are just open in the background. Try these things first. It is not a solution, but might lessen the lagging - # Install an ad-blocker addon (if you have not already). This is very important since the sheer number of adverts can bog down Firefox, specially when not GPU accelerated. I suggest [https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/ uBlock Origin]. '''But use only 1 adblocker, more than one can cause problems.''' # Disable flash - Flash is pretty laggy and should be already set to "ask to activate" by default. Just to be sure, to the Addons tab: ## Press Ctrl+Shift+A on your keyboard -> choose Plugins and set (shockwave or adobe) flash to '''Never activate''' (you can re-enable it later if necessary). ## Also, disable (set to "Never activate") all the other plugins - for testing purposes. # Now clear all "Cache" and "Offline website data". Use [http://www.wikihow.com/Clear-Cookies-and-Cache-in-Firefox this] guide. And restart the browser. Check now how is the scrolling working. We should also get hardware acceleration up and running, if it is possible. For that I need hardware info of your PC/Laptop so I can suggest drivers to install/reinstall. Follow these steps - # Download a program called HWiNFO. It will give the necessary information about your PC. Use this link - http://www.fosshub.com/HWiNFO.html/hw32_520.zip # Extract it, and start it. A small window will pop-up - press Run. # You will see something like this - see image 1 attached. # Close all the windows except that last one - see image 2. # In this last window, press save report - see image 2. # A dialog box will pop-up, follow the steps on - image 3. # A text report of your system will popup. You can either copy-paste its contents here or attach a screen shot.

Okulungisiwe ngu Krow

Umnikazi wombuzo

Dear Krow,

Thank you for your time, for lending me your skills and for being straightforward about the issue.

I apologize that it tales me so long to reply but I have to do this in the clips of time that I can put aside as I'm pretty busy in these months.

I installed the ad blocker and flash only on demand but there has been no noticeable improvement. I also run the software that you suggested. I attach the image.

Bthe way, while trying to reinstall the video drivers to fix the Hardware acceleration it caused a malfunction in my bluetooth: other devices can see my laptop but the service works only one way: I can pair keyboard and phones but. I can only send picture from PC to Android (4.4.2) but not the otherway around and the keyboard does not work. Can you tell me which driver to install to fix the bluetooth and where to find it?

Tommaso

Dear Krow, Thank you for your time, for lending me your skills and for being straightforward about the issue. I apologize that it tales me so long to reply but I have to do this in the clips of time that I can put aside as I'm pretty busy in these months. I installed the ad blocker and flash only on demand but there has been no noticeable improvement. I also run the software that you suggested. I attach the image. Bthe way, while trying to reinstall the video drivers to fix the Hardware acceleration it caused a malfunction in my bluetooth: other devices can see my laptop but the service works only one way: I can pair keyboard and phones but. I can only send picture from PC to Android (4.4.2) but not the otherway around and the keyboard does not work. Can you tell me which driver to install to fix the bluetooth and where to find it? Tommaso

Okulungisiwe ngu ascanio1