X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Have you forgotten that your users are human and have basic human rights?

Kuphostiwe

You have disabled both my antivirus and my VPN addons and denied me the right to make my own choice with your latest update. You are insane. You have no right to to this. All your Orwellian double-talk about customer security does not hide the fact that you have massively over-stepped your rights and have become just another case of psychological rape that your users have to live with. Neither you, your any other person has a right to deny me my right of choice. You may warn me of the possible consequences of your actions, but you will never have the right to take away my freedom. Your arrogance is insufferable, You have forgotten all the basic laws of human decency and become an aggressive, thoughtless bully. I shall be uninstalling Firefox, and praying that the rest of the world does the same. Over the last few years you have gone from being the browser intelligent people love to use to the browser intelligent people wish they had never heard of.

You have disabled both my antivirus and my VPN addons and denied me the right to make my own choice with your latest update. You are insane. You have no right to to this. All your Orwellian double-talk about customer security does not hide the fact that you have massively over-stepped your rights and have become just another case of psychological rape that your users have to live with. Neither you, your any other person has a right to deny me my right of choice. You may warn me of the possible consequences of your actions, but you will never have the right to take away my freedom. Your arrogance is insufferable, You have forgotten all the basic laws of human decency and become an aggressive, thoughtless bully. I shall be uninstalling Firefox, and praying that the rest of the world does the same. Over the last few years you have gone from being the browser intelligent people love to use to the browser intelligent people wish they had never heard of.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPTXSSO Dynamic Link Library
  • NPWLPG
  • QQ2011
  • Shockwave Flash 20.0 r0
  • Unity Player 4.6.1f1
  • VLC media player Web Plugin

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

Eminye Imininingwane

Andrew
  • Moderator
325 izisombululo 4094 izimpendulo
Kuphostiwe

Add-ons are disabled automatically (meaning nobody did it on purpose, but rather for safety sake) if they are no longer compatible with the newer version of Firefox. You should contact the developers of the add-on to ask them why they aren't up to date with providing update to it's users or you can also check to see if a newer version of the add-on is available. Placing the blame on the browser just because it does not work, isn't the best way to be doing things. No humans rights have been taken away, nor have they been violated. User privacy, accessibility and customization is at the forefront of Mozilla.

Add-ons are disabled automatically (meaning nobody did it on purpose, but rather for safety sake) if they are no longer compatible with the newer version of Firefox. You should contact the developers of the add-on to ask them why they aren't up to date with providing update to it's users or you can also check to see if a newer version of the add-on is available. Placing the blame on the browser just because it does not work, isn't the best way to be doing things. No humans rights have been taken away, nor have they been violated. User privacy, accessibility and customization is at the forefront of Mozilla.

Umnikazi wombuzo

You seem to have things back to front, but maybe that's because the developers at Mozilla are currently suffering from a God complex. It is not up to the developers of the add ons to make sure they stay compatible with your updates, this is illogical, immoral and incredibly arrogant. My add ons were working fine. As you decided to update your software, it is your responsibility, by all logic and rationality, to ensure your customers are not inconvenienced by your updates. This means you have a moral and ethical responsibility to ensure my existing add ons work with your update, you are the one initiating the update, you are the one who has the responsibility to ensure I do not suffer because of this update. The fact that Mozilla thinks every developer in the world should jump, every time they say jump, and sit every time they say sit just shows how ignorant and arrogant you are.

To claim it is necessary for security is pure deception, to say it is inevitable because the add on developers haven't jumped quickly enough for you is just insulting. You write the code, you ensure that my add ons don't work anymore - all your lies and self-deception do not hide the fact that you (Mozilla) made a decision to deliberately deny me the right to have my life continue functioning. You have bullied me, every other user and every developer into believing we all must do as you say or be penalized, unnecessarily. I think it is time you apologized to the world for your rape of our minds and our rights. I shall pursue this in the courts if I can as you are so obviously lost in your own illusions you cannot see the truth of your violent, aggressive assault on all your users and on every browser add on developer world wide. Making puerile statements like "no user rights have been taken away" in the hope we will be stupid enough to believe them won't work. It is time you showed your customers some respect, instead of twisting the truth, and the ideas involved, to make your actions reasonable when they are obviously not so.

You seem to have things back to front, but maybe that's because the developers at Mozilla are currently suffering from a God complex. It is not up to the developers of the add ons to make sure they stay compatible with your updates, this is illogical, immoral and incredibly arrogant. My add ons were working fine. As you decided to update your software, it is your responsibility, by all logic and rationality, to ensure your customers are not inconvenienced by your updates. This means you have a moral and ethical responsibility to ensure my existing add ons work with your update, you are the one initiating the update, you are the one who has the responsibility to ensure I do not suffer because of this update. The fact that Mozilla thinks every developer in the world should jump, every time they say jump, and sit every time they say sit just shows how ignorant and arrogant you are. To claim it is necessary for security is pure deception, to say it is inevitable because the add on developers haven't jumped quickly enough for you is just insulting. You write the code, you ensure that my add ons don't work anymore - all your lies and self-deception do not hide the fact that you (Mozilla) made a decision to deliberately deny me the right to have my life continue functioning. You have bullied me, every other user and every developer into believing we all must do as you say or be penalized, unnecessarily. I think it is time you apologized to the world for your rape of our minds and our rights. I shall pursue this in the courts if I can as you are so obviously lost in your own illusions you cannot see the truth of your violent, aggressive assault on all your users and on every browser add on developer world wide. Making puerile statements like "no user rights have been taken away" in the hope we will be stupid enough to believe them won't work. It is time you showed your customers some respect, instead of twisting the truth, and the ideas involved, to make your actions reasonable when they are obviously not so.
philipp
  • Top 25 Contributor
  • Moderator
5342 izisombululo 23598 izimpendulo
Kuphostiwe

i'm closing this thread since i see no particular request for support. please note that the people answering here in the support forum are generally volunteers and normal users like you. the proper place to leave feedback to mozilla is through input.mozilla.org/feedback and not through this forum...

i'm closing this thread since i see no particular request for support. please note that the people answering here in the support forum are generally volunteers and normal users like you. the proper place to leave feedback to mozilla is through input.mozilla.org/feedback and not through this forum...
AliceWyman
  • Moderator
240 izisombululo 2607 izimpendulo
Kuphostiwe

A little more information, in case it's helpful:

Required add-on signing for extensions is new in Firefox version 43. Back in February, it was announced that, for a safer add-on experience, all extensions will have to be verified and signed by Mozilla before they can be installed.

Unsigned extensions that are already installed will be automatically disabled. For more information, see Add-on signing in Firefox.

Extensions hosted on addons.mozilla.org are automatically signed. If an extension you wish to use is distributed by a third-party, it must be signed. Please ask the add-on developer or vendor if an updated and signed version of the add-on is available.

This signing requirement is mandatory in regular release and beta versions of Firefox. For testing purposes, it will still be possible to configure Firefox Developer Edition and Nightly versions to run unsigned extensions. For details, please see https://wiki.mozilla.org/Addons/Extension_Signing.

You can visit the mozilla.addons.user-experience discussion group to further discuss this or to see what others are posting.

A little more information, in case it's helpful: Required add-on signing for extensions is new in Firefox version 43. Back in February, [https://blog.mozilla.org/addons/2015/02/10/extension-signing-safer-experience/ it was announced] that, for a safer add-on experience, all extensions will have to be verified and signed by Mozilla before they can be installed. Unsigned extensions that are already installed will be automatically disabled. For more information, see [[Add-on signing in Firefox]]. Extensions hosted on addons.mozilla.org are automatically signed. If an extension you wish to use is distributed by a third-party, it must be signed. Please ask the add-on developer or vendor if an updated and signed version of the add-on is available. This signing requirement is mandatory in regular release and beta versions of Firefox. For testing purposes, it will still be possible to configure Firefox Developer Edition and Nightly versions to run unsigned extensions. For details, please see [https://wiki.mozilla.org/Addons/Extension_Signing]. You can visit the [https://groups.google.com/forum/#!forum/mozilla.addons.user-experience mozilla.addons.user-experience] discussion group to further discuss this or to see what others are posting.