X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I can not access google.com and some other https sites but not all.

Kuphostiwe

Yesterday I installed FF 43.0 - 64bit. I did as clean install as I could, uninstalled old version, and deleted from HDD every "mozilla" and "firefox" directory I could find. Since then, I am unable to access next sites (I believe list is not complete): https://www.google.com/ https://www.facebook.com/ https://www.google.com/maps https://www.google.rs/?gws_rd=ssl

Error msg is alwaays the same: "You have asked Firefox to connect securely to www.google.com, but we can't confirm that your connection is secure. Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. What Should I Do? If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue. This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate. Technical details: www.google.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)"

Sites that I can normaly access with this FF are: https://support.mozilla.org/en-US/ https://translate.google.com/ https://mail.google.com/

All other browsers can access all sites without problems.

Yesterday I installed FF 43.0 - 64bit. I did as clean install as I could, uninstalled old version, and deleted from HDD every "mozilla" and "firefox" directory I could find. Since then, I am unable to access next sites (I believe list is not complete): https://www.google.com/ https://www.facebook.com/ https://www.google.com/maps https://www.google.rs/?gws_rd=ssl Error msg is alwaays the same: "You have asked Firefox to connect securely to www.google.com, but we can't confirm that your connection is secure. Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. What Should I Do? If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue. This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate. Technical details: www.google.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)" Sites that I can normaly access with this FF are: https://support.mozilla.org/en-US/ https://translate.google.com/ https://mail.google.com/ All other browsers can access all sites without problems.

Isisombululo esikhethiwe

In the last screenshot you can see that the certificate is issued by your Kaspersky security software.

If the certificate is issued by your Kaspersky security software then you have two options:

Funda le mpendulo ngokuhambisana nalesi sihloko 3

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 20.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4254 izisombululo 59583 izimpendulo
Kuphostiwe

There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate.

http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html

https://support.mozilla.org/en-US/kb/server-not-found-connection-problem

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate. http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message '''http://kb.mozillazine.org/Error_loading_websites''' '''This Connection is Untrusted''' is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

Impendulo Ewusizo

Thank you for answer, but this doesnt solve my FF problem. Time and date are quite fine.

I dont think my Kaspersky is problem also, because there are https sites that I can access with FF. Older versions didnt give me this problem with same Kaspersky. I checked, all mozilla and FF instances are green for allowed connection and added to "trusted" apps. I did try to delete cert8.db by instructions from this support forums but no luck. I also cleaned all history, cache and cookies. Didnt help. Never had such problem with FF and I am using it from day 1 and installed/reinstalled it countless times on large number of computers.

Thank you for answer, but this doesnt solve my FF problem. Time and date are quite fine. I dont think my Kaspersky is problem also, because there are https sites that I can access with FF. Older versions didnt give me this problem with same Kaspersky. I checked, all mozilla and FF instances are green for allowed connection and added to "trusted" apps. I did try to delete cert8.db by instructions from this support forums but no luck. I also cleaned all history, cache and cookies. Didnt help. Never had such problem with FF and I am using it from day 1 and installed/reinstalled it countless times on large number of computers.

Okulungisiwe ngu DrStrangeloveSR

FredMcD
  • Top 10 Contributor
4254 izisombululo 59583 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. Is the problem still there? ---------- Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''
cor-el
  • Top 10 Contributor
  • Moderator
17522 izisombululo 158442 izimpendulo
Kuphostiwe

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate: *chrome://pippki/content/exceptionDialog.xul In the location field of this window type or paste the URL of the website. *retrieve the certificate via the "Get certificate" button *click the "View..." button to inspect the certificate in the Certificate Viewer You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

Umnikazi wombuzo

Thank you for answers.

@FredMcD I have tried FF safe mode, nothing changes. Cant afford to try Win safe mode atm as I am @ work (Europe time zone)

@cor-el Please find attached pictures of cert viewers, for google.com and facebook.com (not working and cant "Add Security Exception") and, as a refference, for this site and gmail that are working without any problem. I deleted those numbers as I dont know if it is security risk to show them publicly, if needed will post originals.

What can you conclude out of those? After all it looks like Kaspersky did something but only to few sites, the most popular ones in the world. Also for bing.com and for yahoo. com I was able to "Add Security Exception". Now bing works fine (non secure connection) and yahoo is unusable, page is all messed up, I guess it doesnt load completly.

This defies logic.

Thank you for answers. @FredMcD I have tried FF safe mode, nothing changes. Cant afford to try Win safe mode atm as I am @ work (Europe time zone) @cor-el Please find attached pictures of cert viewers, for google.com and facebook.com (not working and cant "Add Security Exception") and, as a refference, for this site and gmail that are working without any problem. I deleted those numbers as I dont know if it is security risk to show them publicly, if needed will post originals. What can you conclude out of those? After all it looks like Kaspersky did something but only to few sites, the most popular ones in the world. Also for bing.com and for yahoo. com I was able to "Add Security Exception". Now bing works fine (non secure connection) and yahoo is unusable, page is all messed up, I guess it doesnt load completly. This defies logic.

Okulungisiwe ngu DrStrangeloveSR

FredMcD
  • Top 10 Contributor
4254 izisombululo 59583 izimpendulo
Kuphostiwe

I noticed month misspelling on the certificates.

I noticed month misspelling on the certificates.
cor-el
  • Top 10 Contributor
  • Moderator
17522 izisombululo 158442 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

In the last screenshot you can see that the certificate is issued by your Kaspersky security software.

If the certificate is issued by your Kaspersky security software then you have two options:

In the last screenshot you can see that the certificate is issued by your Kaspersky security software. If the certificate is issued by your Kaspersky security software then you have two options: *disable scanning secure connections in Kaspersky *install the Kaspersky root certificate.When prompted set the trust bit to use the certificate to "Trust this CA to identify websites"<br>http://support.kaspersky.com/us/9093#block1<br>http://support.kaspersky.com/us/9927#block1

Umnikazi wombuzo

FredMcD said

I noticed month misspelling on the certificates.

lol, it's not misspelled, it's perfect for my language, also it goes first day then month

''FredMcD [[#answer-819125|said]]'' <blockquote> I noticed month misspelling on the certificates. </blockquote> lol, it's not misspelled, it's perfect for my language, also it goes first day then month

Umnikazi wombuzo

cor-el said

In the last screenshot you can see that the certificate is issued by your Kaspersky security software. If the certificate is issued by your Kaspersky security software then you have two options:

Thanks for suggestion. I just went abroad, will surely try this as soon as I get first chance to use Internet on laptop for more than 5 min. Hopefuly in next day or two.

''cor-el [[#answer-819197|said]]'' <blockquote> In the last screenshot you can see that the certificate is issued by your Kaspersky security software. If the certificate is issued by your Kaspersky security software then you have two options: *disable scanning secure connections in Kaspersky *install the Kaspersky root certificate.When prompted set the trust bit to use the certificate to "Trust this CA to identify websites"<br>http://support.kaspersky.com/us/9093#block1<br>http://support.kaspersky.com/us/9927#block1 </blockquote> Thanks for suggestion. I just went abroad, will surely try this as soon as I get first chance to use Internet on laptop for more than 5 min. Hopefuly in next day or two.
jscher2000
  • Top 10 Contributor
8758 izisombululo 71656 izimpendulo
Kuphostiwe

Did you permanently delete your old profile folder or can you pull it back from the Recycle Bin? Your previous Firefox settings folder contained a cert8.db file set to trust Kaspersky and your new one does not (not yet, anyway). It usually works to drop the old file in place of the new one, but I would exit out of Firefox first to avoid a conflict.

Did you permanently delete your old profile folder or can you pull it back from the Recycle Bin? Your previous Firefox settings folder contained a cert8.db file set to trust Kaspersky and your new one does not (not yet, anyway). It usually works to drop the old file in place of the new one, but I would exit out of Firefox first to avoid a conflict.

Umnikazi wombuzo

jscher2000 said

Did you permanently delete your old profile folder or can you pull it back from the Recycle Bin? Your previous Firefox settings folder contained a cert8.db file set to trust Kaspersky and your new one does not (not yet, anyway). It usually works to drop the old file in place of the new one, but I would exit out of Firefox first to avoid a conflict.

Unfortunately it was shift+del

''jscher2000 [[#answer-819312|said]]'' <blockquote> Did you permanently delete your old profile folder or can you pull it back from the Recycle Bin? Your previous Firefox settings folder contained a cert8.db file set to trust Kaspersky and your new one does not (not yet, anyway). It usually works to drop the old file in place of the new one, but I would exit out of Firefox first to avoid a conflict. </blockquote> Unfortunately it was shift+del

Umnikazi wombuzo

cor-el said

In the last screenshot you can see that the certificate is issued by your Kaspersky security software. If the certificate is issued by your Kaspersky security software then you have two options:

Well, this definitely did the trick. I installed certificate in FF and now google, fb, yahoo work. Thank you for suggestion and help. This was totaly unexpected for me because I havent been changing Kaspersky version for quite some time and previous versions of FF and even Waterfox didnt have isues with it. Also, some google sites like gmail and translade were working without problems. Not sure where this came from. Thank you once again

''cor-el [[#answer-819197|said]]'' <blockquote> In the last screenshot you can see that the certificate is issued by your Kaspersky security software. If the certificate is issued by your Kaspersky security software then you have two options: *disable scanning secure connections in Kaspersky *install the Kaspersky root certificate.When prompted set the trust bit to use the certificate to "Trust this CA to identify websites"<br>http://support.kaspersky.com/us/9093#block1<br>http://support.kaspersky.com/us/9927#block1 </blockquote> Well, this definitely did the trick. I installed certificate in FF and now google, fb, yahoo work. Thank you for suggestion and help. This was totaly unexpected for me because I havent been changing Kaspersky version for quite some time and previous versions of FF and even Waterfox didnt have isues with it. Also, some google sites like gmail and translade were working without problems. Not sure where this came from. Thank you once again

Okulungisiwe ngu DrStrangeloveSR