Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox will not connect to any website. Chrome and IE work fine.

  • 5 uphendule
  • 4 zinale nkinga
  • 2104 views
  • Igcine ukuphendulwa ngu FredMcD

more options

I've been using Firefox as my primary browser for years with no issues. A couple of days ago for no apparent reason, it will no longer connect to ANY website. The tab indefinitely shows "Connecting..." with the spinning circle. I can use IE and Chrome with no issues. I've double checked the Options -> Advanced -> Connection for proxy settings and tried every option but to no avail. I've also started in Safe Mode and still nothing. Also tried uninstalling and reinstalling several times. I'm on version 42.0

Surely there must be a way to debug this to figure it out.

Isisombululo esikhethiwe

I use a different firewall, so I don't know how the Windows works. I've called the big guys to help you. Good luck.

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first use No Proxy. If there is a problem, then try System Proxy.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

I use Windows firewall and I'm on Win 7. I followed the instructions to remove then re-add Firefox to the list of trusted programs and found some oddities.

I have 3 entries for Firefox: 1- Firefox (C:\Program Files (x86)\Mozilla Firefox) 2- Mozilla Firefox 3- Mozilla Firefox See attached screen shots for these

The Remove button is grayed out for the 1st and 2nd entries and the last one lets me click remove but it does not remove Firefox from the list.

I also turned off the Firewall altogether and that did not have any affect. See screen shot of this as well.

I demo enterprise software for a living and Firefox is my go to browser so I’m desperate to get this fixed. Is there any kind of debug option I can try to determine the issue?

more options

Isisombululo Esikhethiwe

I use a different firewall, so I don't know how the Windows works. I've called the big guys to help you. Good luck.

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first use No Proxy. If there is a problem, then try System Proxy.

more options

SOLVED PROBLEM I tried one more thing that did the trick. After uninstalling Firefox for the 4th time, I finally went to the program directory and local data directories and deleted these directories and thus removed all of the remnants of Firefox. Then I did a fresh install and it worked.

Thank you FredMcD for the help!

Okulungisiwe ngu mmarino77

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.