Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

uninstalled firefox to get rid of yahoo that doesn't have permission to load anything.

  • 2 uphendule
  • 1 inale nkinga
  • 5 views
  • Igcine ukuphendulwa ngu jscher2000

more options

For years I could only use firefox, as IE was unusable. Now, since yahoo hijacks the browser and has no permission to load any sites, I uninstalled firefox since you are now the unusable site. I loaded Windows 10, but I still wonder why you ruined a great product. I tried to change my home page following your instructions, but Yahoo kept hijacking it. Just gave up. Thanks a lot.

All Replies (2)

more options

Hmm, you gave up but you posted here, which seems to call for a reply, so here goes.

The standard install of Firefox (from https://www.mozilla.org/firefox/new) is pre-configured with the built-in Firefox home page and Yahoo as the default search engine. It is trivial to change to your preferred search engine, as described in this article: Change your default search settings in Firefox.

If you find that your Firefox does NOT work that way, you probably have an unwanted extension or configuration file that is modifying your Firefox. To make sure your system is clean and other browsers are not infected, here's my suggested procedure for tracking down and cleaning up bad add-ons, hijackers, and ad injectors. I know it seems long, but it's not that bad.

(1) Open the Windows Control Panel, Uninstall a Program. After the list loads, click the "Installed on" column heading to group the infections, I mean, additions, by date. This can help in smoking out undisclosed bundle items that snuck in with some software you agreed to install. Be suspicious of everything you do not recognize/remember, as malware often uses important or innocent sounding names to discourage you from removing it. Take out as much trash as possible here.

(2) Open Firefox's Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. Bear in mind that all extensions are optional, none come with Firefox, and you can learn more about them by checking their reviews on the Add-ons site.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Next, try restoring your preferred home page and search engine. See:

Do your settings work now?

(3) You can search for remaining issues with the scanning/cleaning tools listed in our support article: Troubleshoot Firefox issues caused by malware. These on-demand scanners are free and take considerable time to run. If they finish quickly and especially if they require payment, you may have a serious infection. I suggest the specialized forums listed in the article in that case.

Success?

If your home page is normal when using the Home button, but you have a continuing problem when using a desktop/taskbar shortcut, you can clean that as follows:

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. If not, go ahead and click the Shortcut tab.

The Target line should not have anything after this part:

  • 64-bit Windows, standard 32-bit Firefox: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
  • 64-bit Windows, test 64-bit Firefox: "C:\Program Files\Mozilla Firefox\firefox.exe"
  • 32-bit Windows: "C:\Program Files\Mozilla Firefox\firefox.exe"

If any URLs are listed after that, clear them out and save your change. To test, you can either:

  • Desktop shortcut: double-click the icon to launch a new window
  • Pinned taskbar icon: right-click the icon, click Mozilla Firefox to launch a new window

If you only get your home page, it worked.

Some users have reported a faster fix for a pinned taskbar item:

  • unpin the current icon
  • go into the Start menu, right-click Mozilla Firefox, then Pin to Taskbar

Hopefully one of those will work for you.

more options

Now... regarding permission to load sites. What is the exact message that you get?

In the absence of more specific information, I'll mention two special issues with Windows 10 that users have reported:

(1) Untrusted connection errors resulting from Firefox not being set up to work with the parental control software Microsoft Family Safety. To test by turning it off, see: http://windows.microsoft.com/en-us/wi.../turn-off-microsoft-family-settings

(2) Non-Microsoft browsers unable to access the internet. In some cases, you need to do a reset to the Windows TCP components. See: After upgrade to window 10, cannot access internet from firefox or chrome.