X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I have 59 tabs open and firefox crashes up to 10 times in a row. Is the crash related to many tabs? Which browser can I use that supports many tabs?

Kuphostiwe

My system is an i5 with 22GB RAM running Ubuntu 15.10

My system is an i5 with 22GB RAM running Ubuntu 15.10

Isisombululo esikhethiwe

No crashes yet after about 7 days. It is safe to say that the bad RAM chip was the cause of my nightmare.

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Linux x86_64; Ubuntu 15.10) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.0 Maxthon/1.0.5.3 Safari/537.36

Eminye Imininingwane

Tyler Downer
  • Top 25 Contributor
  • Moderator
1529 izisombululo 10654 izimpendulo
Kuphostiwe

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste those IDs into the "Post a Reply" box.

Note: If a recent Report ID does not start with bp- click on it to submit the report.

(Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.)

aboutcrashesFx29

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash. #Enter ''about:crashes'' in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below. #Copy the '''5''' most recent Report IDs that start with '''bp-''' and then go back to your forum question and paste those IDs into the "Post a Reply" box. ''' Note:''' If a recent Report ID does not start with '''bp-''' click on it to submit the report. (Please don't take a screenshot of your crashes, just copy and paste the IDs. The below image is just an example of what your Firefox screen should look like.) ;[[Image:aboutcrashesFx29|width=500]] Thank you for your help! More information and further troubleshooting steps can be found in the [[Firefox crashes - Troubleshoot, prevent and get help fixing crashes]] article.

Umnikazi wombuzo

bp-0424b7c8-2268-4cfe-becb-308872151205 bp-6989f94a-2f1e-4286-b5d6-752f52151205 bp-120ee2a2-dc41-4e41-8ce1-b5f722151205 bp-78f2ff5d-a829-4ecc-9978-d3f762151205 bp-6ae45a7c-1c1b-4058-8ee1-246752151205 bp-16c6d220-6d59-4080-9c20-1029f2151205 bp-4b37eeaf-e357-4b06-8418-5834a2151205

bp-0424b7c8-2268-4cfe-becb-308872151205 bp-6989f94a-2f1e-4286-b5d6-752f52151205 bp-120ee2a2-dc41-4e41-8ce1-b5f722151205 bp-78f2ff5d-a829-4ecc-9978-d3f762151205 bp-6ae45a7c-1c1b-4058-8ee1-246752151205 bp-16c6d220-6d59-4080-9c20-1029f2151205 bp-4b37eeaf-e357-4b06-8418-5834a2151205
Carm 6 izisombululo 179 izimpendulo
Kuphostiwe

59 tabs!?

I opened up up 25 with no problem in the 64bit dev edition and used less than 500MB I got a i7 8 gigs with a 4 gig video card

I opened up a little less than that in 32 bit FF and almost 600MB of ram

Modified December 6, 2015 at 3:18:56 AM GMT by Carm 

Note Mozilla Firefox is 64 bit on 64 Bit Macs, and probably 64bit on most Linux distros. ~J99

59 tabs!? I opened up up 25 with no problem in the [[64bit dev edition|64bit dev edition]] and used less than 500MB I got a i7 8 gigs with a 4 gig video card I opened up a little less than that in 32 bit FF and almost 600MB of ram Modified December 6, 2015 at 3:18:56 AM GMT by Carm --------- Note Mozilla Firefox is 64 bit on 64 Bit Macs, and probably 64bit on most Linux distros. ~J99

Okulungisiwe ngu John99

cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157342 izimpendulo
Kuphostiwe

The memory usage highly depends on the page content (a lot of large image need considerably more memory).

You can try to use the "Free Memory" feature on the about:memory page to see if that helps to reduce the memory usage.

You can check for issues caused by plugins and set plugins to "Ask to Activate" on the "Firefox menu button/Tools > Add-ons > Plugins" page.

  • plugins are not affected by Firefox Safe Mode

You can check for problems with current Shockwave Flash plugin versions and try this:

See also:

The memory usage highly depends on the page content (a lot of large image need considerably more memory). You can try to use the "Free Memory" feature on the about:memory page to see if that helps to reduce the memory usage. You can check for issues caused by plugins and set plugins to "Ask to Activate" on the "Firefox menu button/Tools > Add-ons > Plugins" page. *plugins are not affected by Firefox Safe Mode You can check for problems with current Shockwave Flash plugin versions and try this: *make sure you have the latest Flash version:<br>http://www.adobe.com/special/products/flashplayer/fp_distribution3.html *check for updates for your graphics drive drivers<br>https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration *disable protected mode in the Flash plugin (Windows Vista and later)<br>https://support.mozilla.org/kb/adobe-flash-protected-mode-firefox *disable hardware acceleration in the Flash plugin<br>https://helpx.adobe.com/flash-player/kb/video-playback-issues.html *disable hardware acceleration in Firefox<br />https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration See also: *http://kb.mozillazine.org/Flash#Troubleshooting

Umnikazi wombuzo

I will check it out. It is a bit tricky do get to settings as Firefox would sometimes crash 10 times in a row before I can get to settings.

I also tried Watefox 64bit as suggested in other posts, but running it on Wine causes too much memory usage with only 5 tabs open.

In the mean time I have been using Opera with no problems at all. I just need the browser to work out of the box.

My question is. Are the crashing related to too many tabs open at the same time?

I will check it out. It is a bit tricky do get to settings as Firefox would sometimes crash 10 times in a row before I can get to settings. I also tried Watefox 64bit as suggested in other posts, but running it on Wine causes too much memory usage with only 5 tabs open. In the mean time I have been using Opera with no problems at all. I just need the browser to work out of the box. My question is. Are the crashing related to too many tabs open at the same time?
Tyler Downer
  • Top 25 Contributor
  • Moderator
1529 izisombululo 10654 izimpendulo
Kuphostiwe

Without being able to see the crash reports, we have no idea what is causing them or if it is related to memory usage from too many tabs, malware, an add-on, etc. There are 1000000 things that could be causing it.

Without being able to see the crash reports, we have no idea what is causing them or if it is related to memory usage from too many tabs, malware, an add-on, etc. There are 1000000 things that could be causing it.

Umnikazi wombuzo

Tyler Downer said

Without being able to see the crash reports, we have no idea what is causing them or if it is related to memory usage from too many tabs, malware, an add-on, etc. There are 1000000 things that could be causing it.

I posted crash reports as requested.

''Tyler Downer [[#answer-814521|said]]'' <blockquote> Without being able to see the crash reports, we have no idea what is causing them or if it is related to memory usage from too many tabs, malware, an add-on, etc. There are 1000000 things that could be causing it. </blockquote> I posted crash reports as requested.
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Thank you for the crash reports. Some of these are so fast that I don't think the number of tabs is relevant.

For others that occur after the first minute, I doubt that the number of tabs is a big issue, particularly if you keep the default setting of only restoring the last active tab in each window. But simultaneously loading 59 pages would put some stress of Firefox...

Anyway, the majority of the crashes seem to occur in the JavaScript engine and/or "garbage collection" which is part of Firefox's memory management. These are not "out of memory" errors (or at least they do not have the hallmark of such errors on Windows).


Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Our support article "Troubleshoot Firefox issues using Safe Mode" says to run this in the Terminal (as a Windows user, I'm assume you have a better idea than I do of how to do that):

firefox -safe-mode

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Thank you for the crash reports. Some of these are so fast that I don't think the number of tabs is relevant. For others that occur after the first minute, I doubt that the number of tabs is a big issue, particularly if you keep the default setting of only restoring the last active tab in each window. But simultaneously loading 59 pages would put some stress of Firefox... Anyway, the majority of the crashes seem to occur in the JavaScript engine and/or "garbage collection" which is part of Firefox's memory management. These are not "out of memory" errors (or at least they do not have the hallmark of such errors on Windows). ---- Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Our support article "[[Troubleshoot Firefox issues using Safe Mode]]" says to run this in the Terminal (as a Windows user, I'm assume you have a better idea than I do of how to do that): firefox -safe-mode ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Umnikazi wombuzo

jscher2000 said

Thank you for the crash reports. Some of these are so fast that I don't think the number of tabs is relevant. For others that occur after the first minute, I doubt that the number of tabs is a big issue, particularly if you keep the default setting of only restoring the last active tab in each window. But simultaneously loading 59 pages would put some stress of Firefox... Anyway, the majority of the crashes seem to occur in the JavaScript engine and/or "garbage collection" which is part of Firefox's memory management. These are not "out of memory" errors (or at least they do not have the hallmark of such errors on Windows).

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Our support article "Troubleshoot Firefox issues using Safe Mode" says to run this in the Terminal (as a Windows user, I'm assume you have a better idea than I do of how to do that):

firefox -safe-mode

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Thanks for the info. I did this and 15 minutes later no crash yet. What is the next step?

''jscher2000 [[#answer-814550|said]]'' <blockquote> Thank you for the crash reports. Some of these are so fast that I don't think the number of tabs is relevant. For others that occur after the first minute, I doubt that the number of tabs is a big issue, particularly if you keep the default setting of only restoring the last active tab in each window. But simultaneously loading 59 pages would put some stress of Firefox... Anyway, the majority of the crashes seem to occur in the JavaScript engine and/or "garbage collection" which is part of Firefox's memory management. These are not "out of memory" errors (or at least they do not have the hallmark of such errors on Windows). ---- Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Our support article "[[Troubleshoot Firefox issues using Safe Mode]]" says to run this in the Terminal (as a Windows user, I'm assume you have a better idea than I do of how to do that): firefox -safe-mode ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? </blockquote> Thanks for the info. I did this and 15 minutes later no crash yet. What is the next step?
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Firefox's Safe Mode does a number of things which also can be switched individually:

  • Deactivates all extensions
  • Disables hardware acceleration
  • Disables the "just in time" JavaScript compilers
  • and more...

Before leaving Safe Mode, try disabling Firefox from using hardware acceleration:

"3-bar" menu button (or Tools menu) > Options Whoops, on Linux that would be Edit menu > Preferences

In the left column, click Advanced, then along the time, click the General mini-tab.

Uncheck the box for "Use hardware acceleration when available" and this will take effect when you exit Firefox and start it up again.

Does that improve stability in regular mode?

Firefox's Safe Mode does a number of things which also can be switched individually: * Deactivates all extensions * Disables hardware acceleration * Disables the "just in time" JavaScript compilers * and more... Before leaving Safe Mode, try disabling Firefox from using hardware acceleration: "3-bar" menu button (or Tools menu) > Options '''''Whoops, on Linux that would be Edit menu > Preferences''''' In the left column, click Advanced, then along the time, click the General mini-tab. Uncheck the box for "Use hardware acceleration when available" and this will take effect when you exit Firefox and start it up again. Does that improve stability in regular mode?

Okulungisiwe ngu jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157342 izimpendulo
Kuphostiwe

Also make sure that you have the latest updates of all packages like GStreamer and FFmpeg

You can try to disable GStreamer support and set this pref to false on the about:config page.

  • media.gstreamer.enabled = false
Also make sure that you have the latest updates of all packages like GStreamer and FFmpeg You can try to disable GStreamer support and set this pref to false on the <b>about:config</b> page. *media.gstreamer.enabled = false

Umnikazi wombuzo

jscher2000 said

Firefox's Safe Mode does a number of things which also can be switched individually:
  • Deactivates all extensions
  • Disables hardware acceleration
  • Disables the "just in time" JavaScript compilers
  • and more...
Before leaving Safe Mode, try disabling Firefox from using hardware acceleration: "3-bar" menu button (or Tools menu) > Options Whoops, on Linux that would be Edit menu > Preferences In the left column, click Advanced, then along the time, click the General mini-tab. Uncheck the box for "Use hardware acceleration when available" and this will take effect when you exit Firefox and start it up again. Does that improve stability in regular mode?

Thanks for the info. I have disabled hardware acceleration and after this Firefox crashed about 5 times over the first 40 minutes. bp-98265380-efef-42d8-8f98-2836a2151208 bp-dc4da2f2-585e-4c27-9369-c49f62151208 bp-269b298d-7d8e-4586-86ae-889f42151208 bp-ec807bf2-532c-4d1f-870f-26d262151208 bp-f88992ee-7835-4a9d-b3e0-d56832151208

''jscher2000 [[#answer-814757|said]]'' <blockquote> Firefox's Safe Mode does a number of things which also can be switched individually: * Deactivates all extensions * Disables hardware acceleration * Disables the "just in time" JavaScript compilers * and more... Before leaving Safe Mode, try disabling Firefox from using hardware acceleration: "3-bar" menu button (or Tools menu) > Options '''''Whoops, on Linux that would be Edit menu > Preferences''''' In the left column, click Advanced, then along the time, click the General mini-tab. Uncheck the box for "Use hardware acceleration when available" and this will take effect when you exit Firefox and start it up again. Does that improve stability in regular mode? </blockquote> Thanks for the info. I have disabled hardware acceleration and after this Firefox crashed about 5 times over the first 40 minutes. bp-98265380-efef-42d8-8f98-2836a2151208 bp-dc4da2f2-585e-4c27-9369-c49f62151208 bp-269b298d-7d8e-4586-86ae-889f42151208 bp-ec807bf2-532c-4d1f-870f-26d262151208 bp-f88992ee-7835-4a9d-b3e0-d56832151208

Umnikazi wombuzo

cor-el said

Also make sure that you have the latest updates of all packages like GStreamer and FFmpeg You can try to disable GStreamer support and set this pref to false on the about:config page.
  • media.gstreamer.enabled = false

Phew thats enough for the day. Firefox does does run long enough so I can get to the config. Will try again later.

bp-74177a32-4f89-4a55-bab2-8c31d2151208 08/12/2015 09:33 bp-7d20ab39-912e-4236-b78d-69c992151208 08/12/2015 09:32 bp-9fcfab83-4c83-4e97-b296-bf6bb2151208 08/12/2015 09:32 bp-7b27b4c5-48dd-4e09-b280-658472151208 08/12/2015 09:31 bp-4db366d6-4bef-4a6f-b5e5-de3a42151208 08/12/2015 09:31 bp-4c0f9613-9630-46e0-a833-d9f942151208 08/12/2015 09:30 bp-35cdc1f5-9b98-4145-969a-470812151208 08/12/2015 09:30 bp-98265380-efef-42d8-8f98-2836a2151208 08/12/2015 09:22 bp-dc4da2f2-585e-4c27-9369-c49f62151208 08/12/2015 09:20 bp-269b298d-7d8e-4586-86ae-889f42151208 08/12/2015 09:20 bp-ec807bf2-532c-4d1f-870f-26d262151208 08/12/2015 09:18 bp-f88992ee-7835-4a9d-b3e0-d56832151208 08/12/2015 08:40

''cor-el [[#answer-814768|said]]'' <blockquote> Also make sure that you have the latest updates of all packages like GStreamer and FFmpeg You can try to disable GStreamer support and set this pref to false on the <b>about:config</b> page. *media.gstreamer.enabled = false </blockquote> Phew thats enough for the day. Firefox does does run long enough so I can get to the config. Will try again later. bp-74177a32-4f89-4a55-bab2-8c31d2151208 08/12/2015 09:33 bp-7d20ab39-912e-4236-b78d-69c992151208 08/12/2015 09:32 bp-9fcfab83-4c83-4e97-b296-bf6bb2151208 08/12/2015 09:32 bp-7b27b4c5-48dd-4e09-b280-658472151208 08/12/2015 09:31 bp-4db366d6-4bef-4a6f-b5e5-de3a42151208 08/12/2015 09:31 bp-4c0f9613-9630-46e0-a833-d9f942151208 08/12/2015 09:30 bp-35cdc1f5-9b98-4145-969a-470812151208 08/12/2015 09:30 bp-98265380-efef-42d8-8f98-2836a2151208 08/12/2015 09:22 bp-dc4da2f2-585e-4c27-9369-c49f62151208 08/12/2015 09:20 bp-269b298d-7d8e-4586-86ae-889f42151208 08/12/2015 09:20 bp-ec807bf2-532c-4d1f-870f-26d262151208 08/12/2015 09:18 bp-f88992ee-7835-4a9d-b3e0-d56832151208 08/12/2015 08:40

Umnikazi wombuzo

So I never really got this problem solved. Firefox still crashed too often. I tried Opera as well, but had similar issues.

As I am typing here, I have 79 tabs open in Firefox. This is a new method I were trying out and did not have crashes for no reason yet after about 2 days.

What I have done, is run the latest Firefox on Wine in my Ubuntu. It might be milliseconds slower than the native Firefox, but no crashes. The only crash I had this far, was when I downloaded a few big TV series from my web server on the same LAN using this browser.

Not sure why, but does this mean that the "Windows" version of Firefox is more stable. Keeping in mind that I use my Mozilla account meaning all the same plugins, bookmarks etc. is sync to this Firefox on wine. Or did it just need some wine :-)

So I never really got this problem solved. Firefox still crashed too often. I tried Opera as well, but had similar issues. As I am typing here, I have 79 tabs open in Firefox. This is a new method I were trying out and did not have crashes for no reason yet after about 2 days. What I have done, is run the latest Firefox on Wine in my Ubuntu. It might be milliseconds slower than the native Firefox, but no crashes. The only crash I had this far, was when I downloaded a few big TV series from my web server on the same LAN using this browser. Not sure why, but does this mean that the "Windows" version of Firefox is more stable. Keeping in mind that I use my Mozilla account meaning all the same plugins, bookmarks etc. is sync to this Firefox on wine. Or did it just need some wine :-)
cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157342 izimpendulo
Kuphostiwe

Impendulo Ewusizo

You can try to disable GStreamer support and set this pref to false on the about:config page.

  • media.gstreamer.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

user.js or prefs.js:

user_pref("media.gstreamer.enabled", false);
You can try to disable GStreamer support and set this pref to false on the <b>about:config</b> page. *media.gstreamer.enabled = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config user.js or prefs.js: user_pref("media.gstreamer.enabled", false);

Umnikazi wombuzo

Think I`m going to stick with Firefox on Wine for the moment. I have 86 tabs open and no crashes since my last post.

Think I`m going to stick with Firefox on Wine for the moment. I have 86 tabs open and no crashes since my last post.

Umnikazi wombuzo

I do not see the media.gstreamer.enabled

I do not see the media.gstreamer.enabled

Umnikazi wombuzo

nazzeem said

I do not see the media.gstreamer.enabled

Apologies. I might have been looking at Firefox on Wine. Will check again.

''nazzeem [[#answer-840446|said]]'' <blockquote> I do not see the media.gstreamer.enabled </blockquote> Apologies. I might have been looking at Firefox on Wine. Will check again.

Umnikazi wombuzo

I have changed this setting "media.gstreamer" to disabled and my Firefox on Ubuntu did not crash yet after 4 days with about 55-70 tabs open. Hope this solves my issue. Thanks

I have changed this setting "media.gstreamer" to disabled and my Firefox on Ubuntu did not crash yet after 4 days with about 55-70 tabs open. Hope this solves my issue. Thanks
Jack 5 izisombululo 46 izimpendulo
Kuphostiwe

nazzeem said

My system is an i5 with 22GB RAM running Ubuntu 15.10

I am a lightweight helper but I wonder if you could avoid that by opening 10 tabs and then open another window of Firefox, 10 more tabs and then aother window of Firefox, etc. ..... I said I was lightweight. Something to try until someone with real Firefox smarts comes alone! ":-Dx lol

''nazzeem [[#question-1097503|said]]'' <blockquote> My system is an i5 with 22GB RAM running Ubuntu 15.10 </blockquote> I am a lightweight helper but I wonder if you could avoid that by opening 10 tabs and then open another window of Firefox, 10 more tabs and then aother window of Firefox, etc. ..... I said I was lightweight. Something to try until someone with real Firefox smarts comes alone! ":-Dx lol