Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

"This Connection is Untrusted" ssl_error_bad_cert_domain security.frontier.com

  • 16 uphendule
  • 6 zinale nkinga
  • 209 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Every day around 9:30 PM, browsing the web becomes impossible. nearly every site I visit brings up a This Connection Is Untrusted page. I have tried using different browsers and Different Devices. Even my 3DS doesn't work. This has lead me to believe that the problem is either with the modem or my service provider. I checked the certificate of Google via chrome://pippki/content/exceptionDialog.xul, and it read ISSUED TO Common Name (CN) security.frontier.com Organization (O) security.frontier.com and when I checked it now, it reads ISSUED TO Common Name (CN) www.google.com Organization (O) Google Inc I don't know what fixes this problem since the problem stops at different times. It started around when I installed AVG, so I tried uninstalling it, but the problem didn't stop. While I'm fairly certain the problem isn't related to Firefox, this is one of the sites that I am able to visit when this problem occurs. I have tried manually adding the exception so I could bypass the Untrusted Connection page, but the page never loads and the next time it happens, the page is there again anyway.

All Replies (16)

more options

Unplug your modem from the power for a slow 10 count to reboot it.

Have your ISP test your service, and ask about your problem.

I've called the big guys to help you. Good luck.

more options

Are you using software from Frontier?

There is security and other software that intercepts secure connections and send their own certificate.

You can check in "Windows Control Panel > Programs" for recently installed programs to see if any suspicious software (Conduit, Search Protect) shows up.

  • Control Panel > Programs > Programs and Features > Uninstall or change a program
  • Click the Installed column to sort by this heading

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

more options

Just finished trying safe mode with network support, still no luck, also, The only new software was the AVG, which I reinstalled. I was able to get some screenshots of the certificate for google. I f I type Google.com/ into the address bar, I'm redirected to https://security.frontier.com/id/connected/

more options

I'm redirected to https://security.frontier.com/id/connected/ if I leave off the https://www. of a website. Websites with something replacing the www seem to still work.

more options

OK, I can't visit the Netflix site but the Netflix app works on my tablet, however, both the youtube site and app don't work.

more options

You can check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can try a LSP (Layered Service Provider) reset

Open a cmd.exe window as administrator and issue this command:

netsh winsock reset

Okulungisiwe ngu cor-el

more options

I've checked the connection settings, so I'm sure that this isn't a firefox problem. I can't browse on chrome or even internet explorer. Before I try an LSP reset, I'm going to need to know exactly what it does.

Sorry cor-el, when I opened your google link I was sent to this page https://security.frontier.com/id/connected/

Okulungisiwe ngu gemeral

more options

could someone look up GeoTrust Inc and these URLs https://security.frontier.com/acctedit/index.php & https://security.frontier/ I need to know what these are. Apparently https://security.frontier/ is untrusted https://security.frontier.com will redirect the request for this address in a way that will never complete and https://security.frontier.com/id/connected/ brings up the redirected page.

more options

I'm getting desperate, so I tried the LSP reset, the cmd response was "The requested operation requires elevation." I'm on an administrator account, so what does that mean? I just used chrome://pippki/content/exceptionDialog.xul to check the certificate of https://security.frontier.com/id/connected/ but there wasn't one?! When I checked the certificate in the address bar I was able to view it. is https://security.frontier.com/id/connected/ not a real site?!

more options

Is there another place that stores security certificates on the computer? Since this is happening on more than one browser and it is not showing up in the Firefox cert, check IE's certificate list as well as any firewalls or security options on the computer. If you can find it and remove the cert you can eliminate if it was a cert installed from before you rebooted the cable modem.

If this is not the case please contact your network provider to make sure that all of the ips listed for your service are correct and are not going through a proxy out of your control.

more options

You need to open a Command prompt window as administrator via the right-click context menu, being an administrator is not enough.

Start -> Programs -> Accessories -> right click on the Command Prompt and choose Run as administrator.
more options

Was finally able to try an LSP reset after the problem started up again. It didn't work, but then, I wasn't sure it would work anyway since the problem is occurring on all devices, not just the computer. Safari on the iPad cant browse and neither can the internet browser on my 3DS. A new page has showed up, not sure if it's legit.

more options

Did you try to reset (power off/on) the router?

You can try a different DNS service.

more options

December 12, 2015 After talking with tech support, decided to try the Frontier page, so far so good, I've been looking through the system and haven't detected any shifts in power, memory, or ram usages. It appears to have worked for now, but will wait a month before confirming. I'll also check to make sure no new programs, files, folder, etc are added or installed on the computer during this time. Now to wait...

January 15, 2016 It's been about a month and no problems so far, I have to assume that this was the solution

January 19, 2016 so it's back, apparently this is NOT the solution, or at least not a permanent one. Back to square one...

Okulungisiwe ngu gemeral

more options

I might suggest contacting Frontier support again or the support that you called to make sure its not a service provider changing anything.

more options

Is it possible your Frontier account has parental control settings relating to the time of day? Otherwise, it's hard to think of a reason for access restrictions to apply only at night.