Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I permanently disable SAFE MODE startup in version 43.0b6?

  • 12 uphendule
  • 1 inale nkinga
  • 1634 views
  • Igcine ukuphendulwa ngu imdafaddah

more options

I've tried every suggestion I can find online without success. I'm not a developer but I have some experience with programming, e.g. VBA, fortran, algol, etc., and I've used windows since 1981. Nevertheless I really would appreciate clear step by step directions in English.

Isisombululo esikhethiwe

I did a refresh using the link you provided (many thanks for that) and reinstalled a couple of my most used extensions. Everything appears to be working as I wanted it to be working. I still have to enable a few others and I will probably clean out a few that are just hanging around but that should be no problem. Thanks for the quick and easy solution to the problem.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (12)

more options

What are you trying to accomplish by disabling safe mode> Maybe that's a better place for us to start.

more options

Every time I close Firefox and then at some later time restart it I have to re-enable all my plugins. I assume this is because it's restarting in Safe Mode. The shortcut I use does not include "-safemode" in the target string. There is no SafeMode tab in the dialog box. Safemode does not appear in the config file Shutting down and unplugging the PC then re-connecting it to the power and rebooting makes no difference. FireFox always restarts with all plugins disabled. I just want FireFox to restart with all my plugins having the same enabled/disabled status they had when I closed it.

more options

Do you mean plugins (like Flash, silverlight, etc.) or extensions? If your extensions are starting disabled, perhaps refreshing your profile and then re-installing your extensions will help. Refresh Firefox - reset add-ons and settings

more options

Please see the image attached.

more options

So the only plugin actually disabled is Java (which is out of date and should be updated) the rest are set to "Ask to Activate". Why do I have to click to activate plugins? can explain some more on what's happening there.

more options

I just noticed that things like Ad Blocker and several other things I had like it have disappeared!!

more options

They are nowhere to be found.

more options

I think my best solution is to uninstall irefox, download the installation and start from scratch. YOur opinion?

more options

Uninstalling and re-installing won't change anything, as your profile is still there. I'd suggest doing a Firefox refresh, and then re-install your extensions. Refresh Firefox - reset add-ons and settings

more options

I will do that when I have more time and report later. Thanks for the input.

more options

The Refresh feature is a fast way to attack this problem. If you want to try something smaller scale but more involved first, then read on.

One reason for this problem to occur would be some corruption in Firefox's database of extensions. You can force Firefox to regenerate the files by doing the following:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename any of these files that you find:

  • compatibility.ini to something like compatibility-old.ini
  • extensions.ini to something like extensions-old.ini
  • extensions.json to something like extensions-old.json
  • extensions.sqlite to something like extensions-old.sqlite (might not exist depending on how long you've been using this settings folder)

When you start Firefox back up again, it should explore your profile folder and other folders to rebuild the list. It probably will ask you to approve some of the extensions. Once things settle down, could you check the Add-ons page again.

Any improvement?

Note: If you have the BetterPrivacy extension, which removes Flash Local Storage Objects, it has a compatibility problem with Firefox 42 and I suggest removing it temporarily as it may be linked with this problem.

more options

Isisombululo Esikhethiwe

I did a refresh using the link you provided (many thanks for that) and reinstalled a couple of my most used extensions. Everything appears to be working as I wanted it to be working. I still have to enable a few others and I will probably clean out a few that are just hanging around but that should be no problem. Thanks for the quick and easy solution to the problem.