X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Is it normal that it takes a good half-second to switch from one tab to another ?

Kuphostiwe

This feels slow as molasses, especially when working with many tabs. It happens :

- On already loaded tabs (so you'd think just clicking on them would bring them to the forefront immediately).

- On a fresh install (a few weeks old).

- With no bookmarks at all.

- On a profile with only 6 extensions, including Tab Mix Plus.

- On a virgin default profile just out of install, with nothing else added.

I've tried to disable the real-time shields of my Avast Free anti-virus, to no avail. Note : I've moved my profiles out of %AppData%, but I don't suppose this is relevant.

I come from Opera (legacy version), which does not have that delay. Is this to be expected on Firefox ?

As an aside, long startup times seem to be the norm (9 to 16 seconds, in my case), and I'm not even sure this includes the Profile Manager startup time. I used to live in a world where launching a browser was immediate.

This feels slow as molasses, especially when working with many tabs. It happens : - On already loaded tabs (so you'd think just clicking on them would bring them to the forefront immediately). - On a fresh install (a few weeks old). - With no bookmarks at all. - On a profile with only 6 extensions, including Tab Mix Plus. - On a virgin default profile just out of install, with nothing else added. I've tried to disable the real-time shields of my Avast Free anti-virus, to no avail. Note : I've moved my profiles out of %AppData%, but I don't suppose this is relevant. I come from Opera (legacy version), which does not have that delay. Is this to be expected on Firefox ? As an aside, long startup times seem to be the norm (9 to 16 seconds, in my case), and I'm not even sure this includes the Profile Manager startup time. I used to live in a world where launching a browser was immediate.

Okulungisiwe ngu Clairvaux

Isisombululo esikhethiwe

cor-el said

Security software can't be ruled out and it is possible that some update of your security software has cured your issue.

That's it. I found the culprit (at least in my case, but it might also have affected other people with the same complaint).

Its' IBM Security Trusteer Rapport (yes, that IBM), a supplemental anti-malware program dedicated to online banking, which adds another layer of protection to browsers, specifically to prevent attacks in such situations.

I had shut it off in order to do some system maintenance, and I forgot to activate it again. Sure enough, the exasperating delay was back when I re-launched it.

I had forgotten about it because IBM partners with banks, and you usually get it through your bank which recommends it to you (although anybody can download it for free from IBM).

It was probably an update, too, because I have been using it for a long time with Firefox without this problem. What we don't know is whether it was an update of Trusteer Rapport or of Firefox which broke their normal cooperation.

I may try to alter its security settings, because they are configurable. I will post back if I have results.

However, this problem occurs only in Firefox, not in Pale Moon, Opera or Maxthon (the other browsers I use).

I do think it's worth to report this bug on both sides, Mozilla and IBM, because IBM has a partnership for this product with many big banks worldwide, and notably in the US. That being the reason why users are not necessary aware of it as a safety product they use, on top of their minds.

Also, you would be reluctant to lower your level of security if you do online banking, as more and more people do. And it's not straightforward to disable Trusteer Rapport -- you have to type a captcha before.

The induced sluggishness in tab-switching is really a motive to ditch Firefox altogether.

Thank you for your continued attention.

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Isisebenziso

  • Firefox 42.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/42.0/WINNT/en-GB/

Izandiso

  • Adblock Plus 2.6.11 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Disconnect 3.15.3.1-signed (2.0@disconnect.me)
  • FlashDisable 1.1.1.1-signed (jid0-bbA9VAawX3LMWDu668aUDrpQVXU@jetpack)
  • HTTPS-Everywhere 5.1.0 (https-everywhere@eff.org)
  • NoScript 2.7 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Tab Mix Plus 0.4.1.9 ({dc572301-7619-498c-a57d-39143191b318})
  • Avast Online Security 10.2.0.187 (wrc@avast.com) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: ATI Radeon HD 4290
  • adapterDescription2:
  • adapterDeviceID: 0x9714
  • adapterDeviceID2:
  • adapterDrivers: atiu9p64 aticfx64 aticfx64 atiu9pag aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 368
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 50 Enhanced Contrast: 200
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17461
  • driverDate: 1-13-2010
  • driverDate2:
  • driverVersion: 8.700.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d 1.1', u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: False
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4290 Direct3D11 vs_4_1 ps_4_1)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
cor-el
  • Top 10 Contributor
  • Moderator
17541 izisombululo 158604 izimpendulo
Kuphostiwe

It is possible that your firewall or other security software blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to install for Firefox and the plugin-container process and the updater process.

See:


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

It is possible that your firewall or other security software blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program. Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to install for Firefox and the plugin-container process and the updater process. See: *https://support.mozilla.org/kb/Server+not+found *https://support.mozilla.org/kb/Firewalls *https://support.mozilla.org/kb/fix-problems-connecting-websites-after-updating ---- Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Umnikazi wombuzo

Thanks. I will try that and report back.

It's probably not the profile, since I created a new one only days ago, and the tabs still need to be pushed hard (so to speak).

Thanks. I will try that and report back. It's probably not the profile, since I created a new one only days ago, and the tabs still need to be pushed hard (so to speak).

Umnikazi wombuzo

This is getting curiouser and curiouser. I followed your advice, and deleted Firefox from the list of authorized programs in Windows 7 firewall (see the result below). Notice that there was only Firefox there, no plug-in container or updater.

And... Firefox can still access the Internet ! Nothing seems to have changed. I rebooted, thinking that maybe it was needed for changes to take effect, but no.

No warning from Windows firewall asking for access for Firefox, either.

Opera is in that list (along with its plug-in wrapper), but Maxthon is not, and Maxthon is one of the browsers I'm currently using. It does not have any problem accessing the Internet either.

I also made a copy of Avast Antivirus Free list of exceptions for real-time file scanning. Firefox is there. I didn't add it, by the way. Is it Firefox or Avast which took the initiative ?

What now ? Should I re-register Firefox in my firewall ? That delay to view tabs is still there, of course.

This is getting curiouser and curiouser. I followed your advice, and deleted Firefox from the list of authorized programs in Windows 7 firewall (see the result below). Notice that there was only Firefox there, no plug-in container or updater. And... Firefox can still access the Internet ! Nothing seems to have changed. I rebooted, thinking that maybe it was needed for changes to take effect, but no. No warning from Windows firewall asking for access for Firefox, either. Opera is in that list (along with its plug-in wrapper), but Maxthon is not, and Maxthon is one of the browsers I'm currently using. It does not have any problem accessing the Internet either. I also made a copy of Avast Antivirus Free list of exceptions for real-time file scanning. Firefox is there. I didn't add it, by the way. Is it Firefox or Avast which took the initiative ? What now ? Should I re-register Firefox in my firewall ? That delay to view tabs is still there, of course.
FredMcD
  • Top 10 Contributor
4261 izisombululo 59658 izimpendulo
Kuphostiwe

Some firewalls know some programs are safe, and will allow them automatically.

When you select a different tab, is the tab blank, or already loaded?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

Some firewalls know some programs are safe, and will allow them automatically. When you select a different tab, is the tab blank, or already loaded? Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. Is the problem still there?

Umnikazi wombuzo

FredMcD said

Some firewalls know some programs are safe, and will allow them automatically.

Should I nonetheless re-register Firefox (and maybe the plug-in and updater) ? How are the latter called ?

FredMcD said

When you select a different tab, is the tab blank, or already loaded ?

I confirm that I took care to verify this with fully loaded tabs.

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?

Yes, exactly the same. Thanks for helping me discover FF Safe Mode, by the way.

Are your browsers out there reacting similarly ? Is that an expected behaviour ? To give you an idea, if I spread tabs across the width of my screen and "play the piano" on them with my mouse, trying to do a slideshow opening one page after the other, nothing happens. No tab will open, except the last on the row, and only once I have stopped clicking.

In fact, I suspect the delay between click and open is closer to a second than to a half-second.

''FredMcD [[#answer-810334|said]]'' <blockquote> Some firewalls know some programs are safe, and will allow them automatically. </blockquote> Should I nonetheless re-register Firefox (and maybe the plug-in and updater) ? How are the latter called ? ''FredMcD [[#answer-810334|said]]'' <blockquote> When you select a different tab, is the tab blank, or already loaded ? </blockquote> I confirm that I took care to verify this with fully loaded tabs. ''FredMcD [[#answer-810334|said]]'' <blockquote> Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. Is the problem still there? </blockquote> Yes, exactly the same. Thanks for helping me discover FF Safe Mode, by the way. Are your browsers out there reacting similarly ? Is that an expected behaviour ? To give you an idea, if I spread tabs across the width of my screen and "play the piano" on them with my mouse, trying to do a slideshow opening one page after the other, nothing happens. No tab will open, except the last on the row, and only once I have stopped clicking. In fact, I suspect the delay between click and open is closer to a second than to a half-second.
FredMcD
  • Top 10 Contributor
4261 izisombululo 59658 izimpendulo
Kuphostiwe

Clairvaux said

Should I nonetheless re-register Firefox

Take a look. Firefox may alredy be listed.

One thing. if it onlt takes a second, I would not worry. Remember that the computer is doing a lot more then just changing one tab.

''Clairvaux [[#answer-810348|said]]'' <blockquote> Should I nonetheless re-register Firefox </blockquote> Take a look. Firefox may alredy be listed. One thing. if it onlt takes a second, I would not worry. Remember that the computer is doing a lot more then just changing one tab.

Umnikazi wombuzo

FredMcD said

Take a look. Firefox may alredy be listed.

Nothing there...

''FredMcD [[#answer-810365|said]]'' <blockquote>Take a look. Firefox may alredy be listed. </blockquote> Nothing there...

Umnikazi wombuzo

I've now added manually to Windows 7 firewall : firefox.exe, updater.exe and plugin-container.exe.

Oh, and I've discovered that mine is an old and widespread problem :

Firefox slow to switch tabs (2007) Why is switching over multiple tabs in Firefox so slow ? (2011) Firefox 14.0.1 slow to switch tabs (2012) Slow switching between tabs (2012) It takes several seconds to switch tabs (2012) Slow Firefox tabs ? (2013)

This is closest to what I experience : Why is Firefox slow to switch already loaded tabs ? (2012)

I am using Firefox 13.0.1 on Windows 7 64-bit. The hardware is Intel Core i3 2.1GHZ with 6GB DDR3 RAM. To make sure that the slowness is not due to any addons, plugins or profiles, I created a new Windows login and open Firefox in that account. I load techcrunch.com in one tab and theverge.com in the second tab. I do the same in Chrome 19.0 and Internet Explorer 9.0.8. I wait until the two tabs finish loading completely. Now, I switch quickly between the two tabs using Ctrl-Tab. The switching in Chrome and IE is instantaneous. But, the switching in Firefox is super slow. It actually takes 500ms to 700ms after I press Ctrl-Tab to switch.

I have 4 Gb RAM, so, less. Even the delay seems to be the same : 500 ms to 700 ms is exactly what I have in mind. For professional reasons, I have been trained to count seconds in my head, so I have a fairly good approximate of what a second is.

This is all the more frustrating since once I'm on a given page, navigating it is pleasantly fast (and loading is not abnormally long). But my style of browsing requires jumping frequently from one tab to another.

Any other suggestions still greatly appreciated.

I've now added manually to Windows 7 firewall :''' firefox.exe''', '''updater.exe''' and '''plugin-container.exe'''. Oh, and I've discovered that mine is an old and widespread problem : [http://forums.mozillazine.org/viewtopic.php?f=38&t=597467 Firefox slow to switch tabs (2007)] [http://www.makeuseof.com/answers/switching-multiple-tabs-firefox-slow/ Why is switching over multiple tabs in Firefox so slow ? (2011)] [https://support.mozilla.org/en-US/questions/932435 Firefox 14.0.1 slow to switch tabs (2012)] [https://support.mozilla.org/en-US/questions/933895#answer-357792 Slow switching between tabs (2012)] [http://forums.anandtech.com/showthread.php?t=2251953 It takes several seconds to switch tabs (2012)] [https://davescomputertips.com/slow-firefox-tabs/ Slow Firefox tabs ? (2013)] This is closest to what I experience : [http://forums.mozillazine.org/viewtopic.php?f=38&t=2496011 Why is Firefox slow to switch already loaded tabs ? (2012)] <blockquote> I am using Firefox 13.0.1 on Windows 7 64-bit. The hardware is Intel Core i3 2.1GHZ with 6GB DDR3 RAM. To make sure that the slowness is not due to any addons, plugins or profiles, I created a new Windows login and open Firefox in that account. I load techcrunch.com in one tab and theverge.com in the second tab. I do the same in Chrome 19.0 and Internet Explorer 9.0.8. I wait until the two tabs finish loading completely. Now, I switch quickly between the two tabs using Ctrl-Tab. The switching in Chrome and IE is instantaneous. But, the switching in Firefox is super slow. It actually takes 500ms to 700ms after I press Ctrl-Tab to switch. </blockquote> I have 4 Gb RAM, so, less. Even the delay seems to be the same : 500 ms to 700 ms is exactly what I have in mind. For professional reasons, I have been trained to count seconds in my head, so I have a fairly good approximate of what a second is. This is all the more frustrating since once I'm on a given page, navigating it is pleasantly fast (and loading is not abnormally long). But my style of browsing requires jumping frequently from one tab to another. Any other suggestions still greatly appreciated.

Umnikazi wombuzo

The mystery deepens.

Now, the delay for switching tabs has (almost) disappeared ! Firefox is pleasantly reactive again... And what did I change in between ? Nothing.

I still have the following extensions active :

  • Adblock Plus
  • NoScript
  • HTTPS Everywhere
  • Disable Flash
  • Disconnect
  • Tab Mix Plus

I also have the Avast Online Security extension downloaded, but it has been disabled before I started this thread.

I did not refresh my profile. I did not create a new profile. I did not do anything with Windows' firewall and Avast Free Antivirus (except what I already explained, which hadn't changed anything). Starting Firefox in safe mode still does not make a difference, and it did not make a difference then.

Now that I think of it, I did install Pale Moon (which does not have that problem, as far as I can see ; I also tried once again the last version of Opera, which is blazingly fast -- however, it lacks plenty of basic features). Maybe that made Firefox relent ?

All right, joking aside : the only thing remotely, possibly relevant I did, that I can think of, was install Flash, which I had deliberately avoided before. Specifically, Shockwave Flash 19.0.0.245 (a confusing name). I can't imagine not having a plug-in can make Firefox slower, and besides, I tried disabling it, with the predictable absence of results on the speed of tab switching.

So I'm not marking this thread solved, because I believe the problem hasn't been identified, and I do think there is a problem, judging from the number of times it has come up, with no obvious solutions.

Any supplementary wisdom on this puzzling issue still welcome...

The mystery deepens. Now, the delay for switching tabs has (almost) disappeared ! Firefox is pleasantly reactive again... And what did I change in between ? ''Nothing.'' I still have the following extensions active : * Adblock Plus * NoScript * HTTPS Everywhere * Disable Flash * Disconnect * Tab Mix Plus I also have the Avast Online Security extension downloaded, but it has been disabled before I started this thread. I did not refresh my profile. I did not create a new profile. I did not do anything with Windows' firewall and Avast Free Antivirus (except what I already explained, which hadn't changed anything). Starting Firefox in safe mode still does not make a difference, and it did not make a difference then. Now that I think of it, I did install Pale Moon (which does not have that problem, as far as I can see ; I also tried once again the last version of Opera, which is blazingly fast -- however, it lacks plenty of basic features). Maybe ''that ''made Firefox relent ? All right, joking aside : the only thing remotely, possibly relevant I did, that I can think of, was install Flash, which I had deliberately avoided before. Specifically, Shockwave Flash 19.0.0.245 (a confusing name). I can't imagine ''not ''having a plug-in can make Firefox slower, and besides, I tried disabling it, with the predictable absence of results on the speed of tab switching. So I'm not marking this thread solved, because I believe the problem hasn't been identified, and I do think there is a problem, judging from the number of times it has come up, with no obvious solutions. Any supplementary wisdom on this puzzling issue still welcome...
cor-el
  • Top 10 Contributor
  • Moderator
17541 izisombululo 158604 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Possible causes are extensions or problems with files like places.sqlite (bookmarks, history) and sessionstore.js (tab history). Security software can't be rules out and it is possible that some update of your security software has cured your issue.

Possible causes are extensions or problems with files like places.sqlite (bookmarks, history) and sessionstore.js (tab history). Security software can't be rules out and it is possible that some update of your security software has cured your issue.

Isisombululo Esikhethiwe

cor-el said

Security software can't be ruled out and it is possible that some update of your security software has cured your issue.

That's it. I found the culprit (at least in my case, but it might also have affected other people with the same complaint).

Its' IBM Security Trusteer Rapport (yes, that IBM), a supplemental anti-malware program dedicated to online banking, which adds another layer of protection to browsers, specifically to prevent attacks in such situations.

I had shut it off in order to do some system maintenance, and I forgot to activate it again. Sure enough, the exasperating delay was back when I re-launched it.

I had forgotten about it because IBM partners with banks, and you usually get it through your bank which recommends it to you (although anybody can download it for free from IBM).

It was probably an update, too, because I have been using it for a long time with Firefox without this problem. What we don't know is whether it was an update of Trusteer Rapport or of Firefox which broke their normal cooperation.

I may try to alter its security settings, because they are configurable. I will post back if I have results.

However, this problem occurs only in Firefox, not in Pale Moon, Opera or Maxthon (the other browsers I use).

I do think it's worth to report this bug on both sides, Mozilla and IBM, because IBM has a partnership for this product with many big banks worldwide, and notably in the US. That being the reason why users are not necessary aware of it as a safety product they use, on top of their minds.

Also, you would be reluctant to lower your level of security if you do online banking, as more and more people do. And it's not straightforward to disable Trusteer Rapport -- you have to type a captcha before.

The induced sluggishness in tab-switching is really a motive to ditch Firefox altogether.

Thank you for your continued attention.

''cor-el [[#answer-811027|said]]'' <blockquote> Security software can't be ruled out and it is possible that some update of your security software has cured your issue. </blockquote> That's it. '''I found the culprit''' (at least in my case, but it might also have affected other people with the same complaint). Its' '''[http://www-03.ibm.com/software/products/en/trusteer-rapport IBM Security Trusteer Rapport]''' (yes, ''that ''IBM), a supplemental anti-malware program dedicated to online banking, which adds another layer of protection to browsers, specifically to prevent attacks in such situations. I had shut it off in order to do some system maintenance, and I forgot to activate it again. Sure enough, the exasperating delay was back when I re-launched it. I had forgotten about it because IBM partners with banks, and you usually get it through your bank which recommends it to you (although anybody can download it for free from IBM). It was probably an update, too, because I have been using it for a long time with Firefox without this problem. What we don't know is whether it was an update of Trusteer Rapport or of Firefox which broke their normal cooperation. I may try to alter its security settings, because they are configurable. I will post back if I have results. However, this problem occurs only in Firefox, not in Pale Moon, Opera or Maxthon (the other browsers I use). I do think it's worth to report this bug on both sides, Mozilla and IBM, because IBM has a partnership for this product with many big banks worldwide, and notably in the US. That being the reason why users are not necessary aware of it as a safety product they use, on top of their minds. Also, you would be reluctant to lower your level of security if you do online banking, as more and more people do. And it's not straightforward to disable Trusteer Rapport -- you have to type a captcha before. The induced sluggishness in tab-switching is really a motive to ditch Firefox altogether. Thank you for your continued attention.

Okulungisiwe ngu Clairvaux

FredMcD
  • Top 10 Contributor
4261 izisombululo 59658 izimpendulo
Kuphostiwe

It could have been a corrupt file that was overwritten.

It could have been a corrupt file that was overwritten.