X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't play twitter movies

Kuphostiwe

I can't play twitter incorporated movies. This one for example cannot be read : https://twitter.com/BeaujolaisNvx/status/664015437680607232 Safe mode doesn't change anything. I've create a full new brand "home" directory from scratch. No change. I've seen some reports about fiddling in about:config. No change either (I don't even find the entry key blabla-media-foundation-blabla).

Vines movies, on the other hand, are handled sucessfully Like this one for example: https://vine.co/v/eUXxn20mKZW

Flash is up-to-date on my Linux-gentoo box 11.2.202.548 Java is up-to-date. Video Codec OpenH264 installed by Cisco systems Firefox version is 38.4.0

Any help would be greatly appreciated ! Thanks

I can't play twitter incorporated movies. This one for example cannot be read : https://twitter.com/BeaujolaisNvx/status/664015437680607232 Safe mode doesn't change anything. I've create a full new brand "home" directory from scratch. No change. I've seen some reports about fiddling in about:config. No change either (I don't even find the entry key blabla-media-foundation-blabla). Vines movies, on the other hand, are handled sucessfully Like this one for example: https://vine.co/v/eUXxn20mKZW Flash is up-to-date on my Linux-gentoo box 11.2.202.548 Java is up-to-date. Video Codec OpenH264 installed by Cisco systems Firefox version is 38.4.0 Any help would be greatly appreciated ! Thanks

Isisombululo esikhethiwe

larbalette said

James said
Do you have the various Gstreamer packages installed? is media.gstreamer.enabled set to true in about:config Also if you do install gstreamer and such packages while Firefox is still running, do restart the Firefox.

I have gstreamer installed : media-libs/gstreamer-0.10.36-r2:0.10

But I have no media.gstreamer.enabled key entry in about:config. Is it an issue ?

OK. I've just understood that you've meant "installed for Firefox" and not for the whole system, which was my initial understanding. So NO, you're right (and BRILLIANT !), gstreamer was not installed for Firefox. I did compile Firefox again with the gstreamer use flag enabled,and everything is now back in order !

Thank you so much both of you Sincerely

Larb@lette

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • The IcedTea-Web Plugin executes Java applets.
  • Shockwave Flash 11.2 r202

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4269 izisombululo 59882 izimpendulo
Kuphostiwe

If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration See also:

removed part not applicable for Flash on Linux.

If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting''' removed part not applicable for Flash on Linux.

Okulungisiwe ngu James

James
  • Top 25 Contributor
  • Moderator
1602 izisombululo 11337 izimpendulo
Kuphostiwe

Do you have the various Gstreamer packages installed?

is media.gstreamer.enabled set to true in about:config

Also if you do install gstreamer and such packages while Firefox is still running, do restart the Firefox.

Do you have the various Gstreamer packages installed? is media.gstreamer.enabled set to true in about:config Also if you do install gstreamer and such packages while Firefox is still running, do restart the Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 158997 izimpendulo
Kuphostiwe

Impendulo Ewusizo

That side play an MP4 file, so as posted above you need to have support for playing media file via GStreamer. See also media.gstreamer.* on the about:config page.

  • media.gstreamer.enabled

You can open the Web Console (Firefox menu button or Tools > Web Developer) and check for media related error messages.

That side play an MP4 file, so as posted above you need to have support for playing media file via GStreamer. See also media.gstreamer.* on the <b>about:config</b> page. *media.gstreamer.enabled You can open the Web Console (Firefox menu button or Tools > Web Developer) and check for media related error messages. *https://developer.mozilla.org/Tools/Web_Console

Umnikazi wombuzo

James said

Do you have the various Gstreamer packages installed? is media.gstreamer.enabled set to true in about:config Also if you do install gstreamer and such packages while Firefox is still running, do restart the Firefox.

I have gstreamer installed : media-libs/gstreamer-0.10.36-r2:0.10

But I have no media.gstreamer.enabled key entry in about:config. Is it an issue ?

''James [[#answer-809106|said]]'' <blockquote> Do you have the various Gstreamer packages installed? is media.gstreamer.enabled set to true in about:config Also if you do install gstreamer and such packages while Firefox is still running, do restart the Firefox. </blockquote> I have gstreamer installed : media-libs/gstreamer-0.10.36-r2:0.10 But I have no media.gstreamer.enabled key entry in about:config. Is it an issue ?

Umnikazi wombuzo

cor-el said

That side play an MP4 file, so as posted above you need to have support for playing media file via GStreamer. See also media.gstreamer.* on the about:config page.
  • media.gstreamer.enabled
You can open the Web Console (Firefox menu button or Tools > Web Developer) and check for media related error messages.

Thanks for the tip When trying to open the movie with the Web Console opened, I get this error message (see the attached image). Basically, it looks like nothing is able to handle the HTTP type video/mp4 (sorry, it's in french) Any idea how to solve this ? Knowing that, again, I can read Youtube movies. Even Vines movies (except that I've discovered that the sound was OFF for this one, for any reason that I'm still not able to solve yet : and I've got similar error message with the Vines movie, different but still saying that content type HTTP video/mp4 is not handled)

Thanks for your help already !

''cor-el [[#answer-809112|said]]'' <blockquote> That side play an MP4 file, so as posted above you need to have support for playing media file via GStreamer. See also media.gstreamer.* on the <b>about:config</b> page. *media.gstreamer.enabled You can open the Web Console (Firefox menu button or Tools > Web Developer) and check for media related error messages. *https://developer.mozilla.org/Tools/Web_Console </blockquote> Thanks for the tip When trying to open the movie with the Web Console opened, I get this error message (see the attached image). Basically, it looks like nothing is able to handle the HTTP type video/mp4 (sorry, it's in french) Any idea how to solve this ? Knowing that, again, I can read Youtube movies. Even Vines movies (except that I've discovered that the sound was OFF for this one, for any reason that I'm still not able to solve yet : and I've got similar error message with the Vines movie, different but still saying that content type HTTP video/mp4 is not handled) Thanks for your help already !

Isisombululo Esikhethiwe

larbalette said

James said
Do you have the various Gstreamer packages installed? is media.gstreamer.enabled set to true in about:config Also if you do install gstreamer and such packages while Firefox is still running, do restart the Firefox.

I have gstreamer installed : media-libs/gstreamer-0.10.36-r2:0.10

But I have no media.gstreamer.enabled key entry in about:config. Is it an issue ?

OK. I've just understood that you've meant "installed for Firefox" and not for the whole system, which was my initial understanding. So NO, you're right (and BRILLIANT !), gstreamer was not installed for Firefox. I did compile Firefox again with the gstreamer use flag enabled,and everything is now back in order !

Thank you so much both of you Sincerely

Larb@lette

''larbalette [[#answer-809322|said]]'' <blockquote> ''James [[#answer-809106|said]]'' <blockquote> Do you have the various Gstreamer packages installed? is media.gstreamer.enabled set to true in about:config Also if you do install gstreamer and such packages while Firefox is still running, do restart the Firefox. </blockquote> I have gstreamer installed : media-libs/gstreamer-0.10.36-r2:0.10 But I have no media.gstreamer.enabled key entry in about:config. Is it an issue ? </blockquote> OK. I've just understood that you've meant "installed for Firefox" and not for the whole system, which was my initial understanding. So NO, you're right (and BRILLIANT !), gstreamer was not installed for Firefox. I did compile Firefox again with the gstreamer use flag enabled,and everything is now back in order ! Thank you so much both of you Sincerely Larb@lette
James
  • Top 25 Contributor
  • Moderator
1602 izisombululo 11337 izimpendulo
Kuphostiwe

I did not say for Firefox but rather Firefox may need to be restartedafter installing gstreamer packages so the html5 videos then works.

Otherwise you solved it.

I did not say for Firefox but rather Firefox may need to be restartedafter installing gstreamer packages so the html5 videos then works. Otherwise you solved it.

Umnikazi wombuzo

yes, indeed with Gentoo distribution, Firefox comes with some USE flags that are either ON or OFF, and are adding/removing functionalities.

gstreamer is one of this USE flag, and without you having pointed gstreamer out to me, I wouldn't have never thought of it...

even if gstreamer was already installed on my box independantly, I needed to activate the USE flag as well, and compile firefox again. And then, now, yes : it's working !

Thanks again

yes, indeed with Gentoo distribution, Firefox comes with some USE flags that are either ON or OFF, and are adding/removing functionalities. gstreamer is one of this USE flag, and without you having pointed gstreamer out to me, I wouldn't have never thought of it... even if gstreamer was already installed on my box independantly, I needed to activate the USE flag as well, and compile firefox again. And then, now, yes : it's working ! Thanks again