Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox keeps "hanging up" now that I just changed to WIN10, why?

  • 10 uphendule
  • 2 zinale nkinga
  • 32 views
  • Igcine ukuphendulwa ngu Krava

more options

I've tried the listed solutions, but the problem keeps happening. Please help and Thank you.

All Replies (10)

more options

By "hanging up" do you mean you get "Not Responding" on the Firefox window?

We do have a support article with suggestions for that scenario: Firefox hangs or is not responding - How to fix.

Since Flash can also cause this problem, and is used pervasively through the web, I suggest the following to minimize potential issues with Flash during your troubleshooting:

(1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.)

The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

(2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

more options

I just noticed that you have two versions of the Flash plugin listed next to your question (Question Details > More System Details). Please remove the older one to avoid potential conflicts.

The official way is to use Adobe's uninstaller and then reinstall fresh. Here are the links:

The shortcut which usually works is to physically delete just the old file. To find its exact location and name, you can check the following page: type or paste about:plugins in the address bar and press Enter. Then you can use Find (Ctrl+f) for npswf to skip to Flash plugins listed on the page.

Generally speaking, on 64-bit Windows, it will be a DLL in this folder:

C:\Windows\SysWOW64\Macromed\Flash

You only want to remove the older versions of the files that match this pattern:

NPSWF32_version-number.DLL

The other files should not be removed.

more options

Hi, I tried this solution first, but I'm still having the problem. I going to try your other solution now since this one did not resolve the issue. Thanks for telling me that I had two versions of Flash on my computer.

more options

jscher2000 said

By "hanging up" do you mean you get "Not Responding" on the Firefox window? We do have a support article with suggestions for that scenario: Firefox hangs or is not responding - How to fix. Since Flash can also cause this problem, and is used pervasively through the web, I suggest the following to minimize potential issues with Flash during your troubleshooting: (1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. To set "Ask to Activate", open the Add-ons page using either:
  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.) The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later. (2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:
  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.
more options

Hi jscher2000, I have the done the Flash suggestion and I really like not seeing all the flash junk, BUT, I still have the problem of non-responding. Sometimes, but fortunately not very often, the browser goes non-responding and then crashes. I checked my WIN10 info and went to settings to stop the background apps from running, which actually comes from what I did for the iPad. Thought that might help, but the issue still remains. Also, picked only the apps/programs I use all the time to start during startup, etc. But, I don't think any of this has to do with the non-responding issue. Any more suggestions? Thank you very much for your help, Krava

more options

Hi Krava, when you say --

Sometimes, but fortunately not very often, the browser goes non-responding and then crashes.

-- do you get the Mozilla crash reporter dialog?

In that case, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the support article "Firefox crashes - asking for support" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here.

Also, the Question Details > More System Details on your original post shows the Skype Click to Call extension, which is associated with the problem of non-responsive script dialogs. Some users frustrated with that dialog may extend the runtime allowed before Firefox reports that error. (Warning Unresponsive script - What it means and how to fix it) But extending the time too much can lead to hangs where you never see the dialog.

I'm not sure if that is an issue, but I do suggest disabling that Skype extension and any other unnecessary add-ons. You can do that on Firefox's Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
  • in the Windows "Run" dialog, type or paste
    firefox.exe "about:addons"

In the left column, click Plugins. Set nonessential and unrecognized plugins to "Never Activate".

In the left column, click Extensions. Then, if in doubt, disable (or Remove, if possible) unrecognized and unwanted extensions. Bear in mind that none of these came with Firefox, they are all optional.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

more options

Hi jscher2000, I just checked my add-ons and found that Skype extension was already disabled. I only have four add-ons, Troubleshooter that belongs to Firefox, LastPass which I can't live without and is a 110% must have add-on, Coupons at Checkout and, Avast online security. Plugins--The only ones that are set to Always Activate are: Two different coupons printers, yes two as it seems different coupon sites use different coupons printers; Java Platform SE 8 U65; NPLastPass and must have for me; Open H265 video which is supplied by Mozilla; Primetime Content Description Module by Adobe. The rest are marked "ask to activate" or "never activate". "-- do you get the Mozilla crash reporter dialog?" I don't remember, but I will look for it in the future. One more thing I have noticed. The browser seems to slow way down and hang-up while I am reading my Yahoo emails more then any other time. But, that is not the only time. When the browser slow down while doing my Lumosity.com my training is impacted. Anyhow, you have give me many, many suggestions, tips, etc., yet the problem still happens. I'm not sure where to go from here. Many thanks for your help, Krava

more options

Hi Krava, Yahoo mail makes me think of advertising as a possible source of delays. But I'm not familiar with Lumosity. Is it a Flash-based site?

more options

jscher2000 said

Hi Krava, Yahoo mail makes me think of advertising as a possible source of delays. But I'm not familiar with Lumosity. Is it a Flash-based site?

Here is the info about Lumosity -- http://www.lumosity.com/about Yes, they would have to use Flash for the training games to work properly.

FYI--I have just put Chrome on my computer and I have just started using it about an hour ago because Firefox just is not working properly. I do not have the same problem with Chrome, so far. I can easily read my Yahoo mails with no hangups.

more options

Sure wish someone would find the solution to this problem with Firefox. I really do NOT want to change to another browser, but that is looking more and more like the final solution. I have done everything suggested and more, but the problem is still happening.