Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Disable Firefox password manager

  • 1 baphendule
  • 1 inale nkinga
  • 19 views
  • Igcine ukuphendulwa ngu cor-el

more options

I'm a web designer and I'm having an issue were a user who is already logged in arrives on a page which allows them to update information on their account as well as update their password with a set of Current password, New password, re-enter password fields. I'm seeing that in firefox for users with password manager information saved, the first password field filled is being auto-completed by Firefox password manager and the entry field above the password reset section is populated by the username, despite the fact this field is not for a username.

I will note that this issue only occurs when the input field directly above the password field is intentionally blank (value="").

Is there any thing I can do without altering the layout of the page so that Firefox password manager will not incorrectly insert data into this field?

All Replies (1)

more options

That is how the Firefox Password Manager is currently working. It tries to detect the password field by the type="password" attribute and assumes that the name field is the field directly before the password field in the DOM.

Here is an older blog, don't know if this still applies.


  • Bug 1121127 - (passwords-2015) [tracking] Password Manager 2015

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html