Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Many versions ago, I [changed an option] so that pdfs would not open in Firefox; now, in v. 42.0, I have no default/built-in pdf viewer at all.

  • 6 uphendule
  • 3 zinale nkinga
  • 133 views
  • Igcine ukuphendulwa ngu Sannica

more options

I'm not sure how long ago it was, but I decided I didn't want to use Firefox's default pdf viewer at the time, and because things were painfully slow in-browser, I turned off the default viewer and set options to make sure that all pdfs open outside of the browser, and directly in Adobe. I have no recollection of what I did to achieve it at the time.

Now, for v. 42.0 (and 41.0.2, before) when I go to Options > Applications, and select one of the "Adobe Acrobat Document"s, my only options are "Always Ask," "Save File," or "Use Other..." and there are definitely no Firefox viewer options in "Use Other."

With Adobe Reader's newest terms, and the fact that they can now push updates whenever they want, I'd like to just *never* use it again.

How do I get the built-in pdf viewer back? I realize there are other pdf viewers in existence and I'm picking through those, but I'd like to have an in-browser one again too.

Okulungisiwe ngu Sannica

Isisombululo esikhethiwe

Oh, hold on, I missed something. When you go to Options > Application, the content type you want to change is Portable Document Format (PDF) which is the standard application/pdf type. (The others are obscure types like FDFs which are not your problem.) Does that work?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (6)

more options

I believe it used to be: https://mozilla.github.io/pdf.js/

more options

Thanks, that sure looks right!

...I have to admit, though, that what's offered in your link is entirely over my head. Is there a version of this out there somewhere that I can install like I would any other application or add-on? Alternately, is there a dummy guide for how to get from the files in their zip folder to the application functioning as usual in Firefox?

more options

Firefox comes with a built-in PDF Viewer, so you wouldn't have to install this component yourself.

You can check the pdfjs.disabled pref on the about:config page.

You can rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

more options

The Question Details > More System Details next to your question shows two Adobe Acrobat plugins:

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"

Try deleting the extremely ancient one so Firefox can focus on the fresh one. To locate the old plugin, type or paste about:plugins in the address bar and press Enter to load it. You can use Find (Ctrl+f) to look for nppdf in the page. When you see 9.5.5 there should be a full path to the file on disk where you can delete or rename it so Firefox no longer "sees" it.

Okulungisiwe ngu jscher2000

more options

Isisombululo Esikhethiwe

Oh, hold on, I missed something. When you go to Options > Application, the content type you want to change is Portable Document Format (PDF) which is the standard application/pdf type. (The others are obscure types like FDFs which are not your problem.) Does that work?

more options

@jscher2000: Wow, that is super-embarrassing. I couldn't view the end of all the Adobe Acrobat document types, but I'm not sure I would have noticed that they weren't for pdfs anyway. Thank you for the quickfix.

@guigs & @cor-el: cor-el said

Firefox comes with a built-in PDF Viewer, so you wouldn't have to install this component yourself. You can check the pdfjs.disabled pref on the about:config page. You can rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

Thanks for dumbing this down a little for me. Had I actually had the problem I was so certain I did, this would be really helpful. Thanks again.