Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I get "invalid parameters" when trying to play videos in Google Photos

  • 17 uphendule
  • 6 zinale nkinga
  • Igcine ukuphendulwa ngu cor-el

more options

I get the error "invalid parameters" over a dark, snowy screen when trying to play videos from my Google Photos account. I see others have this problem too. "F5" has been suggested as has hardware acceleration but nothing has worked for me. Anyone else have this? I haven't (don't want to) try downloading whole other browsers so I'd love it if we could get this working with Firefox. Thanks!

Ama-screenshot ananyekiwe

Okulungisiwe ngu 26kick

All Replies (17)

more options

I see a number of threads about this on Google's forums, with a range of suggestions (e.g., "Invalid Parameters" - Videos no longer play back - Google Product Forums):

  • Use an extension to force an HTML5 player instead of Flash
  • Use a private/incognito window
  • Turn off ad blockers
  • Reload numerous times

Unfortunately, on the first point, there's a problem. Firefox relies on Microsoft software (Media Foundation) to decode MP4 video and Microsoft never offered that to Windows XP users. If the video can't play successfully in the Flash player, then we're in trouble on XP.

A volunteer can simulate XP to some extent by turning off various video settings. Is there a public page you can share that exhibits this problem, or is the problem only apparent when administering your own Google Photos page?

more options

Hi jscher2000, thanks for the response. There is not a public page I am aware of that exhibits this problem, only videos in my Google Photos account. I think, even if I gave you the account login for my Google Photos, it probably wouldn't help because it has to be done on my machine, with XP and so-forth, is that correct?

I have tried all of those suggestions. The videos playback fine on my phone so I'd love to have a workaround for my desktop. Thanks again, please let me know if there's anything else I can provide to help trouble shoot.

more options

Hmm, I don't have any videos in my Google Photos. (I didn't even realize I had anything in my Google Photos, but apparently when I posted screen shots on Google Groups the images end up there.) What is the easiest way to get a video in there?

more options

Easy. I use GP to backup everything I take with my Android phone's camera. I suppose you could do the same on an iPhone with the GP app. I would think in either case, just go into settings and turn on backup as well as adjust the other things in there like back up only over wifi (if you want), or only while charging, etc. Take a short video and set it to back up right away.

Do you use XP? I guess that would help?

more options

Did you try to clear the cookies and possibly localStorage?

Does anything show up if you paste this in the Web Console (Firefox menu button or Tools > Web Developer)?

  • console.log("localStorage",localStorage,"\n\nsessionStorage",sessionStorage);

Okulungisiwe ngu cor-el

more options

Hi, I have cleared cookies.

What does that "console" do? I see a warning not to paste anything I don't understand, and I definitely don't understand this. :)

more options

I uploaded an MP4 video from my computer and disabled these settings in Firefox (which makes Windows 7 look more like XP in relation to MP4 videos):

  • media.directshow.enabled => false
  • media.mediasource.mp4.enabled => false
  • => false

The site then fell back to Flash and gave me the invalid parameters error (screen shot attached).

When I dig into the source of the page, the video area is a frame with this address:

If I try to load that directly, I get the other "fuzzy background" error "An error occurred. Please try again later." When I look at the URL, I don't actually see the identifier for the video to be played. Hmm... no wonder it's not working.

more options

Well, now I can't get HTML5 to work again, I always get Flash => fail. Not sure what's going on with this video.

more options

I'm glad you got the error to reproduce! Now, I guess, fixing it is another matter. I assume if you don't make your machine look like XP, it works?

more options

If you can't paste then type the text that they propose in the command line to make it possible to paste the code. Otherwise you would have to type the full text without errors I posted above and that is a lot harder.

Evaluating this code will show the data that is stored in localStorage and in sessionStorage in JSON format.

more options

Ok Cor-el, I pasted it. It says "true" four times for localstorage and length : 0 for sessionstorage. Does that help you troubleshoot?

more options

No more answers?

more options

Sorry, I had missed that reply.

That would mean that there are four keys stored in localStorage. I don't know if any of these would matter in your case. Firefox doesn't clear localStorage when you clear the cookies unless you use "Clear Recent History" and include the cookies and set the range to everything.

Alternatively you can paste this code in the command line of the web console:

var P=window.localStorage,L=P.length,i;for(i=L-1;i>=0;i--){K=P.key(i);P.removeItem(K)}
more options

What, exactly, will happen if I paste that in my web console. I would like to know if I will notice any other changes. Thank you.

more options

The items that you see with the console.log("localStorage",localStorage) will be cleared, so you can use this command to clear localStorage only for the domain in the current tab. You can reissue the above posted code to verify that, you should see length:0.

more options

Hi, sorry for the delay. I see length 0 now. Same problem in Google Photos when trying to watch a video. Dark, snowy screen that says invalid parameters. Please advise.

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.