Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox keeps changing the url I entered

  • 4 uphendule
  • 3 zinale nkinga
  • 491 views
  • Igcine ukuphendulwa ngu Issan

more options

I've updated a website. When I paste the url into Firefox it keeps changing it and displaying a different page.

The one I want is http://megalithmovers.org/blog-2015-10-24.htm Firefox keeps changing it to http://megalithmovers.org/blog-2015-01-24.htm Both pages are valid (they have the date in the url as YYYY-MM-DD) I know the url is valid, I've pasted it into other browsers. Somewhere FF must have cached the January page. Being too clever for it's good, it's decided I've mis-typed the url and displayed that page, not the October one. I've deleted all the history for this site, but that makes no difference.

Please don't tell me to reset FF to the default settings - I'll have re-install all the Addons then.

Isisombululo esikhethiwe

http://megalithmovers.org/blog-2015-10-24.htm

I had no trouble with this link.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Isisombululo Esikhethiwe

http://megalithmovers.org/blog-2015-10-24.htm

I had no trouble with this link.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

Thanks for your reply Fred. I didn't expect anyone else to have the same problem. I tried restarting in Safe Mode, but it didn't solve the problem.

As I mentioned in my post, it seems FF must have cached the January page somewhere on my PC (Win7). Can someone point me to where that location might be, so I can check it? Or is there something other I've missed? Thanks.

more options

Hi, you say you've deleted the history, but have you cleared the cache and cookies? - Delete all references to the website in question, as shown under the heading 'How do I remove a single website from my history?' in this article - Delete browsing, search and download history on Firefox, then try the site again.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

Hi Scribe, I checked the cookies (there weren't any set anyway) and I cleared history for that domain under Show All History. No luck.

It wasn't until I went for the History>Clear Recent History>that brought up the pop-up for Clear All History, that in desperation I ticked all the check-boxes and the Time Range to clear as Everything. I noticed that was where the Cache was available to delete. That did the trick, although I've lost all the other history as well.

Thanks for all the suggestions.