Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox keeps nagging me to confirm all my addons and extensions

  • 1 baphendule
  • 1 inale nkinga
  • 6 views
  • Igcine ukuphendulwa ngu cor-el

more options

I have several addons/extensions. Every day or 2 I have to confirm each of them. It takes a long time as is very irritating - it stops me working. I need firefox just to enable them without user intervention. If there are risks I took them into account when choosing the addon - no need to recheck!! See attached image.

All Replies (1)

more options

That can happen if there is a problem with the preferences file (prefs.js).

There is software like Advanced SystemCare with its Surfing Protection feature that can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.


It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this hasn't helped then also delete the addons.json file.

You can use this button to go to the current Firefox profile folder: