Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I want to delete a single entry in a autofill form, highlighting item and pressing delete key doesn't work. Turned off autofill but entry is still suggested.

  • 27 uphendule
  • 8 zinale nkinga
  • 346 views
  • Igcine ukuphendulwa ngu Katie2

more options

The instructions to select the entry (I'm in a Google website search form) and press delete key doesn't work. I followed directions to turn off autofill in forms and it didn't work.

I want to delete some of my prior search terms from the list that Firefox autofills as it is trying to be so helpful. Please!

All Replies (20)

more options

Hi Katie2, could you try deleting them by using Firefox's Search Bar and see whether it works there? (That's the bar which usually is on the right end of the main toolbar and drops down a panel with history, suggestions and icons as you type.)

I have attached a screen shot showing how the search history items are indicated with a little clock face icon to distinguish them from suggestions Google is sending.

If you clear Firefox's search history items and Google still shows historical searches, you may want to tweak your Google settings.

more options

If it's from your Google history, this article may help: Delete searches & browsing activity - Search Help

more options

Hi jsher2000, When I delete a search term in the firefox search bar, it is removed from the drop down list that is already displayed but, when I again click on the term in the box, it is shown right back on the list again.

The web and app activity doesn't show these search terms because I searched for them when I wasn't signed on to my google account.

Thanks.

more options

Can you confirm that you are only talking about the search bar and not the location/address bar?

Try to rename (or delete) the formhistory.sqlite file in the Firefox profile folder to remove all stored form data. Note that search engine websites may also include suggestions that depend on what you have typed so far.


If there are problems with the location/address bar then check for problems with the places.sqlite database file (bookmarks, history) in the Firefox profile folder.

more options

Hi cor-el,

I am searching in the search bar and not location bar. I renamed the formhistory.sqlite file and still the search entry shows in the drop down auto fill box.

I searched someone's name (not a celebrity, etc.) and now I want to delete that so that it doesn't show in the drop down box. I did this when I wasn't signed into my Google acct., so Web and App Activity doesn't show it.

I updated my firefox settings to delete search history when I close the app.

But this is auto fill for a form. I saw a video where they deleted an item (with explorer) easily by just clicking in the search bar, highlighting the search term and pressing delete.

Why can't I do that with Firefox or Google (not in google acct)?

Thanks.

more options

This mozillaZine article explains what to do to accomplish what I'm after, but it doesn't work for me.


http://kb.mozillazine.org/Deleting_autocomplete_entries

Deleting autocomplete entries Image:Autocomplete.png

Some form fields on web pages and the Location Bar and the Search Bar have autocomplete drop down lists that appear with a list of previously-entered data.

To delete individual entries from the Firefox Location Bar, Search Bar, and other form field drop-down lists:

   Click on the text field
   Press the Down key to activate autocomplete
   Highlight the entry you want deleted by using the arrow keys or hovering over it with your mouse
   Press the Delete key (On Mac use "Shift + Delete" or, if using an extended keyboard, "Shift+Backspace"). 

The Up and Down arrow keys, and "Page Up" and "Page Down" all work to activate autocomplete or to move in an Up or Down direction within Autocomplete both selecting (highlighting) and copying the line into the Location Bar.

more options

If it was from Firefox's search and form history, deleting the formhistory.sqlite in your currently active profile folder should have removed it.

Could you test in a private window? You can launch that using either:

Does Firefox show the suggestion there?

more options

Yes, the suggestion is still there in private window.

more options

I'm baffled. Do you use any extensions that might possibly have a search history feature?

Sometimes when Firefox features are broken for no apparent reason, the problem is that the program files got corrupted during the last update. For that, we suggest:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 41.0.1 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) Rename the current program folder, either:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in (A). It should automatically connect to your existing settings.

Can you delete search history entries and have them stay deleted?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Otherwise, there's no reason to keep the old folder except research/curiosity.

more options

Did the clean reinstall and...the darn entry is still showing in the drop down. Mozilla, you are SOOO helpful!

Now what, friends?

more options

I don't mean that snark directed to you friends here, I meant it to "Mozilla".

more options

Although you shouldn't need an add-on for this, you could take a look at this one:

https://addons.mozilla.org/firefox/addon/form-history-control/

more options

Are you sure that you aren't seeing suggestions provided by the search engine website?

For the built-in search bars you can disable the suggestions in "Options/Preferences > Search"

You can't disable the suggestions on the Google website, but you can try a different URL.

Okulungisiwe ngu cor-el

more options

Cor-el, those instructions did work to completely turn off the suggestions.

But, I want to delete select entries. That's what I can't do.


Thanks, anyway.

more options

Hi Katie2, it sounds as though the problem is that the entry you want to get rid of is a Google search suggestion that is an obvious match to the beginning of your query, and not based on anything you have done in the past. This conclusion is based on the following:

  • The suggestion cannot be deleted from Firefox's form/search history
  • The suggestion appears even if you disable Firefox from displaying form/search history
  • The suggestion disappears if you disable Google suggestions
  • The suggestion appears even logged out of Google
  • The suggestion appears even in a private window

Do you get the same suggestion in other browsers?

more options

Suggestions are all or nothing, you either see them when you start typing or they do not show if you disable them. You can't remove (hide) a specific suggestion, you can only remove search terms that are stored as part of saved form data.

more options

Ugh! I googled an old boyfriend's name and - do not want my hubby to see it - I remembered once a while ago when I could delete something I've searched. That's what I get for not testing before I got curious this time!

Is there any solution from a developer in the Mozilla world to delete a suggestion?

I think there is an acronym that describes my predictament: FML.

more options

You can use a Private Browsing mode window (tab) to prevent Firefox from storing session data.

Deleting formhistory.sqlite should remove all saved form data. You can also try to clear the cookies from that site in case data is stored there.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

Okulungisiwe ngu cor-el

more options

How many characters do you need to type before you see the suggestion, and is anyone likely to type that string of characters?

more options

Do you get this suggestion on the Google website or also if you use a built-in Firefox search bar?

If Google shows that name as a suggestion on its website because it is an existing search term then there is not much to do about this.

Note that Google can store search history if you are logged on and have this feature enabled in Google.

About Google Search History - Accounts Help:

  1. 1
  2. 2