X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Getting errors installing sync 1.1

Kuphostiwe

I'm trying to install sync 1.1 following the instructions at https://docs.services.mozilla.com/howtos/run-sync.html#howto-run-sync11

System Ubuntu 14.04 LTS

After downloading the source and trying make-build it reported a number of ssl errors. Following advice online, i installed some python packages which made that error go away. (Wiping the local directory and restarting after each error.)

Now, it's giving me an error related to SQLAlchemy. This is even after a succesfull apt-get install python-sqlalchemy It seems to want a local version.

From the output of make build: (snip) Requirement already up-to-date: docopt in ./lib/python2.7/site-packages/docopt-0.6.2-py2.7.egg (from m etlog-py>=0.9.6->-r dev-reqs.txt (line 20)) Installing collected packages: WebOb, WebTest, Beaker, python-memcached, SQLAlchemy, zope.interface, r epoze.who, zope.deprecation, metlog-cef, scrypt Found existing installation: WebOb 1.4.1 Uninstalling WebOb-1.4.1: Successfully uninstalled WebOb-1.4.1 Running setup.py install for WebOb Found existing installation: WebTest 2.0.18 Uninstalling WebTest-2.0.18: Successfully uninstalled WebTest-2.0.18 Running setup.py install for WebTest Running setup.py install for Beaker Found existing installation: SQLAlchemy 1.0.8 Uninstalling SQLAlchemy-1.0.8: Successfully uninstalled SQLAlchemy-1.0.8 Running setup.py install for SQLAlchemy Running setup.py install for zope.interface Running setup.py install for repoze.who Running setup.py install for zope.deprecation Running setup.py install for metlog-cef Running setup.py install for scrypt Successfully installed Beaker SQLAlchemy WebOb WebTest metlog-cef python-memcached repoze.who scrypt zope.deprecation zope.interface /home/.../server-full/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latestsecurity.html#insecureplatformwarning. InsecurePlatformWarning Traceback (most recent call last): (snip) OSError: [Errno 2] No such file or directory: '/home/.../server-full/local/lib/python2.7/site-packages/SQLAlchemy-1.0.8-py2.7-linux-x86_64.egg'

The file does not exist, as stated, however, SQLAlchemy-0.7.10-py2.7.egg-info does exist in that directory, as does a subdirectory named sqlalchemy.

Am i missing a step or a version?

I'm trying to install sync 1.1 following the instructions at https://docs.services.mozilla.com/howtos/run-sync.html#howto-run-sync11 System Ubuntu 14.04 LTS After downloading the source and trying make-build it reported a number of ssl errors. Following advice online, i installed some python packages which made that error go away. (Wiping the local directory and restarting after each error.) Now, it's giving me an error related to SQLAlchemy. This is even after a succesfull apt-get install python-sqlalchemy It seems to want a local version. From the output of make build: (snip) Requirement already up-to-date: docopt in ./lib/python2.7/site-packages/docopt-0.6.2-py2.7.egg (from m etlog-py>=0.9.6->-r dev-reqs.txt (line 20)) Installing collected packages: WebOb, WebTest, Beaker, python-memcached, SQLAlchemy, zope.interface, r epoze.who, zope.deprecation, metlog-cef, scrypt Found existing installation: WebOb 1.4.1 Uninstalling WebOb-1.4.1: Successfully uninstalled WebOb-1.4.1 Running setup.py install for WebOb Found existing installation: WebTest 2.0.18 Uninstalling WebTest-2.0.18: Successfully uninstalled WebTest-2.0.18 Running setup.py install for WebTest Running setup.py install for Beaker Found existing installation: SQLAlchemy 1.0.8 Uninstalling SQLAlchemy-1.0.8: Successfully uninstalled SQLAlchemy-1.0.8 Running setup.py install for SQLAlchemy Running setup.py install for zope.interface Running setup.py install for repoze.who Running setup.py install for zope.deprecation Running setup.py install for metlog-cef Running setup.py install for scrypt Successfully installed Beaker SQLAlchemy WebOb WebTest metlog-cef python-memcached repoze.who scrypt zope.deprecation zope.interface /home/.../server-full/local/lib/python2.7/site-packages/pip/_vendor/requests/packages/urllib3/util/ssl_.py:90: InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail. For more information, see https://urllib3.readthedocs.org/en/latestsecurity.html#insecureplatformwarning. InsecurePlatformWarning Traceback (most recent call last): (snip) OSError: [Errno 2] No such file or directory: '/home/.../server-full/local/lib/python2.7/site-packages/SQLAlchemy-1.0.8-py2.7-linux-x86_64.egg' The file does not exist, as stated, however, SQLAlchemy-0.7.10-py2.7.egg-info does exist in that directory, as does a subdirectory named sqlalchemy. Am i missing a step or a version?

Isisombululo esikhethiwe

I am not the expert here on hosting your own sync server, however because 1.1. has been decomissioned in production pairing a new device will be really hard. "JPAKE stuff will be broken."

I might start checking out 1.5-> https://docs.services.mozilla.com/sto.../apis-1.5.html#server-syncstorage-api-15

And ask your question in the sync distribution list: [ sync-dev@mozilla.org]

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 18.0 r0
  • VLC media player Web Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • 5.1.30514.0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

Eminye Imininingwane

guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

I am not the expert here on hosting your own sync server, however because 1.1. has been decomissioned in production pairing a new device will be really hard. "JPAKE stuff will be broken."

I might start checking out 1.5-> https://docs.services.mozilla.com/sto.../apis-1.5.html#server-syncstorage-api-15

And ask your question in the sync distribution list: [ sync-dev@mozilla.org]

I am not the expert here on hosting your own sync server, however because 1.1. has been decomissioned in production pairing a new device will be really hard. "JPAKE stuff will be broken." I might start checking out 1.5-> [https://docs.services.mozilla.com/storage/apis-1.5.html#server-syncstorage-api-15] And ask your question in the sync distribution list: [ sync-dev@mozilla.org]

Umnikazi wombuzo

I'm using FF28, so it's 1.1 for me.

Anyway, i got on the irc channel listed at the bottom of the page, and one of the dev fixed the source tree for me and it now works. :) Just got it running this morning!

I'm using FF28, so it's 1.1 for me. Anyway, i got on the irc channel listed at the bottom of the page, and one of the dev fixed the source tree for me and it now works. :) Just got it running this morning!