Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Some Icons not showing up when i try to customize toolbar :/

  • 13 uphendule
  • 10 zinale nkinga
  • 6427 views
  • Igcine ukuphendulwa ngu CouerDeLeon

more options

Hi, recently i have a problem with icons at firefox - some of them just plain disappeared from my navigation bar.

Usually i would go for view>toolbars>customize and then drag the icon back to navigation bar, but there i can't find the respective icons either (in my case Flashblock, Adblock Edge and Blur Icon).

Things i already tried: - "restore default" approach -> didn't work. - removing the 3 addons, then re-installing them -> didn't work - updating the addons -> icons still missing

Do you guys have any idea what to do to get those icons back? ;__;

thanks in advance Yato

Isisombululo esikhethiwe

Try to reset the browser.uiCustomization.state pref on the about:config page via the right-click context menu to the default value to clear the toolbar customization.

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (13)

more options

Your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

Okulungisiwe ngu the-edmeister

more options

What toolbar icons are you talking about?

Are that built-in standard icons or icons added by an extension?


Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
more options

cor-el said

What toolbar icons are you talking about?

The ones you get from installing addons. See Image #1 for visual explanation.


the-edmeister said

>Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

Tried most of the stuff. Safemode is kinda pointless b/c all icons are disabled then, ticking off hardware acceleration didn't do the trick, default theme neither, disabling every extention exept the 3 with missing icon was also failure, same with updating (everything up-to-date).

However i noticed something: The other 2 addons don't have an extra sub-menu when you click them, but Adblock Edge has one and there's a menu point for showing the icon at the toolbar-selection. Problem is that i can't activate the thing at all. I can place the "√", but when i restart it's empty again. Maybe it has something to do with FF classic theme restorer?

more options

Ok so now i switched over to a fresh, new Firefox-Profile (e.g. no addons, nothing), installed adblock edge + flashblock and right from the start the icons were nowhere to be found. Maybe it's just that those 3 addons are not 100% compatible with the recent firefox update and the icons keep disappearing by default. I probably wait a few weeks, if the problem is still there by the time i switch to pale moon or something. :/

more options

Isisombululo Esikhethiwe

Try to reset the browser.uiCustomization.state pref on the about:config page via the right-click context menu to the default value to clear the toolbar customization.

It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

more options

resetting the browser.uiCustomisation finally did the trick. Thanks for the help! :3

more options

I don't have the menu icon on the right of the screen next to the hello icon. also I can't find the forward and back arrows. I did open it in safe mode and fixed an earlier problem but this one came up when I did. If I reinstall firefox it won't help.

more options

Do you see the Navigation Toolbar with the location/address bar in Safe Mode?

Can you post a list of the extensions?

You can use one of these to set which toolbars to show.

  • "3-bar" menu button > Customize > Show/Hide Toolbars
  • View > Toolbars
    You can tap the Alt key or press F10 to show the Menu Bar
  • Right-click empty toolbar area

Click Restore Defaults in the Customize palette to reset the toolbar customization.

Make sure that you do not run Firefox in Full Screen mode (press F11 or Fn + F11 to toggle; Mac: Command+Shift+F).

more options

I tried the second suggestion and it worked, after a fashion. I can live with it. Left clicking the 3 bar menu doesn't work, but right clicking it enables me to get in and do what ever I have to do.

Now if I can figure out why an options tab opens every time I start Firefox I'll be fine

more options

Firefox uses a vertical bar ('|') to separate multiple home pages. You can check the home page setting to see if the about:preferences page is included as one of the home pages (|about:preferences#general).

  • Tools > Options > General > Startup: Home page

This can happen if you click "Use Current Page(s)" to set the home page and about:preferences is open in a tab. You can pin the tab with the about:preferences page via the right-click context menu of the tab to prevent including about:preferences to the home page setting if you want to use this button in "Options/Preferences > General". To set a single page as the home page you can drag the globe/padlock to the toolbar Home button.

more options

I have this same problem and have had through the past 5 upgrades. Have tried the uiCustomization.state pref on the about:config but to no avail. Still cannot find most of my addon icons. If I drag one into the customisation folder while it's open, this icon also disappears and cannot be dragged back to the toolbar. It's annoying especially if an addon I download doesn't automatically add the icon to the toolbar. Is there a limit to the number of addons that FF can handle? This may be one of the problems. Not saying I have every addon ever written but I do have 48 active ones. have included screenshot of Addons collection, and the Customise Toolbar screen

Cheers - Trevor

more options

Did you try to click Restore Defaults in the Customize palette window?


Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Thanks Cor-el the "Did you try to click Restore Defaults in the Customize palette window?" suggestion worked and I finally found the missing icon i was looking for. Cheers for that - Trev

Okulungisiwe ngu CouerDeLeon