Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Text fuzzy after adding a keyframe to css

  • 20 uphendule
  • 1 inale nkinga
  • 402 views
  • Igcine ukuphendulwa ngu bobxzx

more options

After adding a keyframe text marquee, all text on the page in view is fuzzy on page load but clears up after scrolling the marquee out of view & remains ok even returning the marquee back in view. I see the same thing on tables but again scrolling the page clears it up. Don't see this problem with chrome. Obviously the marquee is affecting Firefox's text rendering but is there a fix for this?

Isisombululo esikhethiwe

Ok, scrolling the background did solve the fuzzy text problem. I can live with that but would prefer a fixed background, almost all sites today have it fixed, just seems better that way so hoping firefox will look into figuring out how it can accommodate that mode & keep the text solid. That solves this question but not the problem. thx for the feedback.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (20)

more options

I'm amending the previous post, I uninstalled the latest version of Firefox & put on version 35 which cleared up the text problem except on tables the text problem it's reversed now, ie on latest version, viewing a table that takes up the full screen view text is blurry, on 35 it's clear but if you refresh the page, it goes blurry until you scroll the page to the top of the table then returns to normal so from this experiment, I'd say firefox has a text rendering bug somewhere so I hope this gets figured out, I'd like to have the latest version for the security but won't use it with this fuzzy text.

more options

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

You can check for corrupted and duplicate fonts and other font issues: http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

more options

Thx for the reply but none of that is an issue, I have a validated html that shows fine on chrome. Lengthy text tables are the issue I have with firefox. In the newest version, the text in my tables are fuzzy & stay that way, in older versions, text is fuzzy if you refresh the page in the middle of a table but return to normal scrolling to the top or bottom of the table then remain corrected after that. Firefox has a bug!

more options

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

more options

Thx again for the attempt Fred but problem is still there, turned of all my add ons & turned off hardware accel, tables still go fuzzy like described earlier

more options

I've called the big guys to help you. Good luck.

more options

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))
more options

Well, hope they can figure it out. I took my html & removed everything but 1 table & a header to see if there might be anything in my html causing this problem but no it's still there,

I'm including a link to my sample html that's good for 30 days. For whoever would like to examine it, it will open looking fine. Scroll past the header into the table then refresh the page & watch what happens to the text, you'll see what I'm saying but if you can edit the html & remove the header with only the table & reload it, it will load fuzzy & stay that way.

The link for the html sample is @ http://www76.zippyshare.com/v/VNTIHq52/file.html hope this will help for developers to find this bug.

more options

1 other thing, that test html I tested in version 35, on the latest version the table will likely load fuzzy & stay that way as I experienced but removed it so I can't say for sure.

more options

Dangerous Website Blocked You attempted to access:

http://www76.zippyshare.com/v/VNTIHq52/file.html

This is a known dangerous website. It is recommended that you do NOT visit this site. The detailed report explains the security risks on this site. For your protection, this website has been blocked. Visit Symantec to learn more about phishing and internet security.

more options

Yes, I'm aware of that warning & it's because it's known for having malicious files, I assure you my file is clean & anyways, don't you trust your antivirus to do it's job or have your o/s backed up just in case? There's no other place I can find where you can upload an htm file, if you know of one, pass it along plz

more options

I found another file server to use that didn't activate a security warning so here's that test html again @ http://www.filedropper.com/fuzzytexttesthtml Open it in your browser & see if you can figure out this fuzzy text problem

more options

I loaded the file in my Firefox. I saw nothing wrong.

more options

The page looks fine on load but did you scroll into where only the table part is in view & refresh the page? If you still have solid text then I'd say this is an issue with firefox on xp. I have 3 pc's with xp & does the same on them all. I don't have this problem on chrome or even the crappy old IE8. There's still a plenty of xp users out there & none of the newer windows offer anything more compelling worth switching to for my needs.

more options

It may be something about XP.

more options

Does it make a difference if you disable the background image?

  • Tools > Options > Content : Fonts & Colors > Colors : "Override the colors specified by the page with my selections above" > Always

Note that this setting affects background images, so only use this "Always" choice for testing the file.

more options

Yes, disabling the colors did stabilize the text so is it the background image that's bleeding into the text? If so, is this an issue that's addressable by the developers or something I can add to my stylesheet to fix it?

Okulungisiwe ngu bobxzx

more options

A fixed background image can sometimes cause issues with scrolling with some graphics display drivers.

I assume that making the background image scroll helps as well.

body {
 background-attachment: scroll;
}
more options

Isisombululo Esikhethiwe

Ok, scrolling the background did solve the fuzzy text problem. I can live with that but would prefer a fixed background, almost all sites today have it fixed, just seems better that way so hoping firefox will look into figuring out how it can accommodate that mode & keep the text solid. That solves this question but not the problem. thx for the feedback.

more options

With that question answered, I switched from 35 to current version & text is stable as well.