Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox v40.0.3 does not launch

  • 5 uphendule
  • 2 zinale nkinga
  • 236 views
  • Igcine ukuphendulwa ngu soumenray

more options

I am attempting to create a customized installation package for Mozilla Firefox v40.0.3.


>> OS : Windows 7 SP1 x64 <<----

I have performed a Custom installation of the browser (unchecked 'Install Maintenance Service' check-box).

After successful installation, copied the following files to the respective directories:

1. Copied 'local-settings.js' to 'C:\Program Files (x86)\Mozilla Firefox\defaults\pref'


Contents of this file-----------

pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg");



2. Copied 'mozilla.cfg' to 'C:\Program Files (x86)\Mozilla Firefox'


Contents of this file-----------

// pref("browser.startup.homepage", http://intranet/); pref("browser.shell.checkDefaultBrowser", false); pref("app.update.auto", false); pref("app.update.enabled", false); pref("app.update.service.enabled", false); pref("browser.cache.disk.smart_size.use_old_max", false); pref("browser.search.update", false); pref("datareporting.healthreport.uploadEnabled", false); pref("signon.rememberSignons", false);


After performing these steps, when I attempt to launch firefox, it fails to launch at all. No errors are displayed. In Task manager, I noticed firefox.exe getting invoked but it exits within seconds.

What is the cause? Please help.

Isisombululo esikhethiwe

There are no quotes around the browser.startup.homepage value.

//
pref("browser.startup.homepage", "http://intranet/");
pref("browser.shell.checkDefaultBrowser", false);
pref("app.update.auto", false);
pref("app.update.enabled", false);
pref("app.update.service.enabled", false);
pref("browser.cache.disk.smart_size.use_old_max", false);
pref("browser.search.update", false);
pref("datareporting.healthreport.uploadEnabled", false);
pref("signon.rememberSignons", false);
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

First, remove everything you did to see if Firefox will work properly. You may want to just remove the current Firefox folders and re-install.

If it works, make one change, Then test FF.

more options

Yes. Firefox functions as expected when I remove the 'local-settings.js' and 'mozilla.cfg' files from there respective locations. I dont know what is wrong with the content of these files. I created these referring to instructions provided at [http://kb.mozillazine.org/Locking_pre.../Locking_preferences] .

Please help. I am at my wits end with this.

more options

What ou want to do is above my knowledge. I've called the big guys to help you. Good luck.

more options

Isisombululo Esikhethiwe

There are no quotes around the browser.startup.homepage value.

//
pref("browser.startup.homepage", "http://intranet/");
pref("browser.shell.checkDefaultBrowser", false);
pref("app.update.auto", false);
pref("app.update.enabled", false);
pref("app.update.service.enabled", false);
pref("browser.cache.disk.smart_size.use_old_max", false);
pref("browser.search.update", false);
pref("datareporting.healthreport.uploadEnabled", false);
pref("signon.rememberSignons", false);
more options

Thanks a ton. That resolved the issue.