X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox doesn't relect changes to css

Kuphostiwe

Hello,

I'm web developer and working on a local website. The problem is when I made changes in my css file it won't reflect in firefox when I refresh the page. HTML changes are getting reflected correctly. Only the problem with css files.

I have to refresh the page like 20-30 time and after that css changes are getting reflected.

In all other browser website working fine and also changes are reflected as it should, only firefox creating problems since last some days.

I have tried the following solutions and they are not works if it helps. 1) Try Shift + refresh but not working 2) delete cookies.sqlite but not working 3) Download and install newly download firefox but still no luck. 5) DOM storage is also enabled 4) Also formatted the PC (for other reason :)) and installed Firefox on fresh system but after that also no luck

I'm using latest firefox. Please help me with some solution it's is very problematic in web development, right now I've to use another browser for time being which I don't like, because I love Firefox.

Please reply as soon as possible.

Hello, I'm web developer and working on a local website. The problem is when I made changes in my css file it won't reflect in firefox when I refresh the page. HTML changes are getting reflected correctly. Only the problem with css files. I have to refresh the page like 20-30 time and after that css changes are getting reflected. In all other browser website working fine and also changes are reflected as it should, only firefox creating problems since last some days. I have tried the following solutions and they are not works if it helps. 1) Try Shift + refresh but not working 2) delete cookies.sqlite but not working 3) Download and install newly download firefox but still no luck. 5) DOM storage is also enabled 4) Also formatted the PC (for other reason :)) and installed Firefox on fresh system but after that also no luck I'm using latest firefox. Please help me with some solution it's is very problematic in web development, right now I've to use another browser for time being which I don't like, because I love Firefox. Please reply as soon as possible.

Isisombululo esikhethiwe

cor-el said

Does it has effect if you disable the HTTP cache and mixed set network.http.use-cache to false as a test? Are you using server or proxy software to access the pages locally? It is possible that other software is caching pages if a reload with bypassing the cache isn't working. Does this also happen when pages are uploaded to the internet or only with local access?

I'm using PHP with Apache for local website files. It works if i set network.http.use-cache to false. But is that normal? don't it take too much time to load internet pages?

Funda le mpendulo ngokuhambisana nalesi sihloko 0

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Google Update

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

Eminye Imininingwane

Scott 24 izisombululo 110 izimpendulo
Kuphostiwe

Impendulo Ewusizo

If shift+reload doesn't work there might be a deeper problem with your Firefox profile, but it might be worth trying this:

Pop open Firefox's developer tools (Ctrl + Shift + I in Windows) and head to the tools' settings (gear icon). There's an option in there to disable the browser's cache while you've got the tools open.

If shift+reload doesn't work there might be a deeper problem with your Firefox profile, but it might be worth trying this: Pop open Firefox's developer tools (Ctrl + Shift + I in Windows) and head to the tools' settings (gear icon). There's an option in there to disable the browser's cache while you've got the tools open.

Umnikazi wombuzo

Scott said

If shift+reload doesn't work there might be a deeper problem with your Firefox profile, but it might be worth trying this: Pop open Firefox's developer tools (Ctrl + Shift + I in Windows) and head to the tools' settings (gear icon). There's an option in there to disable the browser's cache while you've got the tools open.

As you said I tried disabled the cache in developer window (Ctrl + Shift + I) and it is working fine while developer window is open. But what about normal use is there any other solutions?

''Scott [[#answer-783311|said]]'' <blockquote> If shift+reload doesn't work there might be a deeper problem with your Firefox profile, but it might be worth trying this: Pop open Firefox's developer tools (Ctrl + Shift + I in Windows) and head to the tools' settings (gear icon). There's an option in there to disable the browser's cache while you've got the tools open. </blockquote> As you said I tried disabled the cache in developer window (Ctrl + Shift + I) and it is working fine while developer window is open. But what about normal use is there any other solutions?
Scott 24 izisombululo 110 izimpendulo
Kuphostiwe

Ctrl+Shift+R (or ctrl+F5) should achieve the same effect.

Ctrl+Shift+R (or ctrl+F5) should achieve the same effect.
cor-el
  • Top 10 Contributor
  • Moderator
17425 izisombululo 157481 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Does it has effect if you disable the HTTP cache and mixed set network.http.use-cache to false as a test?

Are you using server or proxy software to access the pages locally?

It is possible that other software is caching pages if a reload with bypassing the cache isn't working.

Does this also happen when pages are uploaded to the internet or only with local access?

Does it has effect if you disable the HTTP cache and mixed set network.http.use-cache to false as a test? Are you using server or proxy software to access the pages locally? It is possible that other software is caching pages if a reload with bypassing the cache isn't working. Does this also happen when pages are uploaded to the internet or only with local access?

Umnikazi wombuzo

Scott said

Ctrl+Shift+R (or ctrl+F5) should achieve the same effect.

No it does not works in my case.

''Scott [[#answer-783314|said]]'' <blockquote> Ctrl+Shift+R (or ctrl+F5) should achieve the same effect. </blockquote> No it does not works in my case.

Isisombululo Esikhethiwe

cor-el said

Does it has effect if you disable the HTTP cache and mixed set network.http.use-cache to false as a test? Are you using server or proxy software to access the pages locally? It is possible that other software is caching pages if a reload with bypassing the cache isn't working. Does this also happen when pages are uploaded to the internet or only with local access?

I'm using PHP with Apache for local website files. It works if i set network.http.use-cache to false. But is that normal? don't it take too much time to load internet pages?

''cor-el [[#answer-783407|said]]'' <blockquote> Does it has effect if you disable the HTTP cache and mixed set network.http.use-cache to false as a test? Are you using server or proxy software to access the pages locally? It is possible that other software is caching pages if a reload with bypassing the cache isn't working. Does this also happen when pages are uploaded to the internet or only with local access? </blockquote> I'm using PHP with Apache for local website files. It works if i set network.http.use-cache to false. But is that normal? don't it take too much time to load internet pages?