X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Constantly getting Secure Connection Failed message even for sites like google.com. Need a solution for non-techie user.

Kuphostiwe

I'm starting to frequently get "Secure Connection Failed" messages when attempting to access web sites. I even got it when trying to access goggle.com. Hard to imagine their security certification is out of date. I did a search in Support but did not see a clear, non-techie answer on how to fix this problem other than reverting to an earlier version of Firefox but do not understand how to do that. I would like to continue using Firefox but if this cannot be remedied I will be switching out of Firefox.

I'm starting to frequently get "Secure Connection Failed" messages when attempting to access web sites. I even got it when trying to access goggle.com. Hard to imagine their security certification is out of date. I did a search in Support but did not see a clear, non-techie answer on how to fix this problem other than reverting to an earlier version of Firefox but do not understand how to do that. I would like to continue using Firefox but if this cannot be remedied I will be switching out of Firefox.

Isisombululo esikhethiwe

hazymsh said

Apparently Firefox is unable to solve this problem I will either hire someone who can solve the problem or stop using Firefox.
We are users helping other users and Firefox is the name of the web browser (third one) as the company is Mozilla.

As cor-el and jscher2000 pointed out a common cause for this is say antivirus or security software intercepting secure connections in their attempts at helping you and instead causing you to have this issue.

What Antivirus and security software do you have installed on Windows as there may be a setting you can change.

Funda le mpendulo ngokuhambisana nalesi sihloko 2

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.15
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • 5.1.40728.0
  • NPWLPG

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

Eminye Imininingwane

the-edmeister
  • Top 25 Contributor
  • Moderator
5406 izisombululo 40245 izimpendulo
Kuphostiwe

Is the date, time, and time zone set correctly in your Win7 installation?

Is the date, time, and time zone set correctly in your Win7 installation?

Impendulo Ewusizo

Well, the date and time display correctly for my time zone on my computer so I assume the answer is yes although I don't know how to confirm this otherwise.

Well, the date and time display correctly for my time zone on my computer so I assume the answer is yes although I don't know how to confirm this otherwise.
cor-el
  • Top 10 Contributor
  • Moderator
17539 izisombululo 158588 izimpendulo
Kuphostiwe

There is security software like Avast and Kaspersky that intercept secure connections and send their own certificate.

If you have Avast then try to disable HTTPS scanning in Avast Web Shield.


If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

There is security software like Avast and Kaspersky that intercept secure connections and send their own certificate. If you have Avast then try to disable HTTPS scanning in Avast Web Shield. *http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/ *https://forum.avast.com/index.php?topic=176073.0 ----- If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate: *chrome://pippki/content/exceptionDialog.xul In the location field of this window type or paste the URL of the website. *retrieve the certificate via the "Get certificate" button *click the "View..." button to inspect the certificate in the Certificate Viewer You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

Impendulo Ewusizo

Apparently Firefox is unable to solve this problem I will either hire someone who can solve the problem or stop using Firefox.

Apparently Firefox is unable to solve this problem I will either hire someone who can solve the problem or stop using Firefox.
jscher2000
  • Top 10 Contributor
8774 izisombululo 71729 izimpendulo
Kuphostiwe

Hi hazymsh, if you like using Firefox, maybe you can take a few more minutes to investigate and provide some information on what you find.

When you get the error page, can you find an error code in parentheses (separated_by_underscore_characters). If you see a section of the page entitled Technical Details, expand that heading to find the error code. This will help identify the source of the problem.

Thanks.

Hi hazymsh, if you like using Firefox, maybe you can take a few more minutes to investigate and provide some information on what you find. When you get the error page, can you find an error code in parentheses (separated_by_underscore_characters). If you see a section of the page entitled Technical Details, expand that heading to find the error code. This will help identify the source of the problem. Thanks.

Umnikazi wombuzo

Here's what displays when there's a failed attempt to access a web site: ____________________________________ Secure Connection Failed

An error occurred during a connection to www.google.com. security library: improperly formatted DER-encoded message. (Error code: sec_error_bad_der)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

_________________________

There is no option for researching "Technical Details".

It's interesting that several sites that I have pinned as tiles on the Tabs page I can go to with no problem. If I enter the name of those same sites in the search field I get the Connection Failed message. Why can I access via tile but not via Google search?

Here's what displays when there's a failed attempt to access a web site: ____________________________________ Secure Connection Failed An error occurred during a connection to www.google.com. security library: improperly formatted DER-encoded message. (Error code: sec_error_bad_der) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem. _________________________ There is no option for researching "Technical Details". It's interesting that several sites that I have pinned as tiles on the Tabs page I can go to with no problem. If I enter the name of those same sites in the search field I get the Connection Failed message. Why can I access via tile but not via Google search?
jscher2000
  • Top 10 Contributor
8774 izisombululo 71729 izimpendulo
Kuphostiwe

Hi hazymsh, thank you for the additional details.

"Error code: sec_error_bad_der" actually is not reported very often on this forum, particularly when accessing well-run sites with normal certificates.

Two users did report getting this error on Google with Firefox 39, but did not follow up with more information about whether they solved it or what the cause was:

I don't think using an earlier version of Firefox is going to resolve this issue.

Next questions:

(1) You mentioned getting this error frequently on websites. Can you access my test page without error, or same error code, or a different error code:

https://jeffersonscher.com/res/jstest.php

(2) Do you use any filtering software, for example, security suites that intercept secure connections (Avast, AVG, BitDefender, ESET, Kaspersky) or parental control software?

Hi hazymsh, thank you for the additional details. "Error code: sec_error_bad_der" actually is not reported very often on this forum, particularly when accessing well-run sites with normal certificates. Two users did report getting this error on Google with Firefox 39, but did not follow up with more information about whether they solved it or what the cause was: * [https://support.mozilla.org/questions/1075060 Since Firefox 39.0, getting "sec_error_bad_der" at Google sites] * [https://support.mozilla.org/questions/1071208 I keep getting an error when I search for anything in Google] I don't think using an earlier version of Firefox is going to resolve this issue. Next questions: (1) You mentioned getting this error frequently on websites. Can you access my test page without error, or same error code, or a different error code: https://jeffersonscher.com/res/jstest.php (2) Do you use any filtering software, for example, security suites that intercept secure connections (Avast, AVG, BitDefender, ESET, Kaspersky) or parental control software?
James
  • Top 25 Contributor
  • Moderator
1598 izisombululo 11290 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

hazymsh said

Apparently Firefox is unable to solve this problem I will either hire someone who can solve the problem or stop using Firefox.
We are users helping other users and Firefox is the name of the web browser (third one) as the company is Mozilla.

As cor-el and jscher2000 pointed out a common cause for this is say antivirus or security software intercepting secure connections in their attempts at helping you and instead causing you to have this issue.

What Antivirus and security software do you have installed on Windows as there may be a setting you can change.

''hazymsh [[#answer-783784|said]]'' <blockquote> Apparently Firefox is unable to solve this problem I will either hire someone who can solve the problem or stop using Firefox. </blockquote>We are users helping other users and Firefox is the name of the web browser (third one) as the company is Mozilla. As cor-el and jscher2000 pointed out a common cause for this is say antivirus or security software intercepting secure connections in their attempts at helping you and instead causing you to have this issue. What Antivirus and security software do you have installed on Windows as there may be a setting you can change.
andycruce 1 izisombululo 13 izimpendulo
Kuphostiwe

I tried your website and got the following security message:

effersonscher.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)

I had McAfee and Norton 360 running. Somehow McAfee got installed without my knowledge. I deleted the McAfee software and got the same message. Not having a problem using Internet Explorer and haven't had this problem before using FF.

I tried your website and got the following security message: effersonscher.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer) I had McAfee and Norton 360 running. Somehow McAfee got installed without my knowledge. I deleted the McAfee software and got the same message. Not having a problem using Internet Explorer and haven't had this problem before using FF.
jscher2000
  • Top 10 Contributor
8774 izisombululo 71729 izimpendulo
Kuphostiwe

Hi andycruce, I will reply under your new question here: https://support.mozilla.org/questions/1087594

Hi andycruce, I will reply under your new question here: https://support.mozilla.org/questions/1087594

Umnikazi wombuzo

Andycruce and Jscher2000, I'm not sure if the posts were directed to me but the problem I was having was solved by changing the settings to Avast suggested in an earlier post. Thanks for the help.

Andycruce and Jscher2000, I'm not sure if the posts were directed to me but the problem I was having was solved by changing the settings to Avast suggested in an earlier post. Thanks for the help.