X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't play videos in Twitter

Kuphostiwe

Videos on Twitter don't play, "The message This browser does not support video playback." appears on the center of a screenshot of the video. Twitter Videos play normally on Chrome. YouTube videos play normally on Firefox.

I have the latest version of Firefox and all the plugins are up to date (Java, Flash Player etc). I have experimented changing Hardware Acceleration Where Available box, the media.windows-media-foundation.enabled attribute, clearing the caches, opening in safe mode, nothing makes the videos play.


Is there anyone who has had the same problem and managed to solve it. Thank you.

Videos on Twitter don't play, "The message This browser does not support video playback." appears on the center of a screenshot of the video. Twitter Videos play normally on Chrome. YouTube videos play normally on Firefox. I have the latest version of Firefox and all the plugins are up to date (Java, Flash Player etc). I have experimented changing Hardware Acceleration Where Available box, the media.windows-media-foundation.enabled attribute, clearing the caches, opening in safe mode, nothing makes the videos play. Is there anyone who has had the same problem and managed to solve it. Thank you.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Google Update
  • Next Generation Java Plug-in 11.60.2 for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Shockwave Flash 18.0 r0
  • 5.1.30514.0
  • VLC media player Web Plugin 2.0.6
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • Firefox 40.0.3
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 5.1; rv:40.0) Gecko/20100101 Firefox/40.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/40.0.3/WINNT/en-US/

Izandiso

  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.2.1-signed (adblockpopups@jessehakanen.net)
  • Advertising Cookie Opt-out 1.5 (optout@google.com)
  • Classic Theme Restorer 1.3.8 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Customizable Shortcuts 0.9.8 (customizable-shortcuts@timtaubert.de)
  • Download Manager (S3) 3.11.1-signed (s3download@statusbar)
  • Easy Youtube Video Downloader Express 9.02 ({b9acf540-acba-11e1-8ccb-001fd0e08bd4})
  • feedly 16.0.528.1-signed (feedly@devhd)
  • FireGestures 1.8.7.1-signed (firegestures@xuldev.org)
  • Hide Caption Titlebar Plus 2.8.9 (hidecaptionplus-dp@dummy.addons.mozilla.org)
  • Lazarus: Form Recovery 2.3.1-signed (lazarus@interclue.com)
  • MClickFocusTab 20.0.20150603 (mclickfocustab@moztw.org)
  • Page Zoom Button 1.4.1.1-signed (54c7d9671b9eccd9e5686a73df34ab60@button.codefisher.org)
  • ReminderFox 2.1.5.2.1-signed ({ada4b710-8346-4b82-8199-5de2b400a6ae})
  • Tile Tabs 13.3 (tiletabs@DW-dev)
  • Twitter App 38.1 ({12b6fdcd-4423-4276-82a3-73fdbff5f7e4})
  • X-notifier 3.5.12 ({37fa1426-b82d-11db-8314-0800200c9a66})
  • YouTube mp3 1.0.9.1-signed (info@youtube-mp3.org)
  • anonymoX 2.5.1 (client@anonymox.net) (Akusebenzi)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Akusebenzi)
  • Nav Bar on Title Bar 1.0.1-signed (navbarontop@digimarco.com) (Akusebenzi)
  • Personal Titlebar 2.0.20140918.1-signed (personaltitlebar@moztw.org) (Akusebenzi)
  • YouTube Unblocker 0.6.17 (youtubeunblocker@unblocker.yt) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0126
  • adapterDeviceID2:
  • adapterDrivers: igxprd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 11-21-2011
  • driverDate2:
  • driverVersion: 6.14.10.5394
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedDriver']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRendererMessage: [u'blockedDriver']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Yebo
  • Ukufinyeleleka: Cha
FredMcD
  • Top 10 Contributor
4220 izisombululo 58909 izimpendulo
Kuphostiwe

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac:<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow.


Go to the web page. Once the page is loading, mouse to the address bar and Left click the icon. A window for displaying site information should come up. Select More Information. Now select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac:<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins.''' Make sure the ones you want to use are set to '''Ask''' or '''Allow.''' -------------- Go to the web page. Once the page is loading, mouse to the address bar and '''Left''' click the icon. A window for displaying site information should come up. Select '''More Information.''' Now select '''Permissions.''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow.'''

Umnikazi wombuzo

Thanks for the reply, but it didn't work. Problem persists.

Thanks for the reply, but it didn't work. Problem persists.
FredMcD
  • Top 10 Contributor
4220 izisombululo 58909 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? --------------------- check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''
jscher2000
  • Top 10 Contributor
8632 izisombululo 70604 izimpendulo
Kuphostiwe

What happens if you try to load that MP4 directly? https://video.twimg.com/ext_tw_video/640920500705861632/pu/vid/240x180/vs9aHUFkVV4z5w5V.mp4

On Windows XP, Firefox does not have the necessary code to play MP4s itself, a plugin is needed. Twitter may not be handling that in the best way, so I guess the question is whether it's possible to help it along by disabling a setting somewhere so Twitter uses Flash or another plugin instead.

It's difficult to me to get hands on XP myself, so hopefully someone else can experiment.

What happens if you try to load that MP4 directly? https://video.twimg.com/ext_tw_video/640920500705861632/pu/vid/240x180/vs9aHUFkVV4z5w5V.mp4 On Windows XP, Firefox does not have the necessary code to play MP4s itself, a plugin is needed. Twitter may not be handling that in the best way, so I guess the question is whether it's possible to help it along by disabling a setting somewhere so Twitter uses Flash or another plugin instead. It's difficult to me to get hands on XP myself, so hopefully someone else can experiment.

Umnikazi wombuzo

Thank you both for your time and effort.

FredMcD, the situation remains the same in Safe Mode.

jscher2000, the mp4 video doesn't play on its own, so I guess it's a matter of handling the mp4 videos on Firefox. This is rather unfortunate, as Chrome plays these videos fine. I hope there is a solution, as I can't change the OS for various reasons.

Thanks again for your help.

Thank you both for your time and effort. FredMcD, the situation remains the same in Safe Mode. jscher2000, the mp4 video doesn't play on its own, so I guess it's a matter of handling the mp4 videos on Firefox. This is rather unfortunate, as Chrome plays these videos fine. I hope there is a solution, as I can't change the OS for various reasons. Thanks again for your help.
jscher2000
  • Top 10 Contributor
8632 izisombululo 70604 izimpendulo
Kuphostiwe

Hmm, when you opened the MP4 directly, I would have though the VLC plugin would jump in and play it. Could you check whether any of your plugins handle MP4? You can check that as follows:

Type or paste about:plugins in the address bar and press Enter. Then use Find (Ctrl+f) to search for mp4 in the page. Since I don't use VLC but I do have QuickTime, for me QuickTime would handle a "stand-alone" MP4.

But in the case that the page uses an HTML5 player without checking whether Firefox can play MP4 in that player, which is a problem on XP, the plugin might not kick in. Hopefully someone knows of a technique to lead the page to use a plugin instead.

Hmm, when you opened the MP4 directly, I would have though the VLC plugin would jump in and play it. Could you check whether any of your plugins handle MP4? You can check that as follows: Type or paste '''about:plugins''' in the address bar and press Enter. Then use Find (Ctrl+f) to search for ''mp4'' in the page. Since I don't use VLC but I do have QuickTime, for me QuickTime would handle a "stand-alone" MP4. But in the case that the page uses an HTML5 player without checking whether Firefox can play MP4 in that player, which is a problem on XP, the plugin might not kick in. Hopefully someone knows of a technique to lead the page to use a plugin instead.
cor-el
  • Top 10 Contributor
  • Moderator
17409 izisombululo 157269 izimpendulo
Kuphostiwe

On Windows XP you would have to set media.directshow.enabled to false to disable the HTML5 media player and possibly have the website switch to a Flash based player. The error message would suggest that Firefox tries to use the HTML5 media player and that is failing.

Firefox would normally only use a plugin if an OBJECT or EMBED tag is used to play the file.

On Windows XP you would have to set media.directshow.enabled to false to disable the HTML5 media player and possibly have the website switch to a Flash based player. The error message would suggest that Firefox tries to use the HTML5 media player and that is failing. Firefox would normally only use a plugin if an OBJECT or EMBED tag is used to play the file.

Umnikazi wombuzo

Thank you all for your inputs.

jscher2000, I triwd to install the Quicktime plugin, but FF doesn't support its previous version that works with XP and the latest update requires Windows Vista or higher.

cor-el, setting media.directshow.enabled to false doesn't solve the problem.

I guess I will have to continue using Chrome for Twitter, which isn't really something I am happy doing.

Thank you again.

Thank you all for your inputs. jscher2000, I triwd to install the Quicktime plugin, but FF doesn't support its previous version that works with XP and the latest update requires Windows Vista or higher. cor-el, setting media.directshow.enabled to false doesn't solve the problem. I guess I will have to continue using Chrome for Twitter, which isn't really something I am happy doing. Thank you again.
capot1948 0 izisombululo 20 izimpendulo
Kuphostiwe

Same problem here. I'm running Ubuntu Linux 14.04.3 Firefox 40.0.3 Started about the same time as the original poster.

Same problem here. I'm running Ubuntu Linux 14.04.3 Firefox 40.0.3 Started about the same time as the original poster.
jscher2000
  • Top 10 Contributor
8632 izisombululo 70604 izimpendulo
Kuphostiwe

Impendulo Ewusizo

The video.js library used by Twitter is supposed to "fall back" to Flash when the HTML5 player doesn't support the available formats, but it's failing and I can't tell why.

I tried to develop a user script to embed a plugin but I just can't get it to work correctly (for example, zoomed too much, no controls, etc.). The best I could do is display a link to open the media in a new tab and if you have a plugin that plays MP4s, such as QuickTime or VLC, that should play the media in the new tab.

Maybe someone else can take it the next mile.

Note: To install the user script, you need the Greasemonkey extension first:

https://addons.mozilla.org/firefox/addon/greasemonkey/

Then see:

https://greasyfork.org/en/scripts/12427-twitter-html5-video-error-to-link

The video.js library used by Twitter is supposed to "fall back" to Flash when the HTML5 player doesn't support the available formats, but it's failing and I can't tell why. I tried to develop a user script to embed a plugin but I just can't get it to work correctly (for example, zoomed too much, no controls, etc.). The best I could do is display a link to open the media in a new tab and if you have a plugin that plays MP4s, such as QuickTime or VLC, that should play the media in the new tab. Maybe someone else can take it the next mile. Note: To install the user script, you need the Greasemonkey extension first: https://addons.mozilla.org/firefox/addon/greasemonkey/ Then see: https://greasyfork.org/en/scripts/12427-twitter-html5-video-error-to-link

Umnikazi wombuzo

Thank you so much jscher! This helps a lot, at least won't have to use a different browser to watch a video. Thanks for your time and effort.

Thank you so much jscher! This helps a lot, at least won't have to use a different browser to watch a video. Thanks for your time and effort.
no1wammy 0 izisombululo 18 izimpendulo
Kuphostiwe

I also have this problem as well. The worst part is the method in which you needed to disable hardware acceleration to see some videos also didn't work. This Greasemonkey script looks to be the only way you can view videos on Twitter properly while on Firefox.

If it's not much, when Twitter recognizes a video link, and the Greasemonkey script kicks in, it will tell you which program or plug-in is supposed to handle it. Mine is supposed to be handled by the QuickTime Plug-In version 7.7.6. I never got any notifications to say to enable QuickTime. That could be a clue.

Until further notice, for all Firefox users having this problem, it is highly recommended that you download Greasemonkey as well as jscher's script.

I also have this problem as well. The worst part is the method in which you needed to disable hardware acceleration to see some videos also didn't work. This Greasemonkey script looks to be the only way you can view videos on Twitter properly while on Firefox. If it's not much, when Twitter recognizes a video link, and the Greasemonkey script kicks in, it will tell you which program or plug-in is supposed to handle it. Mine is supposed to be handled by the QuickTime Plug-In version 7.7.6. I never got any notifications to say to enable QuickTime. That could be a clue. Until further notice, for all Firefox users having this problem, it is highly recommended that you download Greasemonkey as well as jscher's script.
sazanqua 0 izisombululo 1 izimpendulo
Kuphostiwe
  • プラグインを無効化
  • プラグインを最新版に更新
  • Safe modeで再起動
  • about:configで値をチェック

以上のようなことをしても解決しない場合、jscher2000氏のスクリプトが大変役立ちました。

1.Greasemonkeyをインストールする [https://addons.mozilla.org/ja/firefox.../greasemonkey/]  GreasemonkeyはFirefoxユーザーが拡張機能を利用しやすくする為のアドオンです。これ自体が動作するのではなく、このアドオンを利用してスクリプトを編集し各ユーザーに合わせたブラウジング環境が作成可能なツールです。

2.Twitter HTML5 Video Error to Linkをダウンロードする [https://greasyfork.org/en/scripts/124.../12427-twitter-html5-video-error-to-link]  この問題だけを解決する為のスクリプトです。Greasemonkeyをインストールしてから上記リンク先の"Install this script?"と記載された緑のリンクをクリックすると自動的にGreasemonkeyへインストールされます。


日本語では以下のスクリプトの編集が必要です

1.Greasemonkeyのメニューから"ユーザースクリプトの管理"を開きます。 2.切り替わったページの"設定"を開きます。 3.スクリプト設定のタブを選択し、"https://amp.twimg.com/*"にカーソルを合わせ、下の"このユーザースクリプトの編集"を開く。 4.13行目の"does not support video playback"を"再生できません"に書き換え保存。 5.3をもう一度繰り返して書き換えられたか確認。

成功していれば、Twitterで再生できなかったmp4動画の再生ボタンをクリックすると画像のようなリンクが現われます。クリックすると新しいタブで動画が再生します。ブラウザ上でTwitter以外ではmp4が再生できる状態(Quick TimeやVLCがインストールされている)が前提の解決法です。


円満な解決法ではありませんが動画のURLを表示させてコピー→新しいタブで開くという煩雑な作業がなくなりました。jscher2000氏を筆頭に参加された皆様に感謝します。

*プラグインを無効化 *プラグインを最新版に更新 *Safe modeで再起動 *about:configで値をチェック 以上のようなことをしても解決しない場合、jscher2000氏のスクリプトが大変役立ちました。 1.Greasemonkeyをインストールする [[https://addons.mozilla.org/ja/firefox/addon/greasemonkey/|https://addons.mozilla.org/ja/firefox/addon/greasemonkey/]]  GreasemonkeyはFirefoxユーザーが拡張機能を利用しやすくする為のアドオンです。これ自体が動作するのではなく、このアドオンを利用してスクリプトを編集し各ユーザーに合わせたブラウジング環境が作成可能なツールです。 2.Twitter HTML5 Video Error to Linkをダウンロードする [[https://greasyfork.org/en/scripts/12427-twitter-html5-video-error-to-link|https://greasyfork.org/en/scripts/12427-twitter-html5-video-error-to-link]]  この問題だけを解決する為のスクリプトです。Greasemonkeyをインストールしてから上記リンク先の"Install this script?"と記載された緑のリンクをクリックすると自動的にGreasemonkeyへインストールされます。 '''日本語では以下のスクリプトの編集が必要です''' 1.Greasemonkeyのメニューから"ユーザースクリプトの管理"を開きます。 2.切り替わったページの"設定"を開きます。 3.スクリプト設定のタブを選択し、"https://amp.twimg.com/*"にカーソルを合わせ、下の"このユーザースクリプトの編集"を開く。 4.13行目の"does not support video playback"を"再生できません"に書き換え保存。 5.3をもう一度繰り返して書き換えられたか確認。 成功していれば、Twitterで再生できなかったmp4動画の再生ボタンをクリックすると画像のようなリンクが現われます。クリックすると新しいタブで動画が再生します。''ブラウザ上でTwitter以外ではmp4が再生できる状態(Quick TimeやVLCがインストールされている)が前提の解決法です。'' 円満な解決法ではありませんが動画のURLを表示させてコピー→新しいタブで開くという煩雑な作業がなくなりました。jscher2000氏を筆頭に参加された皆様に感謝します。
PPNSteve 0 izisombululo 22 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Firefox 42.0 is out and this problem persists,, Not too happy that Firefox and Mozilla don't care about us (10s of thousands) XP users to find a workaround - even if its just a setting to allow us to point to a user/system-installed codec

  • sigh*
Firefox 42.0 is out and this problem persists,, Not too happy that Firefox and Mozilla don't care about us (10s of thousands) XP users to find a workaround - even if its just a setting to allow us to point to a user/system-installed codec *''sigh''*
capot1948 0 izisombululo 20 izimpendulo
Kuphostiwe

Doesn't work in Ubuntu Linux either, Firefox 42.0 Sure wish someone would figure out a fix for Linux!

Doesn't work in Ubuntu Linux either, Firefox 42.0 Sure wish someone would figure out a fix for Linux!

Okulungisiwe ngu capot1948

menothappy 0 izisombululo 3 izimpendulo
Kuphostiwe

I have this problem also. Seems like Mozilla is spelled Microsoft these days.

I have this problem also. Seems like Mozilla is spelled Microsoft these days.
James
  • Moderator
1594 izisombululo 11229 izimpendulo
Kuphostiwe

menothappy said

I have this problem also. Seems like Mozilla is spelled Microsoft these days.

It is a limitation of the old EOL Windows XP.

''menothappy [[#answer-832117|said]]'' <blockquote> I have this problem also. Seems like Mozilla is spelled Microsoft these days. </blockquote> It is a limitation of the old EOL Windows XP.
James
  • Moderator
1594 izisombululo 11229 izimpendulo
Kuphostiwe

capot1948 said

Doesn't work in Ubuntu Linux either, Firefox 42.0 Sure wish someone would figure out a fix for Linux!

Actually HTML5 videos like those of Youtube and Twitter works very well on Linux.

You just need to have the appropriate Gstreamer packages installed.

I cannot say which ones specifically for you as Linux distros may split up the needed Gstreamer packages a bit differently.

''capot1948 [[#answer-801308|said]]'' <blockquote> Doesn't work in Ubuntu Linux either, Firefox 42.0 Sure wish someone would figure out a fix for Linux! </blockquote> Actually HTML5 videos like those of Youtube and Twitter works very well on Linux. You just need to have the appropriate '''Gstreamer''' packages installed. I cannot say which ones specifically for you as Linux distros may split up the needed Gstreamer packages a bit differently.
capot1948 0 izisombululo 20 izimpendulo
Kuphostiwe

Thanks James, when Firefox was updated to V43.0 videos started working again. Now possibly there were Ubuntu updates Gstreamer which I didn't catch also. But, happily it's working again.

Thanks James, when Firefox was updated to V43.0 videos started working again. Now possibly there were Ubuntu updates Gstreamer which I didn't catch also. But, happily it's working again.
PPNSteve 0 izisombululo 22 izimpendulo
Kuphostiwe

James said

menothappy said
I have this problem also. Seems like Mozilla is spelled Microsoft these days.

It is a limitation of the old EOL Windows XP.

Ya know, you CAN install a avc/aac/mp4 (etc) codec in WinXP yourself.. and Firefox _NEEDS_ to allow you to point to it / use it.

''James [[#answer-832156|said]]'' <blockquote> ''menothappy [[#answer-832117|said]]'' <blockquote> I have this problem also. Seems like Mozilla is spelled Microsoft these days. </blockquote> It is a limitation of the old EOL Windows XP. </blockquote> Ya know, you CAN install a avc/aac/mp4 (etc) codec in WinXP yourself.. and Firefox _NEEDS_ to allow you to point to it / use it.