Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox crashes. It doesn't start, even in safe mode.

  • 8 uphendule
  • 7 zinale nkinga
  • 711 views
  • Igcine ukuphendulwa ngu Repli

more options

Crash ID: bp-f3d4cb77-2341-475c-8b36-2b7222150903

Isisombululo esikhethiwe

The first entry is the regular Shockwave Flash plugin that Adobe makes for Linux.

That item would appear as plugin.state.flash on the about:config page/

The second entry is the PepperFlash plugin. I do not know if that plugin would get a different pref name to disable it. You can remove the plugin temporarily from its install location in /usr/lib/mozilla/plugins/ to prevent Firefox from detecting it.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (8)

more options

I might first suggest a malware check: Troubleshoot Firefox issues caused by malware then: Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove your Firefox program files and then reinstall Firefox. This process does not remove your Firefox profile data (such as bookmarks and passwords), since that information is stored in a different location.

To do a clean reinstall of Firefox, please follow these steps: Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from mozilla.org (or choose the download for your operating system and language from this page) and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (or open the Firefox menu New Fx Menu and click the close button Close 29).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Please report back to say if this helped you!

Thank you.

more options

That doesn't solve my issue. If you would have checked, I'm on linux, so no way for any malware or virus attack. Also, I searched the troubleshooting guide before asking, so I found and tried this solution.

I'm still on Chromium, and I don't like, but, at least, it works.

more options

It is an issue with the Pepperflash plugin (libfreshwrapper-pepperflash.so) as you can see in the crash report, so you will have to look there.

You can check for issues caused by plugins and set plugins to "Ask to Activate" on the "Firefox/Tools > Add-ons > Plugins" page.

You can find the installation path of all plugins on the about:config page.

more options

Thank you for your answer, cor-el, at least, you checked the crash report. I know it's an issue with pepperfash plugin. I have to say it's a very bad plugin, as I have a very choppy video playing and now it crashes my firefox.

But, as I say in the thread title, I can't start in safe mode, so no way to apply your suggestions.

How can I deactivate that pepper plugin without needing to start firefox?

more options

You can check the prefs.js file in the Firefox profile folder to see if it has a plugin.state for this plugin and edit the line to set its value to 0 (zero).

  • plugin.state.* (0:Never Activate; 1:Ask to Activate; 2:Always Activate)

You can try to check the pluginreg.dat file for details about this plugin.


more options

Hmmm... I've checked in prefs.js, and it doesn't appear the word 'pepper'. Also it doesn't appear any "plugin state".

But in pluginreg.dat it appears the word 'pepper', but I don't know what to do with it:

Down the [PLUGINS] section:

libflashplayer.so:$ /usr/lib/flashplugin-installer/libflashplayer.so:$ 11.2.202.508:$ 1439448754000:0:0:0:$ Shockwave Flash 11.2 r202:$ Shockwave Flash:$ 2 0:application/x-shockwave-flash:Shockwave Flash:swf:$ 1:application/futuresplash:FutureSplash Player:spl:$ libfreshwrapper-pepperflash.so:$ /usr/lib/mozilla/plugins/libfreshwrapper-pepperflash.so:$ 13.1.2.3:$ 1441014034000:0:0:0:$ Shockwave Flash 13.1 r2:$ Shockwave Flash:$ 2 0:application/x-shockwave-flash:Shockwave Flash:swf:$ 1:application/futuresplash:FutureSplash Player:spl:$

more options

Isisombululo Esikhethiwe

The first entry is the regular Shockwave Flash plugin that Adobe makes for Linux.

That item would appear as plugin.state.flash on the about:config page/

The second entry is the PepperFlash plugin. I do not know if that plugin would get a different pref name to disable it. You can remove the plugin temporarily from its install location in /usr/lib/mozilla/plugins/ to prevent Firefox from detecting it.

more options

cor-el said

The first entry is the regular Shockwave Flash plugin that Adobe makes for Linux. That item would appear as plugin.state.flash on the about:config page/ The second entry is the PepperFlash plugin. I do not know if that plugin would get a different pref name to disable it. You can remove the plugin temporarily from its install location in /usr/lib/mozilla/plugins/ to prevent Firefox from detecting it.

Thanks!

I've opened the terminal, and made this changes

cd /usr/lib/mozilla/plugins/ sudo chmod +007 libfreshwrapper-pepperflash.so sudo mv libfreshwrapper-pepperflash.so libfreshwrapper-pepperflash.so.bak

And the firefox now starts without errors. I still have to check the flash plugin in the pages, like youtube.