Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I prevent Google Translate from displaying its banner unrequested?

  • 10 uphendule
  • 3 zinale nkinga
  • 1007 views
  • Igcine ukuphendulwa ngu robmm76

more options

Frequently, the Translate banner appears at the top of a page when it has not been requested. How can I prevent this without removing the add-on?

Isisombululo esikhethiwe

The screenshots on the Add-ons site do not show all the panels, so I don't know whether removing a banner or toolbar is an option: https://addons.mozilla.org/firefox/addon/s3google-translator/

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (10)

more options

Is it possible that the S3.Google Translator extension is causing this?

more options

Isisombululo Esikhethiwe

The screenshots on the Add-ons site do not show all the panels, so I don't know whether removing a banner or toolbar is an option: https://addons.mozilla.org/firefox/addon/s3google-translator/

more options

I tried the "discontinue translation for this site" option. I'll wait and see if this helps.

more options

I have tried the "discontinue translation for this site" option several times but I keep getting the banner and have to X it.

more options

Is there any difference if you start Firefox in Safe Mode?

If your problem isn't solved yet then you want want to click the Undo button next to the chosen solution to avoid confusion.

more options

When I restart without add-ons the banner does not appear. When I restart Firefox the banner frequently appears.

more options

Whenever Hotmail.com opens my inbox, the Translate banner replaces the Outlook banner with its drop-down boxes. In order to use the drop-down boxes I have to kill the Translate banner. Selecting "discontinue translation for this site" does not prevent the Translate banner from reappearing at some later time.

more options

If this only occurs when that extension is enabled, I suggest complaining to the developer for a fix. There is a support thread on a different forum (http://forums.mozillazine.org/viewtopic.php?f=48&t=2829503) or you can use the developer's email address listed on the Add-ons site.

Otherwise, we might be able to suggest a few tricks to override its behavior, but since that would require installing and using the extension, and it seems to cause so many problems, I don't know that any volunteers will sign up for that!

more options

I'm trying the option "Automatic Site Translation: Disable".

more options

This seems to have solved the problem.