X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't change the default search engine in FF39/40 using mozilla.cfg

Kuphostiwe

I had followed the instructions outlined in this archived thread: https://support.mozilla.org/en-US/questions/1034136

But it appears they no longer function as of firefox 39 and 40. How can I change the default search engine for all of my users back to Google in the current version? Is this going to break all the time?

I had followed the instructions outlined in this archived thread: https://support.mozilla.org/en-US/questions/1034136 But it appears they no longer function as of firefox 39 and 40. How can I change the default search engine for all of my users back to Google in the current version? Is this going to break all the time?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.14
  • Citrix Receiver Plugin (Win32)
  • Citrix Online App Detector Plugin
  • Citrix URL-Redirection Helper Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • 5.1.40728.0
  • VMware Remote Console Plug-in

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4314 izisombululo 60551 izimpendulo
Kuphostiwe

In what way can you not change the engine? What happens?

Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

In what way can you not change the engine? What happens? Bookmark and use this; Download the '''[https://addons.mozilla.org/en-US/firefox/addon/searchreset/ Mozilla Search Reset]''' {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

Umnikazi wombuzo

That doesn't help. I'm deploying non-persistent VMs to my staff and using the mozilla.cfg to customize firefox. Using the preferences in the mozilla.cfg is not successfully changing the default search engine from yahoo to google.

The settings below which seem to have worked in ff37 no longer function, per the thread I linked in the initial post:

pref("browser.search.geoSpecificDefaults", false); pref("browser.search.defaultenginename.US", "data:text/plain,browser.search.defaultenginename.US=Google");

That doesn't help. I'm deploying non-persistent VMs to my staff and using the mozilla.cfg to customize firefox. Using the preferences in the mozilla.cfg is not successfully changing the default search engine from yahoo to google. The settings below which seem to have worked in ff37 no longer function, per the thread I linked in the initial post: pref("browser.search.geoSpecificDefaults", false); pref("browser.search.defaultenginename.US", "data:text/plain,browser.search.defaultenginename.US=Google");
FredMcD
  • Top 10 Contributor
4314 izisombululo 60551 izimpendulo
Kuphostiwe

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


After the problem is fixed, Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.


I've called the big guys to help you. Good luck.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Remove yahoo '''Anything.''' Now do the same in the computers Programs Folder. '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. ------------------ After the problem is fixed, Bookmark and use this; Download the '''[https://addons.mozilla.org/en-US/firefox/addon/searchreset/ Mozilla Search Reset]''' {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page. ------------------ I've called the big guys to help you. Good luck.
the-edmeister
  • Top 25 Contributor
  • Moderator
5420 izisombululo 40434 izimpendulo
Kuphostiwe

russ,

If that just broke with Firefox 40, the solution for Firefox 34.0.5 and Firefox 37.0 may not work with the changes to 'search' in Firefox 40+. The default search engines were move out of the Profile folder to program files omni.ja file to keep them from being 'messed with' by malware, which had been happening. But I am not sure how or why that change would impact the mozilla.cfg prefs you are using. 'We' need cor-el to weigh in here to see what his 'take' is.

russ, If that just broke with Firefox 40, the solution for Firefox 34.0.5 and Firefox 37.0 may not work with the changes to 'search' in Firefox 40+. The default search engines were move out of the Profile folder to program files omni.ja file to keep them from being 'messed with' by malware, which had been happening. But I am not sure how or why that change would impact the mozilla.cfg prefs you are using. 'We' need cor-el to weigh in here to see what his 'take' is.
cor-el
  • Top 10 Contributor
  • Moderator
17692 izisombululo 160067 izimpendulo
Kuphostiwe

See the comments in the source code:

What is the setting for these prefs?

  • browser.search.selectedEngine
  • browser.search.defaultenginename
See the comments in the source code: *http://mxr.mozilla.org/mozilla-release/source/browser/app/profile/firefox.js#387 *http://mxr.mozilla.org/mozilla-release/source/toolkit/components/search/nsSearchService.js What is the setting for these prefs? * browser.search.selectedEngine * browser.search.defaultenginename

Umnikazi wombuzo

browser.search.defaultenginename is exactly what I'm trying to change, I have it set in mozilla.cfg as the following:

pref("browser.search.defaultenginename","data:text/plain,browser.search.defaultenginename=Google");

But in about:config it still shows Yahoo

browser.search.selectedEngine doesn't appear to exist

browser.search.defaultenginename is exactly what I'm trying to change, I have it set in mozilla.cfg as the following: pref("browser.search.defaultenginename","data:text/plain,browser.search.defaultenginename=Google"); But in about:config it still shows Yahoo browser.search.selectedEngine doesn't appear to exist

Umnikazi wombuzo

It looks like the mozilla.cfg is being overwritten by a prior manual change to the settings.

So I switched to lockPref and it shows the right browser in about:config but the search being used is still wrong, it's just going by whatever I manually set in the options screen even after reload.

It looks like the mozilla.cfg is being overwritten by a prior manual change to the settings. So I switched to lockPref and it shows the right browser in about:config but the search being used is still wrong, it's just going by whatever I manually set in the options screen even after reload.
cor-el
  • Top 10 Contributor
  • Moderator
17692 izisombululo 160067 izimpendulo
Kuphostiwe

Did you try these?

pref("browser.search.defaultenginename","Google");
pref("browser.search.defaultenginename.US","data:text/plain,browser.search.defaultenginename.US=Google");
Did you try these? pref("browser.search.defaultenginename","Google"); pref("browser.search.defaultenginename.US","data:text/plain,browser.search.defaultenginename.US=Google");

Umnikazi wombuzo

Yes. No matter what it loads up with whatever I last selected via the gui settings. I've even tried to tell it not to load the geospecific defaults and not to loadfromjars.

It's like something is overriding the mozilla.cfg.

Yes. No matter what it loads up with whatever I last selected via the gui settings. I've even tried to tell it not to load the geospecific defaults and not to loadfromjars. It's like something is overriding the mozilla.cfg.