X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Ctrl Left click switches to new tab

Kuphostiwe

I don't know what happened but I haven't changed any settings and now my Firefox keeps opening new tabs and switching to them even though "When I open a link in a new tab, switch to it immediately" is unchecked in settings and both browser.tabs.loadInBackground and services.sync.prefs.sync.browser.tabs.loadInBackground are set to true in the about:config. I've also tried the extension "Switch to tab no more" and that doesn't work. I have no idea what caused my browser to act this way but it's pretty frustrating.

I don't know what happened but I haven't changed any settings and now my Firefox keeps opening new tabs and switching to them even though "When I open a link in a new tab, switch to it immediately" is unchecked in settings and both browser.tabs.loadInBackground and services.sync.prefs.sync.browser.tabs.loadInBackground are set to true in the about:config. I've also tried the extension "Switch to tab no more" and that doesn't work. I have no idea what caused my browser to act this way but it's pretty frustrating.

Isisombululo esikhethiwe

It depends on whether the link is designed to stay in the same tab or to open a new window. Firefox has a separate preference for each, and only the one for "same tab" is on the Options page.

Give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste tabs and pause while the list is filtered

(3) Double-click the browser.tabs.loadDivertedInBackground preference to switch it from the default value of false to true -- the line should turn bold

Does that help?


Since there are a number of similar-sounding preferences, here is my understanding of when they apply:

  • browser.tabs.loadInBackground => when you open a regular link in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = true, do not make the new tab active
    • In the Options dialog/page, this is controlled by the "When I open a link in a new tab, switch to it immediately" setting.
  • browser.tabs.loadDivertedInBackground => when you divert a script-generated new window to a new tab using Ctrl+click, or when a page uses the target attribute to launch a link in a new window and you divert it to a new tab
    • default = false, make the new tab active
  • browser.tabs.loadBookmarksInBackground => when you load a bookmark in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = false, make the new tab active
Funda le mpendulo ngokuhambisana nalesi sihloko 3

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Intel web components updater - Installs and updates the Intel web components
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • VMware Remote Console Plug-in

Isisebenziso

  • Firefox 40.0.3
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/40.0.3/WINNT/en-US/

Izandiso

  • Adblock Plus 2.6.10 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • LastPass 3.2.16 (support@lastpass.com)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: AMD Radeon HD 5450
  • adapterDescription2:
  • adapterDeviceID: 0x68f9
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 54501092
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 8-3-2015
  • driverDate2:
  • driverVersion: 15.200.1062.1004
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 5450 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
jscher2000
  • Top 10 Contributor
8837 izisombululo 72222 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

It depends on whether the link is designed to stay in the same tab or to open a new window. Firefox has a separate preference for each, and only the one for "same tab" is on the Options page.

Give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste tabs and pause while the list is filtered

(3) Double-click the browser.tabs.loadDivertedInBackground preference to switch it from the default value of false to true -- the line should turn bold

Does that help?


Since there are a number of similar-sounding preferences, here is my understanding of when they apply:

  • browser.tabs.loadInBackground => when you open a regular link in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = true, do not make the new tab active
    • In the Options dialog/page, this is controlled by the "When I open a link in a new tab, switch to it immediately" setting.
  • browser.tabs.loadDivertedInBackground => when you divert a script-generated new window to a new tab using Ctrl+click, or when a page uses the target attribute to launch a link in a new window and you divert it to a new tab
    • default = false, make the new tab active
  • browser.tabs.loadBookmarksInBackground => when you load a bookmark in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = false, make the new tab active
It depends on whether the link is designed to stay in the same tab or to open a new window. Firefox has a separate preference for each, and only the one for "same tab" is on the Options page. Give this a try: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''tabs''' and pause while the list is filtered (3) Double-click the '''browser.tabs.load<u>Diverted</u>InBackground''' preference to switch it from the default value of false to true -- the line should turn bold Does that help? ---- Since there are a number of similar-sounding preferences, here is my understanding of when they apply: * '''browser.tabs.loadInBackground''' => when you open a regular link in a new tab using Ctrl+click (or right-click > Open in a New Tab) ** default = true, do not make the new tab active ** In the Options dialog/page, this is controlled by the "When I open a link in a new tab, switch to it immediately" setting. * '''browser.tabs.load<u>Diverted</u>InBackground''' => when you divert a script-generated new window to a new tab using Ctrl+click, or when a page uses the target attribute to launch a link in a new window and you divert it to a new tab ** default = false, make the new tab active * '''browser.tabs.load<u>Bookmarks</u>InBackground''' => when you load a bookmark in a new tab using Ctrl+click (or right-click > Open in a New Tab) ** default = false, make the new tab active

Impendulo Ewusizo

My main issue was when I Ctrl left clicked on a bookmark and it kept opening to it. That last option, browser.tabs.loadBookmarksInBackground, is the one that did the trick. It was on false but setting it to true fixed it. Thanks!

My main issue was when I Ctrl left clicked on a bookmark and it kept opening to it. That last option, browser.tabs.loadBookmarksInBackground, is the one that did the trick. It was on false but setting it to true fixed it. Thanks!