Search Support

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

applications panel choice not work

  • 10 uphendule
  • 2 zinale nkinga
  • 467 views
  • Igcine ukuphendulwa ngu FredMcD

more options

I set application panel for PDF to open with ADOBE, yet it won't do it, but ASKS EVERY TIME. See pics attached

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the mimeTypes.rdf file. Then rename or delete it. Restart Firefox.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (10)

more options

Isisombululo Esikhethiwe

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the mimeTypes.rdf file. Then rename or delete it. Restart Firefox.

more options

To add a little background to the first reply, there should not be two separate lines for Portable Document Format. That probably indicates that there is some corruption in the settings file that stores the download handler preferences. While in theory you could try to edit that file, if you open and look at it, it's a soup of confusing codes. That why we suggest renaming or deleting the file (while Firefox is closed) so that Firefox starts a new one. Then you can return to the Preferences page and switch it from "Preview in Firefox" to "Use Adobe Reader" again and hopefully this time it will work.

more options

jscher: What is the name of the "settings file that stores the download handler preferences" so I can try to rename or delete? Is it the one FredMcD showed above: "mimeTypes.rdf"? One of you please let me know so I can try what FredMcD said. Thank you both for your help!

more options

P.S. re "Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes" I looked it up and that seems to be a PC program, and I have a Mac and don't find it on my computer by searching. I do have Norton Antivirus and FW items enabled, so I don't guess that would make the pdf prob? Here's that part:

more options

P.S. I do NOT want to OPEN pdf's inside the browser, but want to DOWNLOAD them. Will deleting that mimeTypes.rdf cause it to open in the browser instead?

more options

Hi r7p, deleting mimeTypes.rdf will revert Firefox to the default setting of "Preview in browser" and then you can change it to your preferred handling. See: View PDF files in Firefox or choose another viewer.

more options

Does it show a content type (MIME type) for "Options/Preferences > Applications" for Adobe PDF document (application/pdf)?

more options

cor-el: you said: Does it show a content type (MIME type) for "Options/Preferences > Applications" for Adobe PDF document (application/pdf)?

Who are you talking to-me? When I open options/prefs/applics/adobe PDF it shows below the "content type" bar the TWO names seen in pic above. (my 8/26@2:35pm), which is why I"m going to try deleting that mime file for it to make a new one, then choose the file location to open pdf files again..maybe I'll end up with only ONE of two listed then.

(A side note here, I wish the reply button was below each person's name, instead of below all posts! But I guess I'll just keep typing person's name first so they will know I'm referring to their post. All I see is "was this helpful" and "quote"...not sure if one of those makes a POST A REPLY box below person who posted or not?)

more options

Fred McD & Jscher: Thank you both. I did the deleting that mime file, and it works now! I tested it out. Plus I no longer have TWO pdf applics, so that was the prob too. Thanks again!

more options

Glad to help. Safe surfing.