Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Removal of Search/Browser Drop Down Menu

  • 8 uphendule
  • 4 zinale nkinga
  • 1205 views
  • Igcine ukuphendulwa ngu the-edmeister

more options

Hello,

I do not want the gray drop down (see attached) when I type within the Search or Browser fields.

I have already disabled "Provide search suggestions" in Search Settings, and deleted the other engines.

Additionally, I am now getting suggestions for ADDING other engines.

I just want to be able to enter search criteria without someone constantly finishing my sentence.

Thanks, Rachel

Isisombululo esikhethiwe

Hello Rachel,

  1. Enter about:config in the address bar
  2. Accept the warning
  3. Find the line browser.search.showOneOffButtons
  4. Double-click on the value (true by default) to change to false
  5. Close the tab and restart Firefox

That should be work as you want.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (8)

more options

Isisombululo Esikhethiwe

Hello Rachel,

  1. Enter about:config in the address bar
  2. Accept the warning
  3. Find the line browser.search.showOneOffButtons
  4. Double-click on the value (true by default) to change to false
  5. Close the tab and restart Firefox

That should be work as you want.

more options

this "search bar drop down list" true false setting only works up to Firefox version 42.0b9 browser I really would like to see this fixed quickly

more options

You may have to use the Classic Theme Restorer extension to restore the classic search engine behavior.

  • Bug 1119250 - Remove the old searchbar UI (43+)

Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

more options

nothing changed the only solution is going back to older firefox versions

cor-el said

You may have to use the Classic Theme Restorer extension to restore the classic search engine behavior.
  • Bug 1119250 - Remove the old searchbar UI (43+)
Please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
more options

Did you install the CTR extension and placed a tick in "General UI(1): Old search (experimental)"?

more options

I have installed Firefox 42.0b9 to solve the problem

more options

The drop down box in the search box is just a bad idea

I just installed Firefox 42.0 to get rid of it as the about config browser.search.showOneOffButtons didn't work for me

I ask why it is you Mozilla thinks that having this DROP DOWN covering the page you READING is a good idea , Can you please STOP changing the search , leave it alone

more options

locking this thread as it was about an older version of Firefox and the 'fix' isn't applicable any longer in the Firefox 43 plus versions

Please start your own thread here: https://support.mozilla.org/en-US/questions/new