Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Bookmarks Toolbar Resets to Top - Can't Keep Tabs on Bottom

  • 4 uphendule
  • 10 zinale nkinga
  • 642 views
  • Igcine ukuphendulwa ngu Treg

more options

Upgraded to release 40 on Windows7 this morning and have lost the functionality of an (outdated) plug-in to keep tabs on the bottom. My ideal world is to have tabs on the bottom, the bookmarks toolbar directly above and the stock icons above that.

In fact, my problem is neatly described/illustrated a few months ago: https://support.mozilla.org/en-US/questions/1049464#answer-696937

I've tried without success: 1. Both 'tabs on bottom' plug-ins, separately 2. Creating a completely new user profile 3. Using the stock customize feature (which works after editing but loses the changes when opening a new window or restarting the browser 4. Navigating the fix suggested in the link above to userChrome (does this apply to r. 40+ ?) 5. Going for a walk, grabbing a coffee and trying again.

Ideas welcome and thanks.

Isisombululo esikhethiwe

Woo-hoo - it works! Thanks heaps for your insights and patience.

Pushing my luck here but if there's a simple way to have the bookmarks toolbar directly above the tabs, then that'd be welcome.

Regardless, many thanks.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (4)

more options

Are you using an extension to place the tab bar on bottom?

Did you try to create the chrome folder and the userChrome.css file in this folder like I posted in that thread?

That works for me and I had never had this issue in any Firefox version including the current Nightly build with this code in place.


  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • Paste the code in the userChrome.css file in the editor window
  • Make sure that the userChrome.css file starts with the default @namespace line
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.
    Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file

You can use this button to go to the current Firefox profile folder:

more options

Thanks for the quick and comprehensive comeback Cor-el - appreciated. But muttonhead here just can't get it to work. Here's what I did:

1. Checked the plug-ins were disabled

2. Navigated to the correct profile folder using the in-built FF help

3. Created the userChrome directory, created the userChrome.css file and pasted the content (see screenshot#1) and saved, checking extension as .css

4. Restarted FF but still the tabs are on top (see screenshot#2)

5. Used the 'ChromEdit' plug-in to double check the work and started again from 3.

6. Still no luck

I must be doing something wrong, right?! Conscious I'm outstaying the free support window here......

more options

Did you disable all tab related extensions (do not confuse plugins and extensions)?

Did you check it with all extensions disabled?

I see in the screenshot that you have reset Firefox recently (1439685521387) and created a new profile.

Did you try this in a new profile without any other modifications?

Does other code in the userChrome.css file work?

#urlbar .textbox-input-box {
font-size: 16pt !important; 
}
more options

Isisombululo Esikhethiwe

Woo-hoo - it works! Thanks heaps for your insights and patience.

Pushing my luck here but if there's a simple way to have the bookmarks toolbar directly above the tabs, then that'd be welcome.

Regardless, many thanks.