Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

If I download a file, and click firefox's download manager the entire PC freezes for 30s or so

  • 17 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu lynob

more options

If I download a file, and click firefox's download manager the entire PC freezes for 30s or so. I'm using firefox 39.0.3, on the latest version of manjaro 64 bit xfce, and been having this issue for a while. and hoping for this issue to be fixed each time a new version comes out.

I don't want to reset my profile.

All Replies (17)

more options

Is this when you open the manager, or doing something inside?

Is your Firefox set-up to (virus)scan downloads? Turn it off.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

Usually happens when I click the download manager -> open in folder. Starting in safe mode doesn't solve it.

more options

Is that the only problem? Do you open it during the download? Are you using a download manager?

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Then in the reply box at the bottom of this page, do a right click in the box and select Paste. This will show us your system details. No Personal Information Is Collected.

more options

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the current Firefox profile folder:

more options

yes it is the only problem, yes I'm using flashgot + uget to download big files but small files such as images are downloaded automatically in download manager, so technically when I'm encountering this issue, I'm not using third parties. And no, I don't open it during the download.

Here's the output of about:support

Application Basics

Name: Firefox Version: 39.0.3 Build ID: 20150807021757 User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0 Multiprocess Windows: 0/1 (default: false)


Name: Adblock Plus Version: 2.6.10 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: EverSync - Sync bookmarks, backup your favorites. Version: Enabled: true ID:

Name: Firebug Version: 2.0.11 Enabled: true ID:

Name: FlashGot Version: Enabled: true ID: {19503e42-ca3c-4c27-b1e2-9cdb2170ee34}

Name: Gmail Notifier (restartless) Version: Enabled: true ID: jid0-GjwrPchS3Ugt7xydvqVK4DQk8Ls@jetpack

Name: Google Docs Viewer Version: Enabled: true ID:

Name: LastPass Version: 3.2.16 Enabled: true ID:

Name: Modern Download Manager Version: Enabled: true ID:

Name: Session Sync Version: Enabled: true ID:

Name: Speed Dial [FVD] - New Tab Page, Sync... Version: Enabled: true ID:

Name: Tab Mix Plus Version: Enabled: true ID: {dc572301-7619-498c-a57d-39143191b318}

Name: Tamper Data Version: Enabled: true ID: {9c51bd27-6ed8-4000-a2bf-36cb95c0c947}

Name: Xmarks Version: Enabled: true ID:

Name: Yamli for Firefox Version: Enabled: true ID:


Adapter Description: Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile Asynchronous Pan/Zoom: none Device ID: Mesa DRI Intel(R) Sandybridge Mobile Driver Version: 3.0 Mesa 10.6.3 GPU Accelerated Windows: 0/1 Basic Vendor ID: Intel Open Source Technology Center WebGL Renderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile windowLayerManagerRemote: false AzureCanvasBackend: cairo AzureContentBackend: cairo AzureFallbackCanvasBackend: none AzureSkiaAccelerated: 0

Important Modified Preferences

accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size_cached_value: 215040 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 2 true browser.newtab.url: chrome://fvd.speeddial/content/fvd_about_blank.html browser.places.smartBookmarksVersion: 7 browser.sessionstore.upgradeBackup.latestBuildID: 20150807021757 browser.startup.homepage: about:home browser.startup.homepage_override.buildID: 20150807021757 browser.startup.homepage_override.mstone: 39.0.3 browser.tabs.closeWindowWithLastTab: false browser.tabs.warnOnClose: false browser.urlbar.maxRichResults: 15 dom.mozApps.used: true extensions.lastAppVersion: 39.0.3 media.gmp-gmpopenh264.lastUpdate: 1431943175 media.gmp-gmpopenh264.version: 1.4 media.gmp-manager.buildID: 20150807021757 media.gmp-manager.lastCheck: 1439709439 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1439562343 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true print.print_bgcolor: false print.print_bgimages: false print.print_colorspace: default print.print_downloadfonts: false print.print_duplex: 0 print.print_evenpages: true print.print_in_color: true print.print_margin_bottom: 0.5 print.print_margin_left: 0.5 print.print_margin_right: 0.5 print.print_margin_top: 0.5 print.print_oddpages: true print.print_orientation: 0 print.print_page_delay: 50 print.print_paper_data: 0 print.print_paper_height: 279.40 print.print_paper_name: na_letter print.print_paper_size_type: 1 print.print_paper_size_unit: 1 print.print_paper_width: 215.90 print.print_plex_name: default print.print_resolution_name: default print.print_scaling: 1.00 print.print_shrink_to_fit: true print.print_to_file: false print.print_unwriteable_margin_bottom: 56 print.print_unwriteable_margin_left: 25 print.print_unwriteable_margin_right: 25 print.print_unwriteable_margin_top: 25 privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1437904889

Important Locked Preferences


Incremental GC: true


Activated: false Prevent Accessibility: 0

Library Versions

NSPR Expected minimum version: 4.10.8 Version in use: 4.10.8

NSS Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSMIME Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSSSL Expected minimum version: 3.19.2 Basic ECC Version in use: 3.19.2 Basic ECC

NSSUTIL Expected minimum version: 3.19.2 Version in use: 3.19.2

Experimental Features


Seccomp-BPF (System Call Filtering): true Seccomp Thread Synchronization: false User Namespaces: false Media Plugin Sandboxing: true

more options

please note that I tried using this to solve the problem

but the issue is still there

more options


If I delete those files, won't that reset everything and I have to reinstall my extensions? cause I don't want to do that

more options

lynob said

If I delete those files, won't that reset everything . . . .

That will only reset the preferences to default. Nothing more.

Starting in safe mode doesn't solve it.

Hmm, very odd. Do try removing the preferences as cor-el said.

more options

There's no user.js only one pref.js, I closed firefox, deleted it, then started firefox, didn't solve it, the issue stands, also I reported it on few days ago, no replies yet. This issue isn't new at all and with each release I hope it gets fixed but it doesn't.

more options

Make sure your download history is not too big.

Any download sites that uses Flash for Captcha and Ads on download page, make sure Flash is set to "Ask to Activate" at time. This alone can have a big impact on how smooth the download manager loads during the save, more so on a older lower spec system. Especially if you have had browser running for a while with a lot of downloads previously or currently going on.

Doing the "Ask to Activate" on Flash helped hugely in download stuff on a old Linux box I had before system was taken down by PSU after a bad power outage.

Okulungisiwe ngu James

more options

lynob said

I reported it on few days ago , , , ,

What is the link?

more options

Try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

Try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen).

Try to delete the MRU (Most Recently Used) ComDlg32 registry keys with the registry editor (regedit.exe). Navigate to: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\ComDlg32 Delete the subkeys (LastVisitedPidlMRU and OpenSavePidlMRU)

Be cautious with editing the registry as there is no Undo possible: all changes are applied immediately. You can export registry keys before making changes.

more options

cor-el, much of your reply was for Windows when the user is on 64-bit Linux.

Okulungisiwe ngu James

more options

lynob said

This issue isn't new at all and with each release I hope it gets fixed but it doesn't.

Firefox 40.0 (40.0.2 update last Thursday) has been the current Release since Tuesday Aug 10. The Fx 39.0.3 was a last minute chemspill security update (for 39.0) the week before.

Okulungisiwe ngu James

more options

deleted mimeTypes.rdf , the issue still stands, rest of the answer is for windows, I'm on linux.

I'm using 39.0.3, seems that latest version hasn't yet been pushed to Manjaro repo

link to bug report

more options

btw when I was on Xubuntu, I noticed that Firefox beta, i think it was called next, is extremely better than the stable firefox, I used to use that, now that I'm on manjaro I don't want to install that cause I want to keep my pc stable but if things stay bad, I will have no other option, chrome is slow beast, opera is dead meat and vivaldi is a young child!

And thunar is my file manager btw,

more options

I just updated firefox to 40.0.2 and the issue is still there.