X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

After FF40 update I cannot use Flash player on youtube, video quality is up to 360p.

Kuphostiwe

As title says, everything started on FF40. There are two problems: 1. I can use HTML5 player only which is annoying. I prefer flash but I can't change it anymore on youtube/html5. 2. HTML5 player makes all videos play in 360p quality, there are no higher options available. Please help.

As title says, everything started on FF40. There are two problems: 1. I can use HTML5 player only which is annoying. I prefer flash but I can't change it anymore on youtube/html5. 2. HTML5 player makes all videos play in 360p quality, there are no higher options available. Please help.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.51.2 for Mozilla browsers
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.7.157
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.0
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:40.0) Gecko/20100101 Firefox/40.0

Eminye Imininingwane

Umnikazi wombuzo

Thing is - that changed after FF40 update so it's Firefox's issue. Everything still works like a charm on FF 39.0.3.

Thing is - that changed after FF40 update so it's Firefox's issue. Everything still works like a charm on FF 39.0.3.
jscher2000
  • Top 10 Contributor
8632 izisombululo 70600 izimpendulo
Kuphostiwe

I found a Windows XP system and after about an hour of updates and testing, I think I have a workaround. Which is, lie to YouTube and tell the site you run Firefox 39.

I started by installing Firefox 39.0.3 and got the first screen shot attached. I don't have H.264 support, which I think is the default state for XP. YouTube serves the Flash player.

I upgraded to Firefox 40.0.2 and got the second screen shot attached. YouTube now defaults to HTML5 and WebM, which only offers 360p.

I installed the extension https://addons.mozilla.org/firefox/addon/ua-site-switch/ which admittedly has a confusing interface. I opened its dialog on YouTube and entered this for the user agent:

Mozilla/5.0 (Windows NT 5.1; rv:39.0) Gecko/20100101 Firefox/39.0

Then I launched a private window (so as to avoid any influence of cookies YouTube/Google might have set already) and tested the html5 page again. Back to Firefox 39 behavior, as shown in the third screen shot.

Restarted in Safe Mode (extensions disabled) and opened a video: HTML5 player

Restart in normal mode (extensions enabled) and opened a video: Flash player

I found a Windows XP system and after about an hour of updates and testing, I think I have a workaround. Which is, lie to YouTube and tell the site you run Firefox 39. I started by installing Firefox 39.0.3 and got the first screen shot attached. I don't have H.264 support, which I think is the default state for XP. YouTube serves the Flash player. I upgraded to Firefox 40.0.2 and got the second screen shot attached. YouTube now defaults to HTML5 and WebM, which only offers 360p. I installed the extension https://addons.mozilla.org/firefox/addon/ua-site-switch/ which admittedly has a confusing interface. I opened its dialog on YouTube and entered this for the user agent: Mozilla/5.0 (Windows NT 5.1; rv:39.0) Gecko/20100101 Firefox/39.0 Then I launched a private window (so as to avoid any influence of cookies YouTube/Google might have set already) and tested the html5 page again. Back to Firefox 39 behavior, as shown in the third screen shot. Restarted in Safe Mode (extensions disabled) and opened a video: HTML5 player Restart in normal mode (extensions enabled) and opened a video: Flash player
jscher2000
  • Top 10 Contributor
8632 izisombululo 70600 izimpendulo
Kuphostiwe

Missed something: embedded YouTube videos often launch from a different domain, so you need to apply the same lie to this site as well:

https://www.youtube-nocookie.com/

Missed something: embedded YouTube videos often launch from a different domain, so you need to apply the same lie to this site as well: https://www.youtube-nocookie.com/

Umnikazi wombuzo

Walkaround? For such basic thing, something that should work fawlessly by default? I haven't tried it but what about other sites, do you have to set ua-site-switchseparately in all of them? It's a Firefox's issue and I'm going to wait until it's fixed.

Walkaround? For such basic thing, something that should work fawlessly by default? I haven't tried it but what about other sites, do you have to set ua-site-switchseparately in all of them? It's a Firefox's issue and I'm going to wait until it's fixed.
jscher2000
  • Top 10 Contributor
8632 izisombululo 70600 izimpendulo
Kuphostiwe

Hi penguino, what this workaround demonstrates is that the change in Firefox 40 which is triggering the change on YouTube is just the version number. I'm pretty sure Mozilla isn't going to issue a new version of Firefox 40 with the version number 39.

If you prefer an older version of Firefox, consider the Extended Service Release version. At least that gets security updates. http://www.mozilla.org/firefox/organizations/

Hi penguino, what this workaround demonstrates is that the change in Firefox 40 which is triggering the change on YouTube is ''just the version number.'' I'm pretty sure Mozilla isn't going to issue a new version of Firefox 40 with the version number 39. If you prefer an older version of Firefox, consider the Extended Service Release version. At least that gets security updates. http://www.mozilla.org/firefox/organizations/

Umnikazi wombuzo

You don't think Mozilla is going to fix it? I thought they want Firefox to work properly.

"Extended Service Release" clearly says it's not for me: "Who is it not for? Individual users who always want the latest features"

You don't think Mozilla is going to fix it? I thought they want Firefox to work properly. "Extended Service Release" clearly says it's not for me: "Who is it not for? Individual users who always want the latest features"
jscher2000
  • Top 10 Contributor
8632 izisombululo 70600 izimpendulo
Kuphostiwe

Hi penguino, we are not communicating effectively.

What my test demonstrated is that there is nothing to fix in Firefox 40 to get back to using the Flash player on YouTube for Windows XP users. You just have to change the version number it reports to YouTube from 40 to 39. Boom => Flash.

This is down to how YouTube chooses to structure its pages based on your browser identification. It's not fixable by Mozilla.

Hi penguino, we are not communicating effectively. What my test demonstrated is that there is nothing to fix in Firefox 40 to get back to using the Flash player on YouTube for Windows XP users. You just have to change the version number it reports to YouTube from 40 to 39. Boom => Flash. This is down to how YouTube chooses to structure its pages based on your browser identification. It's not fixable by Mozilla.

Umnikazi wombuzo

So youtube trolled FF users and is now enforcing html player?

PS. I'm going to skip FF40 anyway, it was slower and there was more stuttering than on FF39 which is very smooth and fast, at least on my computer.

So youtube trolled FF users and is now enforcing html player? PS. I'm going to skip FF40 anyway, it was slower and there was more stuttering than on FF39 which is very smooth and fast, at least on my computer.

Okulungisiwe ngu penguino