X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

After FF40 update I cannot use Flash player on youtube, video quality is up to 360p.

Kuphostiwe

As title says, everything started on FF40. There are two problems: 1. I can use HTML5 player only which is annoying. I prefer flash but I can't change it anymore on youtube/html5. 2. HTML5 player makes all videos play in 360p quality, there are no higher options available. Please help.

As title says, everything started on FF40. There are two problems: 1. I can use HTML5 player only which is annoying. I prefer flash but I can't change it anymore on youtube/html5. 2. HTML5 player makes all videos play in 360p quality, there are no higher options available. Please help.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.51.2 for Mozilla browsers
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.7.157
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.0
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:40.0) Gecko/20100101 Firefox/40.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Are you running Windows XP, or a later version of Windows with Firefox set to Windows XP compatibility mode? On Windows XP, Firefox doesn't handle MP4 well or at all.

There are at least two extensions to force YouTube to serve the Flash player, and perhaps one of these would work around the problem:

Are you running Windows XP, or a later version of Windows with Firefox set to Windows XP compatibility mode? On Windows XP, Firefox doesn't handle MP4 well or at all. There are at least two extensions to force YouTube to serve the Flash player, and perhaps one of these would work around the problem: * https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ * https://addons.mozilla.org/firefox/addon/youtube-flash-player/

Umnikazi wombuzo

I have XP indeed but everything was fine on FF39. I just downgraded and youtube works perfectly fine, much faster and smoother than on FF40.

I have XP indeed but everything was fine on FF39. I just downgraded and youtube works perfectly fine, much faster and smoother than on FF40.
EL20 0 izisombululo 17 izimpendulo
Kuphostiwe

Impendulo Ewusizo

jscher2000, I also run Windows XP, and experience the same problem. I think the point penguino is trying to make is that, Firefox 39 had Flash Player by default to run YouTube videos. It is the transition to Firefox 40 which forced the use of HTML5 [regardless of whether Shockwave Flash plugin is set to 'Always Activate' or not].

There should certainly be a way to revert to the old way?

jscher2000, I also run Windows XP, and experience the same problem. I think the point penguino is trying to make is that, Firefox 39 had Flash Player by default to run YouTube videos. It is the transition to Firefox 40 which forced the use of HTML5 [regardless of whether Shockwave Flash plugin is set to 'Always Activate' or not]. There should certainly be a way to revert to the old way?
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Hi EL20, I'm not sure how YouTube decides what player to use, Flash or HTML5. There must be some test it does on Firefox where 39 gives Answer A and 40 gives Answer B, but reading Google's scripts is like torture, so hopefully the explanation will pop up on Google's forum and I won't have to try to understand them!

Hi EL20, I'm not sure how YouTube decides what player to use, Flash or HTML5. There must be some test it does on Firefox where 39 gives Answer A and 40 gives Answer B, but reading Google's scripts is like torture, so hopefully the explanation will pop up on Google's forum and I won't have to try to understand them!

Umnikazi wombuzo

Thing is - on FF39 you can choose the player on your own here: youtube.com/html5

On FF40 you can't, you're stuck with HTML5 player only.

Thing is - on FF39 you can choose the player on your own here: youtube.com/html5 On FF40 you can't, you're stuck with HTML5 player only.
EL20 0 izisombululo 17 izimpendulo
Kuphostiwe

What penguino said above is precisely what I meant, jscher2000.

What penguino said above is precisely what I meant, jscher2000.
EL20 0 izisombululo 17 izimpendulo
Kuphostiwe

Sorry for the double post, but through trial-and-error, I have found a piece of information which may be of interest to you, even if it seems unrelated.

When I launch a YouTube video, it is played using HTML5, as previously described. Now, while the video is playing, if I select 'Clear Recent History' (ticking all of the options except Form & Search History and Cookies), the playback area freezes for a second. Afterwards, video playback resumes, but this time Flash Player is used!

I do not know if this is some kind of bug, but it seems to show that I can still use Flash Player to run YouTube videos somehow; which I am perfectly fine with.

Sorry for the double post, but through trial-and-error, I have found a piece of information which may be of interest to you, even if it seems unrelated. When I launch a YouTube video, it is played using HTML5, as previously described. Now, while the video is playing, if I select 'Clear Recent History' (ticking all of the options except ''Form & Search History'' and ''Cookies''), the playback area freezes for a second. Afterwards, video playback resumes, but this time Flash Player is used! I do not know if this is some kind of bug, but it seems to show that I can still use Flash Player to run YouTube videos somehow; which I am perfectly fine with.

Umnikazi wombuzo

That' how it looks on FF39 while using flash player: https://support.cdn.mozilla.net/media/uploads/images/2015-08-13-11-12-31-333c2a.png

Picture from here so don't mind the codecs. You can request html5 player. If you're using html5 player, there's an option to go back to default (flash) player. Problem is - on FF40 there's no uch option, it forces you to use html5 player and you can't change it. It just says "you're using html5 player" and that's it, you can't switch back to flash player.

That' how it looks on FF39 while using flash player: https://support.cdn.mozilla.net/media/uploads/images/2015-08-13-11-12-31-333c2a.png Picture from [https://support.mozilla.org/en-US/questions/1044212 here ] so don't mind the codecs. You can request html5 player. If you're using html5 player, there's an option to go back to default (flash) player. Problem is - on FF40 there's no uch option, it forces you to use html5 player and you can't change it. It just says "you're using html5 player" and that's it, you can't switch back to flash player.
EL20 0 izisombululo 17 izimpendulo
Kuphostiwe

Again, I second penguino's explanation. I hope you can understand the issue better now, jscher2000, and possibly enlighten us on the root of the problem.

Again, I second penguino's explanation. I hope you can understand the issue better now, jscher2000, and possibly enlighten us on the root of the problem.
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Hi penguino, YouTube has behaved that way for Windows Vista-7 -8-8.1 users for quite a while now.

There are significant differences between XP and later versions because XP doesn't have Media Foundation so Firefox was only able to use Windows to decode MP3s, not MP4s. Since there are hundreds of changes in each version, I can't spot the relevant one.

Could you check these preferences and see whether disabling them helps:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste media. and pause while the list is filtered

(3) If either of these are set to true, try double-clicking to set them to false:

  • media.mediasource.mp4.enabled
  • media.windows-media-foundation.enabled (may not exist)
Hi penguino, YouTube has behaved that way for Windows Vista-7 -8-8.1 users for quite a while now. There are significant differences between XP and later versions because XP doesn't have Media Foundation so Firefox was only able to use Windows to decode MP3s, not MP4s. Since there are hundreds of changes in each version, I can't spot the relevant one. Could you check these preferences and see whether disabling them helps: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media.''' and pause while the list is filtered (3) If either of these are set to true, try double-clicking to set them to false: * media.mediasource.mp4.enabled * media.windows-media-foundation.enabled (may not exist)
EL20 0 izisombululo 17 izimpendulo
Kuphostiwe

I tried performing the steps you explained, jscher2000. I tried various combinations of true/false for the two items you listed. This did not change anything to YouTube video playback. HTML5 would still be used in all cases.

I tried performing the steps you explained, jscher2000. I tried various combinations of true/false for the two items you listed. This did not change anything to YouTube video playback. HTML5 would still be used in all cases.
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

You definitely do not want true for either of those. Possibly some changes do not take effect until after you exit out of Firefox and start it up again.

Since I can't get hands on with XP + Firefox + YouTube myself, I suggest using one of the forced Flash extensions as a temporary workaround if it works.

You definitely do not want true for either of those. Possibly some changes do not take effect until after you exit out of Firefox and start it up again. Since I can't get hands on with XP + Firefox + YouTube myself, I suggest using one of the forced Flash extensions as a temporary workaround if it works.

Umnikazi wombuzo

Or just downgrade to FF39. Works perfectly.

Or just downgrade to FF39. Works perfectly.
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

penguino said

Or just downgrade to FF39.

We have security-related reasons for not recommending that. https://www.mozilla.org/security/known-vulnerabilities/firefox.html

''penguino [[#answer-766945|said]]'' <blockquote> Or just downgrade to FF39. </blockquote> We have security-related reasons for not recommending that. https://www.mozilla.org/security/known-vulnerabilities/firefox.html

Umnikazi wombuzo

I prefer slightly less safe one that WORKS. Safer one but problematic is useless.

I prefer slightly less safe one that WORKS. Safer one but problematic is useless.
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Hi penguino, are you saying that the extensions to force Flash on YouTube did not work for you in Firefox 40, or that you prefer to use Firefox 39 than to use one of those extensions? Let me know if I can't recommend the extensions to other XP users.

Hi penguino, are you saying that the extensions to force Flash on YouTube did not work for you in Firefox 40, or that you prefer to use Firefox 39 than to use one of those extensions? Let me know if I can't recommend the extensions to other XP users.
PPNSteve 0 izisombululo 22 izimpendulo
Kuphostiwe

Firefox's support of HTML5, h.264, and Win XP is just horrible. ALL other browsers support this yet Firefox, one of the best browsers, does not. Not looking good for the future guys.


I do run an extension that allows / chooses flash player when ON youtube's pages but It doesn't work well for embedded videos and many are just horrible at 360p max res. This forces you to use the play on YT link, diverting you away from the posting you were reading that had the embedded video in it.. annoyingly.


FIX IT SO IT JUST WORKS like every other browser.

Firefox's support of HTML5, h.264, and Win XP is just horrible. ALL other browsers support this yet Firefox, one of the best browsers, does not. Not looking good for the future guys. I do run an extension that allows / chooses flash player when ON youtube's pages but It doesn't work well for embedded videos and many are just horrible at 360p max res. This forces you to use the play on YT link, diverting you away from the posting you were reading that had the embedded video in it.. annoyingly. FIX IT SO IT JUST WORKS like every other browser.
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

PPNSteve said

Firefox's support of HTML5, h.264, and Win XP is just horrible. ALL other browsers support this yet Firefox, one of the best browsers, does not. Not looking good for the future guys.

With all due respect, Windows XP is not part of the future, and with limited resources, I do not agree that Mozilla should invest in supporting MP4/H.264 on XP.

''PPNSteve [[#answer-768042|said]]'' <blockquote> Firefox's support of HTML5, h.264, and Win XP is just horrible. ALL other browsers support this yet Firefox, one of the best browsers, does not. Not looking good for the future guys.</blockquote> With all due respect, Windows XP is not part of the future, and with limited resources, I do not agree that Mozilla should invest in supporting MP4/H.264 on XP.
PPNSteve 0 izisombululo 22 izimpendulo
Kuphostiwe

Just because something is old, you don't up and throw it away.. There are 10s of thousands of xp users still out there and many, like myself, can't "just update" due to programs and application needs.

I'm sorry you think otherwise but a MAJOR browser that says the OS is supported should support it fully or at least have all the required features needed before FORCING us on html5 only video players (in YouTube for example) that do not work.

Just because something is old, you don't up and throw it away.. There are 10s of thousands of xp users still out there and many, like myself, can't "just update" due to programs and application needs. I'm sorry you think otherwise but a MAJOR browser that says the OS is supported should support it fully or at least have all the required features needed before FORCING us on html5 only video players (in YouTube for example) that do not work.
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

PPNSteve said

I'm sorry you think otherwise but a MAJOR browser that says the OS is supported should support it fully or at least have all the required features needed before FORCING us on html5 only video players (in YouTube for example) that do not work.

Google chooses the player, not Firefox. As I've said before, I do not know why YouTube serves Firefox 40/XP the HTML5 player when it served the Flash player to Firefox 39/XP. I asked other users to disable some preferences that seemed related but that didn't work. Google's scripts are very complex and it's just something I am not able to research.

''PPNSteve [[#answer-768079|said]]'' <blockquote> I'm sorry you think otherwise but a MAJOR browser that says the OS is supported should support it fully or at least have all the required features needed before FORCING us on html5 only video players (in YouTube for example) that do not work. </blockquote> Google chooses the player, not Firefox. As I've said before, I do not know why YouTube serves Firefox 40/XP the HTML5 player when it served the Flash player to Firefox 39/XP. I asked other users to disable some preferences that seemed related but that didn't work. Google's scripts are very complex and it's just something I am not able to research.