X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Dictionary keeps changing back to default (USA) after I change it to British

Kuphostiwe

Hi there,

I have installed a British dictionary, as I don't use American spelling (I'm Australian).

I've changed the language to British in settings and deleted USA from the options. Every time I close the browser it changes back to the US dictionary and the spellcheck starts correcting me based on USA spelling. I right click a text box, click languages and it's set itself to English (USA).

Is there some way to delete the USA dictionary entirely? Why does it keep changing back to the default?? It's so frustrating!

I am using a Mac, latest OS, with the default Firefox theme.

Thanks in advance, Hayden

Hi there, I have installed a British dictionary, as I don't use American spelling (I'm Australian). I've changed the language to British in settings and deleted USA from the options. Every time I close the browser it changes back to the US dictionary and the spellcheck starts correcting me based on USA spelling. I right click a text box, click languages and it's set itself to English (USA). Is there some way to delete the USA dictionary entirely? Why does it keep changing back to the default?? It's so frustrating! I am using a Mac, latest OS, with the default Firefox theme. Thanks in advance, Hayden

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Provides information about the default web browser
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • 5.1.30514.0

Isisebenziso

  • Firefox 39.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:39.0) Gecko/20100101 Firefox/39.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/39.0/Darwin/en-US/

Izandiso

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • anonymoX 2.4.7.1-signed (client@anonymox.net)
  • Bigger Address Bar Font 1.0.1-signed (bigger-address-bar-font@xrxrxr.com)
  • Ecosia — The search engine that plants trees! 3.3.0.1-signed ({d04b0b40-3dab-4f0b-97a6-04ec3eddbfb0})
  • LastPass 3.2.16 (support@lastpass.com)
  • Self-Destructing Cookies 0.4.7.1-signed (jid0-9XfBwUWnvPx4wWsfBWMCm4Jj69E@jetpack)
  • Vacuum Places Improved 1.2.1-signed (VacuumPlacesImproved@lultimouomo-gmail.com)
  • NoSquint 2.1.9.1-signed (nosquint@urandom.ca) (Akusebenzi)
  • Video DownloadHelper 5.3.1.1-signed ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Akusebenzi)
  • YouTube High Definition 39.0 ({7b1bf0b6-a1b9-42b0-b75d-252036438bdc}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription:
  • adapterDeviceID: 0x68a1
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 5750 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
Banban 57 izisombululo 334 izimpendulo
Kuphostiwe

Hi Hayden,

Did you delete en-us language from the Content panel in the Options? If so, it is the page display language and not spellcheck language.

Moreover, you can't remove default language dictionary of your browser. If you have English (US) version of Firefox, default dictionary is en-us.

So you should uninstall current Firefox and install English (British) version of Firefox (download here).

Hi Hayden, Did you delete '''en-us''' language from the ''Content'' panel in the Options? If so, it is the page display language and not spellcheck language. Moreover, you can't remove default language dictionary of your browser. If you have English (US) version of Firefox, default dictionary is ''en-us''. So you should uninstall current Firefox and install English (British) version of Firefox (download [https://www.mozilla.org/firefox/all/ here]).

Okulungisiwe ngu Banban

cor-el
  • Top 10 Contributor
  • Moderator
17521 izisombululo 158427 izimpendulo
Kuphostiwe

You can find the default dictionaries in the dictionaries folder in the Firefox application folder. Dictionaries that you install yourself are stored in the Firefox profile folder. You can use this button to go to the current Firefox profile folder:

What is the value of the spellchecker.dictionary on the about:config page?

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can find the default dictionaries in the dictionaries folder in the Firefox application folder. Dictionaries that you install yourself are stored in the Firefox profile folder. You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox What is the value of the spellchecker.dictionary on the about:config page? You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config
jiawen 0 izisombululo 9 izimpendulo
Kuphostiwe

I have a similar problem. Firefox keeps resetting itself to the British English dictionary, but I want to use the US English dictionary. I have the default Firefox 39 for my US English Linux Mint 17 install, and spellchecker.dictionary is set to en-US, but Firefox still keeps resetting itself at random intervals to British English. I can download and install the en_US version of Firefox 39, but I'd rather just make this install work correctly. Is there a way to make my designated dictionary persist? Thanks!

I have a similar problem. Firefox keeps resetting itself to the British English dictionary, but I want to use the US English dictionary. I have the default Firefox 39 for my US English Linux Mint 17 install, and spellchecker.dictionary is set to en-US, but Firefox still keeps resetting itself at random intervals to British English. I can download and install the en_US version of Firefox 39, but I'd rather just make this install work correctly. Is there a way to make my designated dictionary persist? Thanks!
cor-el
  • Top 10 Contributor
  • Moderator
17521 izisombululo 158427 izimpendulo
Kuphostiwe

A possibility is to set the spellchecker.dictionary via a user.js file to a predefined setting of your choice. Then at least you have the correct dictionary selected each time you start Firefox.

The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can create a plain text file named user.js in the profile folder.

You can use this button to go to the current Firefox profile folder:

A possibility is to set the spellchecker.dictionary via a user.js file to a predefined setting of your choice. Then at least you have the correct dictionary selected each time you start Firefox. The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session. You can create a plain text file named user.js in the profile folder. *http://kb.mozillazine.org/Editing_configuration *http://kb.mozillazine.org/user.js_file You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox
jiawen 0 izisombululo 9 izimpendulo
Kuphostiwe

Adding a user.js didn't help. However, that prompted me to look in my profile directory and see if there were any other culprits. I opened the prefs.js file and found, on line 788, user_pref("spellchecker.dictionary", "en-GB"); . I changed this to en-US and restarted Firefox. It now seems to be correctly defaulting to US English; hopefully this will be persistent.

Adding a user.js didn't help. However, that prompted me to look in my profile directory and see if there were any other culprits. I opened the prefs.js file and found, on line 788, '''user_pref("spellchecker.dictionary", "en-GB");''' . I changed this to en-US and restarted Firefox. It now seems to be correctly defaulting to US English; hopefully this will be persistent.
jiawen 0 izisombululo 9 izimpendulo
Kuphostiwe

Hmm, that doesn't seem to have worked. Something, I don't know what, reset my dictionary to en-GB without me asking it to. Checking the prefs.js file again, I see it is set to en-GB. What would cause this file to spontaneously change? Is there some part of Firefox that is recalling an earlier (erroneous) setting and recurrently resetting my install to that? Most importantly, how do I prevent this from happening? I'd really like to set Firefox to one language per session, or ideally just one language ever, rather than having to do it at random intervals when Firefox feels like annoying me.

Hmm, that doesn't seem to have worked. Something, I don't know what, reset my dictionary to en-GB without me asking it to. Checking the prefs.js file again, I see it is set to en-GB. What would cause this file to spontaneously change? Is there some part of Firefox that is recalling an earlier (erroneous) setting and recurrently resetting my install to that? Most importantly, how do I prevent this from happening? I'd really like to set Firefox to one language per session, or ideally just one language ever, rather than having to do it at random intervals when Firefox feels like annoying me.
cor-el
  • Top 10 Contributor
  • Moderator
17521 izisombululo 158427 izimpendulo
Kuphostiwe

If you use a user.js file with that user_pref line then at least you should get this dictionary (re)selected on each start.

user_pref("spellchecker.dictionary", "en-US");
If you use a user.js file with that user_pref line then at least you should get this dictionary (re)selected on each start. user_pref("spellchecker.dictionary", "en-US");
jiawen 0 izisombululo 9 izimpendulo
Kuphostiwe

Restarting the browser to get the correct spelling dictionary is rather extreme. Does that mean that there's no permanent way to stop Firefox randomly selecting a different dictionary? I do a lot of work via typing in my browser, so this is a major problem.

Restarting the browser to get the correct spelling dictionary is rather extreme. Does that mean that there's no permanent way to stop Firefox randomly selecting a different dictionary? I do a lot of work via typing in my browser, so this is a major problem.
cor-el
  • Top 10 Contributor
  • Moderator
17521 izisombululo 158427 izimpendulo
Kuphostiwe

There are extensions to change the dictionary that you can look for.

There are extensions to change the dictionary that you can look for. * Dictionary Switcher: https://addons.mozilla.org/firefox/addon/dictionary-switcher/
jiawen 0 izisombululo 9 izimpendulo
Kuphostiwe

Doesn't that just accomplish the same thing as right-clicking and then selecting Languages > Whichever dictionary? I'm not talking about ease of of switching; I'm talking about getting Firefox to stop changing the dictionary by itself. Seems like that shouldn't require an extension to accomplish.

Doesn't that just accomplish the same thing as right-clicking and then selecting Languages > Whichever dictionary? I'm not talking about ease of of switching; I'm talking about getting Firefox to stop changing the dictionary by itself. Seems like that shouldn't require an extension to accomplish.
cor-el
  • Top 10 Contributor
  • Moderator
17521 izisombululo 158427 izimpendulo
Kuphostiwe

Yes, that is basically the same. I don't know what makes Firefox switch the dictionary.

Note that Firefox probably stores such a website related setting in the content-prefs.sqlite file in the profile folder as part of the Site Preferences. So if it keeps going wrong on specific website then consider to clear the Site Preferences or delete the content-prefs.sqlite (you keep the permissions deleting the file).

Yes, that is basically the same. I don't know what makes Firefox switch the dictionary. Note that Firefox probably stores such a website related setting in the content-prefs.sqlite file in the profile folder as part of the Site Preferences. So if it keeps going wrong on specific website then consider to clear the Site Preferences or delete the content-prefs.sqlite (you keep the permissions deleting the file). *http://kb.mozillazine.org/Profile_folder_-_Firefox
jiawen 0 izisombululo 9 izimpendulo
Kuphostiwe

Not only is this problem not solved in Firefox, it now seems to be affecting Thunderbird. I'm now getting Thunderbird selecting UK English as its spelling dictionary all by itself. This appears to also be ignoring my user dictionary, meaning that composing messages in Thunderbird has just become significantly more difficult.

Someone please fix this problem!

Not only is this problem not solved in Firefox, it now seems to be affecting Thunderbird. I'm now getting Thunderbird selecting UK English as its spelling dictionary all by itself. This appears to also be ignoring my user dictionary, meaning that composing messages in Thunderbird has just become significantly more difficult. Someone '''please''' fix this problem!