Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Java Deployment Toolkit

  • 8 uphendule
  • 67 zinale nkinga
  • 79396 views
  • Igcine ukuphendulwa ngu jscher2000

more options

FF has blocked Flashplayer and Java. I have updated both to latest versions BUT Java Deployment Toolkit 8.0.510.16 11.51.2.16 is still blocked and cannot be activated (or apparently updated). The option "ask to activate" is selected but does not do anything. "You cannot UNINSTALL this program because: Why I am not able to run the Java Uninstall tool and the Java verification applet? The Java Uninstall Tool and the Java verification applet uses the Java DT to do Java version detection on the user system. If Java DT is blocked by browser (like Firefox) than these applets will not run. In order to run these applets the user will have to permit Java DT to run in browsers." https://www.java.com/en/download/faq/deployment_toolkit.xml

So, there is a Catch 22. It needs to run itself to uninstall but it can't. How can this be resolved?

As an additional comment - flash and Java run in MS IE - which is considered less secure. Mozilla are forcing people to use an inferior product. Best Regards, Chris

Isisombululo esikhethiwe

Thanks for the further suggestions from theshine and jscher2000. Not sure whether I should just mark this as SOLVED given my reluctant IE workaround. Respectively... As indicated earlier, I did uninstall/reinstall of Java (confirmed both RTEs are up to date). And, my Registry was recently overhauled by Ccleaner. FF add-on for Java DT is set to "ask to activate" but on the page there is just a circle with a cross and "This plug-in is disabled". Manage plug-ins takes me to the add-ons page where "Always activate" is greyed out. Right clicking on the page does not produce a "page option" menu. But, this is visible via, Tools, Page Info, Permissions - where everything is set to default. HOWEVER, with a D'Oh! Whilst the original question is still sound/valid, I was being fooled into thinking the problem (with a particular page) was Java DT - which, as reported I cannot activate to uninstall. The manage plug-ins always seemed to take me to this app that was highlighted. BUT, the actual problem with the web page was Flash plug-in disabled. Page displays once this is activated. Hey ho.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (8)

more options

ChrisJez said

FF has blocked Flashplayer and Java. I have updated both to latest versions BUT Java Deployment Toolkit 8.0.510.16 11.51.2.16 is still blocked and cannot be activated (or apparently updated). The option "ask to activate" is selected but does not do anything. "You cannot UNINSTALL this program because: Why I am not able to run the Java Uninstall tool and the Java verification applet? The Java Uninstall Tool and the Java verification applet uses the Java DT to do Java version detection on the user system. If Java DT is blocked by browser (like Firefox) than these applets will not run. In order to run these applets the user will have to permit Java DT to run in browsers." https://www.java.com/en/download/faq/deployment_toolkit.xml So, there is a Catch 22. It needs to run itself to uninstall but it can't. How can this be resolved? As an additional comment - flash and Java run in MS IE - which is considered less secure. Mozilla are forcing people to use an inferior product. Best Regards, Chris

Hi Chris,

  1. At the beginning, please close all Firefox windows to exit Firefox completely.
  2. Uninstall Java completely via the control panel > uninstall programs. Maybe you should also clean temporary files on your computer.
  3. Start Firefox as usual. Click the menu button, and choose Add-ons. Now click on the "Plugin" section.
  • Java still there? Bad news, follow steps 1 and 2.
  • Java not there? Good news, just follow step 2.

Step 1:

If you can't use an uninstaller program to remove a plugin, you can remove it manually:

  1. Start Firefox.
  2. Type about:plugins into the Location bar and press Enter to display the About Plugins page.
  3. Each entry in the About Plugins page will have "File:" and "Path:", showing the name and location of the plugin file. Use Windows Explorer to navigate to the folder shown for the plugin you want to remove.
  4. Delete the content of the folder.
  5. Restart Firefox.

The plugin will be removed.

Step 2:

  1. Start Firefox.
  2. Type about:support into Location bar.
  3. Click on Show Folder.
  4. Close Firefox.
  5. Delete the file pluginreg.dat.
  6. Restart Firefox.

Now install Java all over again, with Firefox closed from this site: https://www.java.com/de/download/windows_xpi.jsp

Please note: Your O/S Windows XP isn't supported by Oracle anymore. So keep in mind that maybe the add-on itself is incompatible.

If there are any further question, please report back. Thanks.

Regards, Tobias

Okulungisiwe ngu Tobias

more options

Hi Tobias, Many thanks for your fast reply. Good news and bad news. I uninstalled Java and this removed both java RTE and DT from add-ons. Yay, straight to step 2, did the edit, closed FF then restarted and reinstalled Java. Go to webpage - Plugin is disabled; Click manage plug-ins - Java Deployment Tools highlighted. It has reappeared. Back to the square labelled one.

I also know Java is unsupported for XP. I have 8.1 on another PC but like many other users I do not find it comfortable. Best,

more options

ChrisJez said

Hi Tobias, Many thanks for your fast reply. Good news and bad news. I uninstalled Java and this removed both java RTE and DT from add-ons. Yay, straight to step 2, did the edit, closed FF then restarted and reinstalled Java. Go to webpage - Plugin is disabled; Click manage plug-ins - Java Deployment Tools highlighted. It has reappeared. Back to the square labelled one. I also know Java is unsupported for XP. I have 8.1 on another PC but like many other users I do not find it comfortable. Best,

Hi Chris,

Okay, I think Firefox having issues to detect the current version of Java. But, if you've really installed the latest version of Java on your system you can unconcerned proceed with these steps:

CAUTION: These steps deactivate the Firefox blocklist for vulnerable plugins and extensions. Furthermore, vulnerable add-ons will NOT be blocked anymore. Use at your own risk!

  1. Type about:config into Location bar.
  2. Proceed by clicking the button "I'll be careful, I promise!".
  3. Rightclick, to toggle the string extensions.blocklist.enabled from true to false.
  4. Restart Firefox.

See if this help you out. If not try to deactivate your anti virus and try again. Thanks.

Regards,

Tobias

Okulungisiwe ngu Tobias

more options

Hi Tobias, Thanks again. I may have to consult the oracle about this DT issue. Sad and reluctant workaround is to use IE to look at pages/sites that FF won't allow. It seems wiser to leave the blocking in place until everyone gets their acts together.

more options

C:/Programmes/Java/jre "your version"/bin/new_plugin

delete npdeploytk.dll nothing else but close your broswer first :p and when you have deleted try to clean your registery with ccleaner or anything else :p

more options

ChrisJez said

Sad and reluctant workaround is to use IE to look at pages/sites that FF won't allow.

On what page does Java not work for you in Firefox?

For sites that use the regular Java plugin, if it is set to "Ask to Activate", you should be able to activate it using the "usual" method:

  • a dark gray notification icon in the address bar that is reminiscent of a small Lego block, or
  • a link in a black rectangle in the page, or
  • an infobar sliding down between the toolbar area and the page

Hardly any sites use the deployment toolkit and if you find one that does, then Firefox should light up the plugin notification icon in the address bar in red instead of dark gray.

If the notification interface is not working correctly, you can use the Permissions panel of the Page Info dialog. You can call that up using any of these:

  • right-click the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address > More Information > Permissions

In the top section, you can override the default behavior for the current site. I guess the deployment toolkit is the one listed as Java — Vulnerable plugin!

more options

Isisombululo Esikhethiwe

Thanks for the further suggestions from theshine and jscher2000. Not sure whether I should just mark this as SOLVED given my reluctant IE workaround. Respectively... As indicated earlier, I did uninstall/reinstall of Java (confirmed both RTEs are up to date). And, my Registry was recently overhauled by Ccleaner. FF add-on for Java DT is set to "ask to activate" but on the page there is just a circle with a cross and "This plug-in is disabled". Manage plug-ins takes me to the add-ons page where "Always activate" is greyed out. Right clicking on the page does not produce a "page option" menu. But, this is visible via, Tools, Page Info, Permissions - where everything is set to default. HOWEVER, with a D'Oh! Whilst the original question is still sound/valid, I was being fooled into thinking the problem (with a particular page) was Java DT - which, as reported I cannot activate to uninstall. The manage plug-ins always seemed to take me to this app that was highlighted. BUT, the actual problem with the web page was Flash plug-in disabled. Page displays once this is activated. Hey ho.

more options

Hmm, that's confusing, Firefox usually can distinguish between plugins the page wants to use, and if you click the plugin notification icon in the address bar, should list all plugins the page is trying to use so you can activate the one(s) you want to activate.