X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Stop Firefox from issuing warnings about sites with unverfied certificates that it it had never issued before

Kuphostiwe

I just upgraded yesterday and now some sites are issuing certificate warnings. I'm not too adept with all the tech jargon, etc. Just want a simple solution to stop a problem I never had before with Firefox. Don't want to leave for Safari--which does not give same warnings--but if this is too difficult to slave and stop then I will

I just upgraded yesterday and now some sites are issuing certificate warnings. I'm not too adept with all the tech jargon, etc. Just want a simple solution to stop a problem I never had before with Firefox. Don't want to leave for Safari--which does not give same warnings--but if this is too difficult to slave and stop then I will

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 18.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:39.0) Gecko/20100101 Firefox/39.0

Eminye Imininingwane

jayelbe 50 izisombululo 293 izimpendulo
Kuphostiwe

Hi,

Sorry you're having trouble accessing secure websites in Firefox. Could you give us an example of some websites which aren't working, so I can take a look?

Thanks!

Hi, Sorry you're having trouble accessing secure websites in Firefox. Could you give us an example of some websites which aren't working, so I can take a look? Thanks!
jscher2000
  • Top 10 Contributor
8763 izisombululo 71700 izimpendulo
Kuphostiwe

Hi technophobia, this problem can be caused by Firefox not being completely set up to work with your security software. Some programs have a feature to intercept all your web requests for filtering. In order to filter secure connections (HTTPS sites), they need to present fake certificates to Firefox. If this is the issue, then somehow your Firefox lost trust in your security software. Do you use avast, ESET, Kaspersky or Bitdefender?

One reason this might happen is if you used the Refresh feature during your update. This can happen when Firefox says it is performing poorly and you can speed it up by restoring some default settings. If you click that button, your settings folder is moved to the desktop inside an Old Firefox Data folder. Do you see anything like that?

Hi technophobia, this problem can be caused by Firefox not being completely set up to work with your security software. Some programs have a feature to intercept all your web requests for filtering. In order to filter secure connections (HTTPS sites), they need to present fake certificates to Firefox. If this is the issue, then somehow your Firefox lost trust in your security software. Do you use avast, ESET, Kaspersky or Bitdefender? One reason this might happen is if you used the Refresh feature during your update. This can happen when Firefox says it is performing poorly and you can speed it up by restoring some default settings. If you click that button, your settings folder is moved to the desktop inside an Old Firefox Data folder. Do you see anything like that?
cor-el
  • Top 10 Contributor
  • Moderator
17530 izisombululo 158511 izimpendulo
Kuphostiwe

You can check the date and time and time zone in the clock on your computer.

We have seen reports that the time as set via an internet based time service was so much out of sync that an error occurs, so if that is the case with your current service then try to switch to another time service.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"
  • Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate"
  • Click the "View" button and inspect the certificate and check who is the issuer of the certificate.

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer.

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open this chrome URI by pasting or typing this URI in the location/address bar to open the "Add Security Exception" window and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field type/paste the URL of the website

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer
You can check the date and time and time zone in the clock on your computer. *https://support.mozilla.org/kb/Secure+Connection+Failed We have seen reports that the time as set via an internet based time service was so much out of sync that an error occurs, so if that is the case with your current service then try to switch to another time service. You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates. *Click the link at the bottom of the error page: "I Understand the Risks" *Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate" *Click the "View" button and inspect the certificate and check who is the issuer of the certificate. You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. If you can't inspect the certificate via "I Understand the Risks" then try this: Open this chrome URI by pasting or typing this URI in the location/address bar to open the "Add Security Exception" window and check the certificate: *chrome://pippki/content/exceptionDialog.xul In the location field type/paste the URL of the website *retrieve the certificate via the "Get certificate" button *click the "View..." button to inspect the certificate in the Certificate Viewer