Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Word wrap no longer works in text boxes.

  • 2 uphendule
  • 8 zinale nkinga
  • Igcine ukuphendulwa ngu cor-el

more options

I see others noting this problem beginning in March 2015, but no solutions.

Just updated to 39.0, still the problem.

No word wrap within a text posting box on a website, instead the sentence just continues scrolling horizontally.

Apparently Firefox began doing this with 36.0.1.

Was hoping it would be fixed in the newest version, but no.

A search found this post with an illustration of the problem, in case anything is unclear:

How could this not have been fixed between March and July?

How do I get word wrap within a text box?


All Replies (2)

more options

The textbox calculates a max width. It wraps for me on this site.

There are some creative css available that changes this:

See also: -webkit-box-sizing: border-box; -moz-box-sizing: border-box;

more options

Current releases (36+) support the white-space property for a text area and it is possible that the website uses white-space: pre instead of white-space: pre-wrap. The former will prevent Firefox from wrapping the text.

You can check that in the Inspector via the right-click context menu.


The white-space property is now working on <textarea> HTML elements (bug 82711).

See also: