X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Going back to the previous page refreshes the whole page

Kuphostiwe

When browsing certain pages (specifically Reddit.com), going back to the previous page will refresh the whole page, which expands the comments I've collapsed and I can no longer find the comment I was looking at a moment ago.

Currently I do not have any add-ons activated, but if I start Firefox in safe-mode the problem is no longer there.

I have tried to refresh Firefox, but this did not solve my problem.

I have also cleared my cache and this did not solve my problem either.

This is a problem that seems to come and go from time to time, without any reason that I understand.

When browsing certain pages (specifically Reddit.com), going back to the previous page will refresh the whole page, which expands the comments I've collapsed and I can no longer find the comment I was looking at a moment ago. Currently I do not have any add-ons activated, but if I start Firefox in safe-mode the problem is no longer there. I have tried to refresh Firefox, but this did not solve my problem. I have also cleared my cache and this did not solve my problem either. This is a problem that seems to come and go from time to time, without any reason that I understand.

Okulungisiwe ngu SuiTobi

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.11
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • Shockwave Flash 17.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.6.156
  • 5.1.40416.0
  • Unity Player 4.3.5f1
  • VLC media player Web Plugin 2.1.3

Isisebenziso

  • Firefox 38.0.5
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Izandiso

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: NVIDIA GeForce GTX 660
  • adapterDescription2:
  • adapterDeviceID: 0x11c0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 28711462
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17292
  • driverDate: 5-27-2015
  • driverDate2:
  • driverVersion: 9.18.13.5306
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d 1.1', u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 660 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
FredMcD
  • Top 10 Contributor
4254 izisombululo 59583 izimpendulo
Kuphostiwe

I get around this by opening a New Tab to the link I want to check.

I get around this by opening a New Tab to the link I want to check.

Umnikazi wombuzo

FredMcD said

I get around this by opening a New Tab to the link I want to check.

That's not how I want to browse though and it doesn't really fix the problem, it just accepts it and works around it. I know it can work the way I want, I just don't know how to make it so! :)

''FredMcD [[#answer-747324|said]]'' <blockquote> I get around this by opening a New Tab to the link I want to check. </blockquote> That's not how I want to browse though and it doesn't really fix the problem, it just accepts it and works around it. I know it can work the way I want, I just don't know how to make it so! :)
RayHarney 0 izisombululo 2 izimpendulo
Kuphostiwe

SuiTobi said

When browsing certain pages (specifically Reddit.com), going back to the previous page will refresh the whole page, which expands the comments I've collapsed and I can no longer find the comment I was looking at a moment ago. Currently I do not have any add-ons activated, but if I start Firefox in safe-mode the problem is no longer there. I have tried to refresh Firefox, but this did not solve my problem. I have also cleared my cache and this did not solve my problem either. This is a problem that seems to come and go from time to time, without any reason that I understand.

It does not refresh the page if I go back to a pinned page

''SuiTobi [[#question-1069550|said]]'' <blockquote> When browsing certain pages (specifically Reddit.com), going back to the previous page will refresh the whole page, which expands the comments I've collapsed and I can no longer find the comment I was looking at a moment ago. Currently I do not have any add-ons activated, but if I start Firefox in safe-mode the problem is no longer there. I have tried to refresh Firefox, but this did not solve my problem. I have also cleared my cache and this did not solve my problem either. This is a problem that seems to come and go from time to time, without any reason that I understand. </blockquote> It does not refresh the page if I go back to a pinned page
jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

I'm sometimes puzzled by what Firefox caches and what it doesn't. When I open a comments page, it is served with:

Cache-Control: private, max-age=0, must-revalidate, no-cache

But Firefox stores numerous pages in a "fast back-forward cache" even when the server specifies no-cache, unless it also specifies no-store. So that might explain why I can view images from a reddit page and go back without a reload.

I wonder why yours behaves different in regular and Safe Mode? Could you check the Extensions list? It is Extensions that are disabled in Safe Mode. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side, is there anything that seems as though it might affect caching?

I'm sometimes puzzled by what Firefox caches and what it doesn't. When I open a comments page, it is served with: Cache-Control: private, max-age=0, must-revalidate, no-cache But Firefox stores numerous pages in a "fast back-forward cache" even when the server specifies no-cache, unless it also specifies no-store. So that might explain why I can view images from a reddit page and go back without a reload. I wonder why yours behaves different in regular and Safe Mode? Could you check the Extensions list? It is Extensions that are disabled in Safe Mode. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then on the right side, is there anything that seems as though it might affect caching?
RayHarney 0 izisombululo 2 izimpendulo
Kuphostiwe

I like a refreshed page if I go back and forth between pinned pages

I like a refreshed page if I go back and forth between pinned pages

Umnikazi wombuzo

jscher2000 said

I'm sometimes puzzled by what Firefox caches and what it doesn't. When I open a comments page, it is served with: Cache-Control: private, max-age=0, must-revalidate, no-cache But Firefox stores numerous pages in a "fast back-forward cache" even when the server specifies no-cache, unless it also specifies no-store. So that might explain why I can view images from a reddit page and go back without a reload. I wonder why yours behaves different in regular and Safe Mode? Could you check the Extensions list? It is Extensions that are disabled in Safe Mode. Either:
  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Extensions. Then on the right side, is there anything that seems as though it might affect caching?

As mentioned, even without ANY add-ons installed, I still have the problem. That is why I'm really confused as to why it works in safe-mode, since that usually means it's an add-on problem.

''jscher2000 [[#answer-747334|said]]'' <blockquote> I'm sometimes puzzled by what Firefox caches and what it doesn't. When I open a comments page, it is served with: Cache-Control: private, max-age=0, must-revalidate, no-cache But Firefox stores numerous pages in a "fast back-forward cache" even when the server specifies no-cache, unless it also specifies no-store. So that might explain why I can view images from a reddit page and go back without a reload. I wonder why yours behaves different in regular and Safe Mode? Could you check the Extensions list? It is Extensions that are disabled in Safe Mode. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then on the right side, is there anything that seems as though it might affect caching? </blockquote> As mentioned, even without ANY add-ons installed, I still have the problem. That is why I'm really confused as to why it works in safe-mode, since that usually means it's an add-on problem.
jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

Safe Mode affects a range of other things, but they just don't seem very relevant... http://kb.mozillazine.org/Safe_Mode

Safe Mode affects a range of other things, but they just don't seem very relevant... http://kb.mozillazine.org/Safe_Mode

Umnikazi wombuzo

jscher2000 said

Safe Mode affects a range of other things, but they just don't seem very relevant... http://kb.mozillazine.org/Safe_Mode

Yeah.. That's why I hoped someone else would have a brilliant solution :D

''jscher2000 [[#answer-747351|said]]'' <blockquote> Safe Mode affects a range of other things, but they just don't seem very relevant... http://kb.mozillazine.org/Safe_Mode </blockquote> Yeah.. That's why I hoped someone else would have a brilliant solution :D

Umnikazi wombuzo

Odd. Now safe-mode doesn't work anymore. I am out of ideas.

Odd. Now safe-mode doesn't work anymore. I am out of ideas.

Umnikazi wombuzo

I have found a temporary solution to the problem by following this guide.

It's not a safe solution as far as I understand, since it makes Firefox somewhat vulnerable, but it does fix my problem. I will leave the support-thread unsolved for now, in case anyone finds a proper solution.

I have found a temporary solution to the problem by following [https://www.reddit.com/r/firefox/comments/2vdd68/improve_reddits_performance_in_firefox/ this guide.] It's not a safe solution as far as I understand, since it makes Firefox somewhat vulnerable, but it does fix my problem. I will leave the support-thread unsolved for now, in case anyone finds a proper solution.
jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

Oh, you didn't mention using HTTPS, so apparently my testing did not match your scenario.

I think what that rule does is okay in this case. You wouldn't want to override anti-caching on sites that contain personal/confidential information. But the pages you generally find on Reddit are not very sensitive, so if they linger on disk, it's not a big deal, is it?

Oh, you didn't mention using HTTPS, so apparently my testing did not match your scenario. I think what that rule does is okay in this case. You wouldn't want to override anti-caching on sites that contain personal/confidential information. But the pages you generally find on Reddit are not very sensitive, so if they linger on disk, it's not a big deal, is it?

Umnikazi wombuzo

jscher2000 said

Oh, you didn't mention using HTTPS, so apparently my testing did not match your scenario. I think what that rule does is okay in this case. You wouldn't want to override anti-caching on sites that contain personal/confidential information. But the pages you generally find on Reddit are not very sensitive, so if they linger on disk, it's not a big deal, is it?

Most sites are nowadays aren't they? I figured *that* wasn't the direct problem, especially since Reddit has been using HTTPS for a long while (and my problem only started recently, after a long period where it was gone).

Reddit is basically a forum for threads, posts and discussions which basically uses no personal or confidential information. As far as I understand, this fix only has an effect on Reddit, so it should definitely not be a big deal :)

''jscher2000 [[#answer-747480|said]]'' <blockquote> Oh, you didn't mention using HTTPS, so apparently my testing did not match your scenario. I think what that rule does is okay in this case. You wouldn't want to override anti-caching on sites that contain personal/confidential information. But the pages you generally find on Reddit are not very sensitive, so if they linger on disk, it's not a big deal, is it? </blockquote> Most sites are nowadays aren't they? I figured *that* wasn't the direct problem, especially since Reddit has been using HTTPS for a long while (and my problem only started recently, after a long period where it was gone). Reddit is basically a forum for threads, posts and discussions which basically uses no personal or confidential information. As far as I understand, this fix only has an effect on Reddit, so it should definitely not be a big deal :)

Umnikazi wombuzo

Reddit now exhibits the same problem as before, even though I'm still using the fix mentioned previously in this thread. Hope someone with some wits can help me out!

Reddit now exhibits the same problem as before, even though I'm still using the fix mentioned previously in this thread. Hope someone with some wits can help me out!
jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Other people are mentioning it here: https://www.reddit.com/r/firefox/comments/2vdd68/improve_reddits_performance_in_firefox/

If you use the Web Console to look at the caching headers, has the add-on stopped working, i.e., stopped modifying the cache-control header? While on a Reddit page, you can open the Web Console by pressing Ctrl+Shift+k or using the Developer menu. Then reload the page and various URLs should be listed in the console. (If URLs don't appear, click the Net button above the console once or twice.) If you scroll back up to the first URL and click it, you should see the Response Headers including the caching line.

Mine shows this:

Cache-Control: max-age=0, must-revalidate

I'm not sure why I am not getting no-cache today.

I didn't check comments pages, which were mentioned in the above thread.

Other people are mentioning it here: https://www.reddit.com/r/firefox/comments/2vdd68/improve_reddits_performance_in_firefox/ If you use the Web Console to look at the caching headers, has the add-on stopped working, i.e., stopped modifying the cache-control header? While on a Reddit page, you can open the Web Console by pressing Ctrl+Shift+k or using the Developer menu. Then reload the page and various URLs should be listed in the console. (If URLs don't appear, click the Net button above the console once or twice.) If you scroll back up to the first URL and click it, you should see the Response Headers including the caching line. Mine shows this: Cache-Control: max-age=0, must-revalidate I'm not sure why I am not getting no-cache today. I didn't check comments pages, which were mentioned in the above thread.

Umnikazi wombuzo

jscher2000 said

Other people are mentioning it here: https://www.reddit.com/r/firefox/comments/2vdd68/improve_reddits_performance_in_firefox/ If you use the Web Console to look at the caching headers, has the add-on stopped working, i.e., stopped modifying the cache-control header? While on a Reddit page, you can open the Web Console by pressing Ctrl+Shift+k or using the Developer menu. Then reload the page and various URLs should be listed in the console. (If URLs don't appear, click the Net button above the console once or twice.) If you scroll back up to the first URL and click it, you should see the Response Headers including the caching line. Mine shows this: Cache-Control: max-age=0, must-revalidate I'm not sure why I am not getting no-cache today. I didn't check comments pages, which were mentioned in the above thread.

Thanks for helping out once again :)

Mine shows this:

Cache-Control: private, s-maxage=0, max-age=0, must-revalidate, max-age=0, must-revalidate

''jscher2000 [[#answer-761140|said]]'' <blockquote> Other people are mentioning it here: https://www.reddit.com/r/firefox/comments/2vdd68/improve_reddits_performance_in_firefox/ If you use the Web Console to look at the caching headers, has the add-on stopped working, i.e., stopped modifying the cache-control header? While on a Reddit page, you can open the Web Console by pressing Ctrl+Shift+k or using the Developer menu. Then reload the page and various URLs should be listed in the console. (If URLs don't appear, click the Net button above the console once or twice.) If you scroll back up to the first URL and click it, you should see the Response Headers including the caching line. Mine shows this: Cache-Control: max-age=0, must-revalidate I'm not sure why I am not getting no-cache today. I didn't check comments pages, which were mentioned in the above thread. </blockquote> Thanks for helping out once again :) Mine shows this: Cache-Control: private, s-maxage=0, max-age=0, must-revalidate, max-age=0, must-revalidate

Okulungisiwe ngu SuiTobi

jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

Well, it seems that setting it to null (blank) is not working. Is there any change in the URL? The rule only applies to www.reddit.com (exactly) and not, for example, reddit.com or abc.reddit.com.

Well, it seems that setting it to null (blank) is not working. Is there any change in the URL? The rule only applies to www.reddit.com (exactly) and not, for example, reddit.com or abc.reddit.com.

Umnikazi wombuzo

jscher2000 said

Well, it seems that setting it to null (blank) is not working. Is there any change in the URL? The rule only applies to www.reddit.com (exactly) and not, for example, reddit.com or abc.reddit.com.

Not that I can see, but I'm not entirely sure I understand what you're asking.

''jscher2000 [[#answer-761171|said]]'' <blockquote> Well, it seems that setting it to null (blank) is not working. Is there any change in the URL? The rule only applies to www.reddit.com (exactly) and not, for example, reddit.com or abc.reddit.com. </blockquote> Not that I can see, but I'm not entirely sure I understand what you're asking.
jscher2000
  • Top 10 Contributor
8758 izisombululo 71658 izimpendulo
Kuphostiwe

Someone is the discussion thread on reddit mentioned that some parts of the site are now on np.reddit.com instead of www.reddit.com and you may need to add a second rule as a result. But this is all second hand, I haven't tested it myself.

Someone is the discussion thread on reddit mentioned that some parts of the site are now on np.reddit.com instead of www.reddit.com and you may need to add a second rule as a result. But this is all second hand, I haven't tested it myself.

Umnikazi wombuzo

jscher2000 said

Someone is the discussion thread on reddit mentioned that some parts of the site are now on np.reddit.com instead of www.reddit.com and you may need to add a second rule as a result. But this is all second hand, I haven't tested it myself.

It's actually not many parts that use np, and my problem is on the regular www anyways.

''jscher2000 [[#answer-761187|said]]'' <blockquote> Someone is the discussion thread on reddit mentioned that some parts of the site are now on np.reddit.com instead of www.reddit.com and you may need to add a second rule as a result. But this is all second hand, I haven't tested it myself. </blockquote> It's actually not many parts that use np, and my problem is on the regular www anyways.

Umnikazi wombuzo

Bump for help :(

Bump for help :(