Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

After printing one page, when I try to print again it says printing function not available

  • 5 uphendule
  • 2 zinale nkinga
  • Igcine ukuphendulwa ngu PeteThirdEye

more options

I have a Canon MG6250 connected via USB. I run Windows 7 with all latest updates and currently the Firefox version is 38.0.5. For quite some time, probably about a year, starting after a new version of Firefox I think , I have trouble printing. (Sorry I can't remember with which version it started happening.) Unless I wait for the printer to ready itself completely, although the print dialogue box appears and I click Print, often (not always) nothing happens. If I try to print again I get a pop-up box saying the print function is not available. If I then close Firefox and try to restart it, it tells me that Firefox is already running; I have to end its process via Task Manager. Often I want to print from several tabs, already loaded with the pages to be printed. Even if I manage to get the first tab to print, somewhere along the line the same thing often happens: before I've printed the last tab's page I get the pop-up box again and I have to end the Firefox process to make it work again. I can usually prevent it from happening if I monitor my computer's CPU activity (via System Mechanic) and make sure all activity has stopped after printing one tab before I try to print the next; this makes printing from Firefox frustratingly slow!

I do not have any printing problems whatsoever from any other application.

Note that fairly recently, due to a system drive failure, I re-installed Windows and all my software. I hoped that a by-product of doing this might fix the Firefox printing problem, but it hasn't.

I'd be most grateful for a solution to this problem.

Isisombululo esikhethiwe

I continued to use IE with no printing problems. But then after Firefox 3.0 was released I gave it another go - and the problem seems to have been resolved. No matter how quickly I switch to another tab and select Print, it behaves as it should. Thank goodness - Firefox is so much better than IE.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

Hi PeteThirdEye, It might be saying Firefox is already running because a process is taking a while to close the program completely, when you restart Firefox do you see an apology that Firefox closed improperly?

more options

Thanks, guigs2, for taking the trouble to respond, and apologies for my taking so long to get back again.

I forced the problem to occur again (by trying to print the page in the next tab before the previous page had finished printing and before the Canon print progress box had disappeared). As usual, nothing happened (i.e. it didn't print and no print was added to the Canon print queue) and when I tried to print again I got the error message box saying print function is not available. I tried printing from yet another tab I got the same error box.

So I clicked the X to shut down Firefox, and this time, as you suggested, I waited and after half a minute or so Firefox ended, and, on re-starting it, it told me that it had crashed.

For your point about printer drivers, I have software that monitors for driver updates, so I'm sure I do have the latest. And the problem has been occurring for months, during which time I've re-installed Windows and all software onto a completely new system drive disc; this made no difference to the problem.

It appears that, if I don't wait for each print to finish processing completely before requesting another print, Firefox's printing routine fails in some way such that it never finishes (stuck in a loop?). Task Manager shows some activity for Firefox all the time after this has happened. So my guess is that when I try printing again the routine cannot start because it's already active. Then when I try to close Firefox, whatever has gone wrong with the routine causes the whole of Firefox to crash. Could it be that there is some incompatibility with Firefox's print routine and the Canon print driver?

I also sometimes print from Paint Shop Pro, Microsoft Word and Publisher, Open Office Writer and Calc, Thunderbird, Foxit PDF Reader... and I've never had the slightest problem printing from these applications. It must surely be a bug in Firefox, mustn't it?

more options

Further information: I got so fed up with this that I'm now doing my multi-tab prints from Internet Explorer. No matter what I do in I.E., e.g. select the next tab and start printing its page before the previous tab's page has finished printing, I can't break it. So it really does look like a Firefox problem. (I still use Firefox for most browsing as I much prefer it to I.E..)

more options

Isisombululo Esikhethiwe

I continued to use IE with no printing problems. But then after Firefox 3.0 was released I gave it another go - and the problem seems to have been resolved. No matter how quickly I switch to another tab and select Print, it behaves as it should. Thank goodness - Firefox is so much better than IE.

more options

Spoke too soon. The problem re-occurred again today when I had 10 tabs to print one after the other. The symptoms were exactly the same as before, described above, occurring after selecting the third tab and requesting it to be printed. When I closed Firefox and tried again I was only able to print one tab before the problem occurred.

So back to Internet Explorer for this particular task. This has NEVER had this problem.

Developers :- if you need any more information I'll do my best to supply it.

Okulungisiwe ngu PeteThirdEye