X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Sync encountered an unknown error

Kuphostiwe

Hello,

I've been using my own Sync 1.5 server since January without having any issue until this week.

I am unable to sync my clients, getting the "Sync encountered an error while synching: Unknown error, Sync will try again automatically."

Here's the log: https://pastebin.mozilla.org/8836193

The problem seems to happen at line 101 (on pastebin).

Here's some more info about my setup.

Syncserver 1.5.2 installed on a local server running on Linux.

I have 1 Windows client, 2 Linux clients. None of them can sync. All uses Firefox 38.0.

Any help would be appreciated. Thanks, Phil

Hello, I've been using my own Sync 1.5 server since January without having any issue until this week. I am unable to sync my clients, getting the "Sync encountered an error while synching: Unknown error, Sync will try again automatically." Here's the log: https://pastebin.mozilla.org/8836193 The problem seems to happen at line 101 (on pastebin). Here's some more info about my setup. Syncserver 1.5.2 installed on a local server running on Linux. I have 1 Windows client, 2 Linux clients. None of them can sync. All uses Firefox 38.0. Any help would be appreciated. Thanks, Phil

Isisombululo esikhethiwe

HI GuizmoPhil, Thank you for your question. I am asking the irc channel to see if I can get a second opinion on the logs, however: You are right about that being were is started, but it was already debuging and completed the sync anyway at the end. (so it seems as I did not write the error logger :-/) The exception is thrown is when its checking if there is a newer record of stored forms. (Autofill stuff) and I think that is stored in "History" or formhistory.sqlite in the profile, you could just stop syncing this, or:

What I would do is disconnect all of the devices on the account by logging out. I would start over by deleting the cloud account AFTER the devices are disconnected. (then make a back up just in case of all profiles!) Then sign up with the same email and attach each device.

There is something that is corrupted, if you can isolate with device it is you can create a new profile on that device and restore the data from that device's profile:

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • DivX Web Player version 1.4.0.233
  • The IcedTea-Web Plugin executes Java applets.
  • The Videos 3.10.1 plugin handles video and audio streams.
  • Shockwave Flash 11.2 r202

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

Eminye Imininingwane

guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

HI GuizmoPhil, Thank you for your question. I am asking the irc channel to see if I can get a second opinion on the logs, however: You are right about that being were is started, but it was already debuging and completed the sync anyway at the end. (so it seems as I did not write the error logger :-/) The exception is thrown is when its checking if there is a newer record of stored forms. (Autofill stuff) and I think that is stored in "History" or formhistory.sqlite in the profile, you could just stop syncing this, or:

What I would do is disconnect all of the devices on the account by logging out. I would start over by deleting the cloud account AFTER the devices are disconnected. (then make a back up just in case of all profiles!) Then sign up with the same email and attach each device.

There is something that is corrupted, if you can isolate with device it is you can create a new profile on that device and restore the data from that device's profile:

HI GuizmoPhil, Thank you for your question. I am asking the irc channel to see if I can get a second opinion on the logs, however: You are right about that being were is started, but it was already debuging and completed the sync anyway at the end. (so it seems as I did not write the error logger :-/) The exception is thrown is when its checking if there is a newer record of stored forms. (Autofill stuff) and I think that is stored in "History" or formhistory.sqlite in the profile, you could just stop syncing this, or: What I would do is disconnect all of the devices on the account by logging out. I would start over by deleting the cloud account AFTER the devices are disconnected. (then make a back up just in case of all profiles!) Then sign up with the same email and attach each device. There is something that is corrupted, if you can isolate with device it is you can create a new profile on that device and restore the data from that device's profile: * [[Back up and restore information in Firefox profiles]]

Impendulo Ewusizo

guigs2 said

HI GuizmoPhil, Thank you for your question. I am asking the irc channel to see if I can get a second opinion on the logs, however: You are right about that being were is started, but it was already debuging and completed the sync anyway at the end. (so it seems as I did not write the error logger :-/) The exception is thrown is when its checking if there is a newer record of stored forms. (Autofill stuff) and I think that is stored in "History" or formhistory.sqlite in the profile, you could just stop syncing this, or: What I would do is disconnect all of the devices on the account by logging out. I would start over by deleting the cloud account AFTER the devices are disconnected. (then make a back up just in case of all profiles!) Then sign up with the same email and attach each device. There is something that is corrupted, if you can isolate with device it is you can create a new profile on that device and restore the data from that device's profile:

Thanks, the History was the problem. As I don't really need to sync my history at all, I just unselected it from the Sync configuration. What is important to me are my bookmarks , add-on and passwords.

Thanks again, Phil

''guigs2 [[#answer-739510|said]]'' <blockquote> HI GuizmoPhil, Thank you for your question. I am asking the irc channel to see if I can get a second opinion on the logs, however: You are right about that being were is started, but it was already debuging and completed the sync anyway at the end. (so it seems as I did not write the error logger :-/) The exception is thrown is when its checking if there is a newer record of stored forms. (Autofill stuff) and I think that is stored in "History" or formhistory.sqlite in the profile, you could just stop syncing this, or: What I would do is disconnect all of the devices on the account by logging out. I would start over by deleting the cloud account AFTER the devices are disconnected. (then make a back up just in case of all profiles!) Then sign up with the same email and attach each device. There is something that is corrupted, if you can isolate with device it is you can create a new profile on that device and restore the data from that device's profile: * [[Back up and restore information in Firefox profiles]] </blockquote> Thanks, the History was the problem. As I don't really need to sync my history at all, I just unselected it from the Sync configuration. What is important to me are my bookmarks , add-on and passwords. Thanks again, Phil
dobydoby 3 izisombululo 112 izimpendulo
Kuphostiwe

Yes unsyncing history worked for me too, but my question is there a way to fix it so that we can sync our history, its ok for now, just looking at possible need to do this in future.

Yes unsyncing history worked for me too, but my question is there a way to fix it so that we can sync our history, its ok for now, just looking at possible need to do this in future.