X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox ver. 37 and 38 distort my PC screen display so I can't use it.

Kuphostiwe

After behaving faultlessly forever, suddenly with ver. 37.0.2 when I opened Firefox browser it distorted the screen so much that I had to discard it. The only time the distortion occurs is with Firefox. I have reinstalled it several times and reset it but no solution. I am now using Chrome but don't like it much. Can someone help with this Firefox problem. I can send a photo of the distorted screen as an SMS or to an email address. Local IT gurus can't explain the cause.

After behaving faultlessly forever, suddenly with ver. 37.0.2 when I opened Firefox browser it distorted the screen so much that I had to discard it. The only time the distortion occurs is with Firefox. I have reinstalled it several times and reset it but no solution. I am now using Chrome but don't like it much. Can someone help with this Firefox problem. I can send a photo of the distorted screen as an SMS or to an email address. Local IT gurus can't explain the cause.

Isisombululo esikhethiwe

Yes, you can reset the pref via the right-click context menu to the default value.

Make sure that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Funda le mpendulo ngokuhambisana nalesi sihloko 3

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

Eminye Imininingwane

guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Hi peterfin0, Distortion sounds like a graphics issue. Can you please try these troubleshooting tips:

  1. Does it happen in Firefox Safe Mode: Troubleshoot Firefox issues using Safe Mode
  2. Upgrade your graphics drivers to use hardware acceleration and WebGL
Hi peterfin0, Distortion sounds like a graphics issue. Can you please try these troubleshooting tips: # Does it happen in Firefox Safe Mode: [[Troubleshoot Firefox issues using Safe Mode]] #[[Upgrade your graphics drivers to use hardware acceleration and WebGL]]

Umnikazi wombuzo

guigs2 said

Hi peterfin0, Distortion sounds like a graphics issue. Can you please try these troubleshooting tips:
  1. Does it happen in Firefox Safe Mode: Troubleshoot Firefox issues using Safe Mode
  2. Upgrade your graphics drivers to use hardware acceleration and WebGL

Yes, it happens in Safe Mode and Refresh does not help. The problem is associated with Firefox and only with Firefox.

''guigs2 [[#answer-738703|said]]'' <blockquote> Hi peterfin0, Distortion sounds like a graphics issue. Can you please try these troubleshooting tips: # Does it happen in Firefox Safe Mode: [[Troubleshoot Firefox issues using Safe Mode]] #[[Upgrade your graphics drivers to use hardware acceleration and WebGL]] </blockquote> Yes, it happens in Safe Mode and Refresh does not help. The problem is associated with Firefox and only with Firefox.

Umnikazi wombuzo

Yes, it happens in Safe Mode and Refresh does not help. The problem is associated with Firefox and only with Firefox. I don't understand Option 2.

Yes, it happens in Safe Mode and Refresh does not help. The problem is associated with Firefox and only with Firefox. I don't understand Option 2.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

Option two is to troubleshoot hardware acceleration, however this is disabled in Safe Mode. Please update your plugins to the latest version. Check to make sure you are up to date:

If you see any issues also see:

Option two is to troubleshoot hardware acceleration, however this is disabled in Safe Mode. Please update your plugins to the latest version. Check to make sure you are up to date: *[https://www.mozilla.org/en-US/plugincheck/] If you see any issues also see: *[[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]

Umnikazi wombuzo

Problem not solved. Plug-ins and drivers are all up to date. Can't find solution in Troubleshoot, either. Very strange. Mozilla display is readable but colors are 'washed out' and distorted.

Problem not solved. Plug-ins and drivers are all up to date. Can't find solution in Troubleshoot, either. Very strange. Mozilla display is readable but colors are 'washed out' and distorted.
guigs 1072 izisombululo 11697 izimpendulo
Kuphostiwe

There is a gfx color manager about:config entry that does something similar, can you please provide the troubleshooting information to check if this entry has been changed? It might not be an entry that changes back to default in Safe Mode.

There is a gfx color manager about:config entry that does something similar, can you please provide the troubleshooting information to check if this entry has been changed? It might not be an entry that changes back to default in Safe Mode.
cor-el
  • Top 10 Contributor
  • Moderator
17483 izisombululo 158000 izimpendulo
Kuphostiwe

You can try to disable color management to test if it is caused by a problem with color management.

You can set the gfx.color_management.mode pref to 0 on the about:config page to disable Color Management. You need to close and restart Firefox to make the change effective.

See:

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB
You can try to disable color management to test if it is caused by a problem with color management. You can set the gfx.color_management.mode pref to 0 on the about:config page to disable Color Management. You need to close and restart Firefox to make the change effective. See: * http://kb.mozillazine.org/gfx.color_management.mode You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config ---- Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB

Impendulo Ewusizo

Screen shots herewith. The problem only occurs with Firefox. Chrome and IE are no problem.

Screen shots herewith. The problem only occurs with Firefox. Chrome and IE are no problem.
cor-el
  • Top 10 Contributor
  • Moderator
17483 izisombululo 158000 izimpendulo
Kuphostiwe

Did you try to disable color management in Firefox?

Did you try to disable color management in Firefox?

Umnikazi wombuzo

Changing the color management mode to 0 had no effect. Should I change it back to 2?

Changing the color management mode to 0 had no effect. Should I change it back to 2?
cor-el
  • Top 10 Contributor
  • Moderator
17483 izisombululo 158000 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

Yes, you can reset the pref via the right-click context menu to the default value.

Make sure that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Yes, you can reset the pref via the right-click context menu to the default value. Make sure that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Umnikazi wombuzo

Problem solved when I unticked the 'Run in 256 colors' box in the Properties > Compatibility tab.

Thanks Cor-el, it's taken 2-3 months to arrive at that simple solution. I have always run Firefox in 256 colors though; why is it a problem now?

Problem solved when I unticked the 'Run in 256 colors' box in the Properties > Compatibility tab. Thanks Cor-el, it's taken 2-3 months to arrive at that simple solution. I have always run Firefox in 256 colors though; why is it a problem now?
James
  • Moderator
1596 izisombululo 11250 izimpendulo
Kuphostiwe

peterfin0 said

I have always run Firefox in 256 colors though; why is it a problem now?

Why?

''peterfin0 [[#answer-750638|said]]'' <blockquote> I have always run Firefox in 256 colors though; why is it a problem now? </blockquote> Why?

Umnikazi wombuzo

Yes, why?

Yes, why?
James
  • Moderator
1596 izisombululo 11250 izimpendulo
Kuphostiwe

I was referring to the run Firefox in 256 colours. Only reason I can think of is this is on a terminal.

I was referring to the run Firefox in 256 colours. Only reason I can think of is this is on a terminal.

Umnikazi wombuzo

Ah, I misunderstood the question. I don't know why I have always run with 256 colors. It seemed to be the default setting and no one has suggested it could cause problems. Anyhow all is well again and I can close Chrome. Thanks.

Ah, I misunderstood the question. I don't know why I have always run with 256 colors. It seemed to be the default setting and no one has suggested it could cause problems. Anyhow all is well again and I can close Chrome. Thanks.