X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

disable the reader view function

Kuphostiwe

Just updated to FF 38.0.5. Is there a way to disable the reader view function/icon from showing up in the address bar?

Just updated to FF 38.0.5. Is there a way to disable the reader view function/icon from showing up in the address bar?

Isisombululo esikhethiwe

You can toggle the reader.parse-on-load.enabled pref to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


Funda le mpendulo ngokuhambisana nalesi sihloko 47

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.14
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Isisebenziso

  • Firefox 38.0.5
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.0; rv:38.0) Gecko/20100101 Firefox/38.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Izandiso

  • AdBlock for Firefox 2.0 (jid1-NIfFY2CA8fy1tg@jetpack)
  • Australis Small Icons 1.0.1-signed (australissmall@icons.com)
  • AVG Do Not Track 1.0.0.2.1-signed ({F53C93F1-07D5-430c-86D4-C9531B27DFAF})
  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Akusebenzi)
  • AVG Security Toolbar 18.5.0.909 (avg@toolbar) (Akusebenzi)
  • Bluhell Firewall 2.5.1.1-signed ({6BB5760D-F97E-421B-AF5B-8457A90C3CED}) (Akusebenzi)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: ATI Radeon HD 2600 XT
  • adapterDescription2:
  • adapterDeviceID: 0x9588
  • adapterDeviceID2:
  • adapterDrivers: atiumdag atiumdva atitmmxx
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 25421028
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'9.6']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.23680
  • driverDate: 11-1-2007
  • driverDate2:
  • driverVersion: 8.432.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
cor-el
  • Top 10 Contributor
  • Moderator
17531 izisombululo 158524 izimpendulo
Kuphostiwe

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#reader-mode-button,
#readinglist-addremove-button {
 display:none !important;
}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • Paste the code in the userChrome.css file in the editor window
  • Make sure that the userChrome.css file starts with the default @namespace line
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.
    Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file
Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css ---- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #reader-mode-button, #readinglist-addremove-button { display:none !important; } </nowiki></pre> ---- The customization files userChrome.css (user interface) and userContent.css (websites) are located in the <b>chrome</b> folder in the Firefox profile folder. *http://kb.mozillazine.org/Editing_configuration You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox *Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist *Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive) *Paste the code in the userChrome.css file in the editor window *Make sure that the userChrome.css file starts with the default @namespace line *Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.<br>Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file
cor-el
  • Top 10 Contributor
  • Moderator
17531 izisombululo 158524 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

You can toggle the reader.parse-on-load.enabled pref to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.


You can toggle the <b>reader.parse-on-load.enabled</b> pref to false on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config ----- *http://mxr.mozilla.org/mozilla-release/source/toolkit/components/reader/ReaderMode.jsm
pedro147 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Why do all these tech companies keep giving us crap like this we do not need or ask for?

Why do all these tech companies keep giving us crap like this we do not need or ask for?
Mozzix 2 izisombululo 25 izimpendulo
Kuphostiwe

Impendulo Ewusizo

I already use ScrapBook for saving articles.

Why integrating ReaderView and Pocket in the browser. If people want these services let them download the add-on. These things are not essential. It only bloats the browser.

Please stop doing this!.

I already use ScrapBook for saving articles. Why integrating ReaderView and Pocket in the browser. If people want these services let them download the add-on. These things are not essential. It only bloats the browser. Please stop doing this!.

Umnikazi wombuzo

I agree with the previous posts. If I wanted these add-ons I would have added them myself.

I agree with the previous posts. If I wanted these add-ons I would have added them myself.
LarsEighner 1 izisombululo 4 izimpendulo
Kuphostiwe

I have done my best to disable this in my browser.

As a page author, can I do something to keep my pages from triggering reader view? I notice many pages on other sites do not.

I have done my best to disable this in my browser. As a page author, can I do something to keep my pages from triggering reader view? I notice many pages on other sites do not.
SargonIII 1 izisombululo 11 izimpendulo
Kuphostiwe

The first solution (which uses userChrome.css) does not work on my computer, but the second works properly. Thanks!

The first solution (which uses userChrome.css) does not work on my computer, but the second works properly. Thanks!
hoggys2much 0 izisombululo 37 izimpendulo
Kuphostiwe

I am with everyone else here. I too am getting sick and bloody tired of companies trying to force their crap pathetic ideas down our throats.

If I want something I will download it myself.

We are supposed to be living in a free and democratic society where we can do what we want but big companies behave worse than the ... forcing their crap on us.

Are Mozilla trying to force us to move to other browsers?

Believe me if Internet Explorer 11 had Ad Block+ I would use that instead of Firefox.

Fx a fantastic browser that Mozilla seem hell bent on destroying.

It is no wonder you are in THIRD place behind Chrome and I.E when you keep adding stuff like this.

I am with everyone else here. I too am getting sick and bloody tired of companies trying to force their crap pathetic ideas down our throats. If I want something I will download it myself. We are supposed to be living in a free and democratic society where we can do what we want but big companies behave worse than the ... forcing their crap on us. Are Mozilla trying to force us to move to other browsers? Believe me if Internet Explorer 11 had Ad Block+ I would use that instead of Firefox. Fx a fantastic browser that Mozilla seem hell bent on destroying. It is no wonder you are in '''THIRD''' place behind Chrome and I.E when you keep adding stuff like this.

Okulungisiwe ngu James

bribling 0 izisombululo 13 izimpendulo
Kuphostiwe

arejfour said

Just updated to FF 38.0.5. Is there a way to disable the reader view function/icon from showing up in the address bar?

I followed the directions but could not change to "False". This app is causing me serious problems and I want the option to disable it. When I try to Comment at FB, the comment will not enter and FF is on a continuous load. I can't do anything because it will not stop loading. Why is this forced on us? I switched to Chrome and now every time I open Chrome I get a Welcome to Chrome message. I have been using Chrome for years for a FB game. Now I cannot use Firefox or Chrome without a lot of aggravation. This started with the new FF Update this week.

''arejfour [[#question-1065043|said]]'' <blockquote> Just updated to FF 38.0.5. Is there a way to disable the reader view function/icon from showing up in the address bar? </blockquote> I followed the directions but could not change to "False". This app is causing me serious problems and I want the option to disable it. When I try to Comment at FB, the comment will not enter and FF is on a continuous load. I can't do anything because it will not stop loading. Why is this forced on us? I switched to Chrome and now every time I open Chrome I get a Welcome to Chrome message. I have been using Chrome for years for a FB game. Now I cannot use Firefox or Chrome without a lot of aggravation. This started with the new FF Update this week.
hoggys2much 0 izisombululo 37 izimpendulo
Kuphostiwe

bribling said

arejfour said
Just updated to FF 38.0.5. Is there a way to disable the reader view function/icon from showing up in the address bar?

I followed the directions but could not change to "False". This app is causing me serious problems and I want the option to disable it. When I try to Comment at FB, the comment will not enter and FF is on a continuous load. I can't do anything because it will not stop loading. Why is this forced on us? I switched to Chrome and now every time I open Chrome I get a Welcome to Chrome message. I have been using Chrome for years for a FB game. Now I cannot use Firefox or Chrome without a lot of aggravation. This started with the new FF Update this week.

You must be doing something wrong. It is so easy to disable.

1. Open a new tab and type about:config in the address bar. 2. Confirm that you will be careful when the warning message appears. 3. Enter the following text in the filter box reader.parse-on-load.enabled 4. You will see it enabled set it to false by clicking where it says true 5. Restart Firefox.

Website: http://winaero.com/blog/how-to-disable-reader-view-in-firefox/

Hope it helps.

''bribling [[#answer-748306|said]]'' <blockquote> ''arejfour [[#question-1065043|said]]'' <blockquote> Just updated to FF 38.0.5. Is there a way to disable the reader view function/icon from showing up in the address bar? </blockquote> I followed the directions but could not change to "False". This app is causing me serious problems and I want the option to disable it. When I try to Comment at FB, the comment will not enter and FF is on a continuous load. I can't do anything because it will not stop loading. Why is this forced on us? I switched to Chrome and now every time I open Chrome I get a Welcome to Chrome message. I have been using Chrome for years for a FB game. Now I cannot use Firefox or Chrome without a lot of aggravation. This started with the new FF Update this week. </blockquote> You must be doing something wrong. It is so easy to disable. 1. Open a new tab and type '''about:config ''' in the address bar. 2. Confirm that you will be careful when the warning message appears. 3. Enter the following text in the filter box''' reader.parse-on-load.enabled''' 4. You will see it enabled set it to false by clicking where it says true 5. Restart Firefox. Website: http://winaero.com/blog/how-to-disable-reader-view-in-firefox/ Hope it helps.

Okulungisiwe ngu hoggys2much

bribling 0 izisombululo 13 izimpendulo
Kuphostiwe

I finally got it to work and got rid of the Reader which, BTW, I have no use for. It should be optional as an add-on.

I finally got it to work and got rid of the Reader which, BTW, I have no use for. It should be optional as an add-on.
hoggys2much 0 izisombululo 37 izimpendulo
Kuphostiwe

Agreed!bribling said

I finally got it to work and got rid of the Reader which, BTW, I have no use for. It should be optional as an add-on.

Couldn't agree more.

But unfortunately Mozilla are just like all the other big companies in loving to force their utter crap down our throats with their usual take it, like it and lump it attitude.

Agreed!''bribling [[#answer-748405|said]]'' <blockquote> I finally got it to work and got rid of the Reader which, BTW, I have no use for. '''It should be optional as an add-on.''' </blockquote> Couldn't agree more. But unfortunately Mozilla are just like all the other big companies in loving to force their utter crap down our throats with their usual take it, like it and lump it attitude.
cor-el
  • Top 10 Contributor
  • Moderator
17531 izisombululo 158524 izimpendulo
Kuphostiwe
See also: *https://addons.mozilla.org/firefox/addon/disable-hello-pocket-reader/
James
  • Top 25 Contributor
  • Moderator
1598 izisombululo 11287 izimpendulo
Kuphostiwe

hoggys2much, please watch your language as you can still get your point across without the use of such and more likely to be heard instead of ignored.

https://support.mozilla.org/en-US/kb/forum-rules-and-guidelines#w_language-and-conduct

'''hoggys2much''', please watch your language as you can still get your point across without the use of such and more likely to be heard instead of ignored. https://support.mozilla.org/en-US/kb/forum-rules-and-guidelines#w_language-and-conduct

Okulungisiwe ngu James

hoggys2much 0 izisombululo 37 izimpendulo
Kuphostiwe

That is hysterical.

Mozilla has allowed someone to add an add-on to to let everybody get rid of their unwanted unneeded crap.

That is hysterical. Mozilla has allowed someone to add an add-on to to let everybody get rid of their unwanted unneeded crap.