Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I wish not to have mozilla add-ons as my opening page and ant to return to simple page with address space and google space in upper right

more options

Using my Macbook Pro I accidentally made Ask.com my search page when I opened Firefox last week. I wanted to restore to my original opening page. Trying to delete it seemed impossible so I tried to supercede the page by reverting back to the original with an address bar in the upper left corner and a search bar (Google) in the upper right using mozilla somehow. Unfortunately Mozilla Add-ons page now opens up when I click firefox. These add-ons may be very useful in the future, but I don't to bother with them now. I'd like to now how to delete that page so it doesn't open, and restore what I had before. P.S. I got to it trying to eliminate Ask.com according to instructions....with pictures even. Hard to find for Apple.

Isisombululo esikhethiwe

virginiakropas said

Thanks for info on default, jscher2000. It worked almost exactly as I wished and though there isn't a search bar in the right corner, I am content. It also seemed to resolve most of the Download nuisances. I am allowed to to open with Word (docx), and Preview (jpg). Only pdf must be saved,but I can name it and put it where I want to find it easily to delete. I will keep your last e-mail to refer to when I'm checking Add-ons,etc. Thanks so much. It seems ridiculously simple now. Thanks to you and Mozilla support. virginia
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (12)

more options

Hia!

Although I am not on a iMac of any sort, is Ask opening up as your homepage when you open Firefox?

-TacoSenpai

more options

As long as the Add-ons page is opening anyway... please check for any/all unknown and unwanted add-ons in the Plugins and Extensions categories and disable them or if possible remove them.

Firefox will alert you to whether you need to restart in order for the chane to take effect, and you can use any link for that on the Add-ons page as the last step.

Then, please see:

In Preferences > General, below the home page blank, you could try Restore to Default. Then test in a new window (Command+n) and your designated home page should open.

Success?

more options

virginiakropas said

Using my Macbook Pro I accidentally made Ask.com my search page when I opened Firefox last week. I wanted to restore to my original opening page. Trying to delete it seemed impossible so I tried to supercede the page by reverting back to the original with an address bar in the upper left corner and a search bar (Google) in the upper right using mozilla somehow. Unfortunately Mozilla Add-ons page now opens up when I click firefox. These add-ons may be very useful in the future, but I don't to bother with them now. I'd like to now how to delete that page so it doesn't open, and restore what I had before. P.S. I got to it trying to eliminate Ask.com according to instructions....with pictures even. Hard to find for Apple.

virginiakropas said

Using my Macbook Pro I accidentally made Ask.com my search page when I opened Firefox last week. I wanted to restore to my original opening page. Trying to delete it seemed impossible so I tried to supercede the page by reverting back to the original with an address bar in the upper left corner and a search bar (Google) in the upper right using mozilla somehow. Unfortunately Mozilla Add-ons page now opens up when I click firefox. These add-ons may be very useful in the future, but I don't to bother with them now. I'd like to now how to delete that page so it doesn't open, and restore what I had before. P.S. I got to it trying to eliminate Ask.com according to instructions....with pictures even. Hard to find for Apple.

virginiakropas said

Using my Macbook Pro I accidentally made Ask.com my search page when I opened Firefox last week. I wanted to restore to my original opening page. Trying to delete it seemed impossible so I tried to supercede the page by reverting back to the original with an address bar in the upper left corner and a search bar (Google) in the upper right using mozilla somehow. Unfortunately Mozilla Add-ons page now opens up when I click firefox. These add-ons may be very useful in the future, but I don't to bother with them now. I'd like to now how to delete that page so it doesn't open, and restore what I had before. P.S. I got to it trying to eliminate Ask.com according to instructions....with pictures even. Hard to find for Apple.
more options

Howdy back atcha,TacoSenpai

No ask doesn't open up now, the Mozilla Add-ons page does.

more options

jscher2000 said

As long as the Add-ons page is opening anyway... please check for any/all unknown and unwanted add-ons in the Plugins and Extensions categories and disable them or if possible remove them. Firefox will alert you to whether you need to restart in order for the chane to take effect, and you can use any link for that on the Add-ons page as the last step. Then, please see: In Preferences > General, below the home page blank, you could try Restore to Default. Then test in a new window (Command+n) and your designated home page should open. Success?
more options

Jscher2000, thank you. I wouldn't know a proper plug-in or extension from Adam, but I was able to look at the bulleted items and will work with them. I'm leaving for a class and won't be back for a couple hours, but am eager to try this out when I get home.

more options

I do not now how to search for and (maybe) remove plug-ins and extensions, unfortunately. I'd like to try the default if it's quick.

more options

I'll get back to this issue later. I wish I had the option to merely open Downloads, not save before opening. Can never find out what they are to delete and must have 1,000. Can I just open and see/read and then choose to save to location of my choice? Must run to class.

Thanks, everyone.

V

more options

Hi Virginia, for extensions, they are all optional so if in doubt, disable them. You can access the Add-ons page using either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

Click Extensions in the left column to get to that list.

Plugins are a little trickier, but generally speaking, the only one is common use is Shockwave Flash (the Flash player).

Regarding downloads, Firefox can preview PDF files, but most downloads require an external application... are there particular types of files that are a problem?

more options

Thanks for info on default. It worked almost exactly as I wished though there isn't a search bar in the right corner, I am content. It also seemed to resolve most of the Download nuisances. I am allowed to to open with Word (docx), and Preview (jpg). Only pdf must be saved,but I can name it and put it where I want to find it easily to delete.

I will keep your last e-mail to refer to when I'm checking Add-ons,etc. Thanks so much. It seems ridiculously simple now. Thanks to you and Mozilla support.

virginia

more options

Isisombululo Esikhethiwe

virginiakropas said

Thanks for info on default, jscher2000. It worked almost exactly as I wished and though there isn't a search bar in the right corner, I am content. It also seemed to resolve most of the Download nuisances. I am allowed to to open with Word (docx), and Preview (jpg). Only pdf must be saved,but I can name it and put it where I want to find it easily to delete. I will keep your last e-mail to refer to when I'm checking Add-ons,etc. Thanks so much. It seems ridiculously simple now. Thanks to you and Mozilla support. virginia
more options

You're the best, jscher2000. How come an 8 hour time dif? NO need to answer. I am content.

V