X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Right side scroll bar not displaying when opening new window in FF 38.0

Kuphostiwe

Hi,

  Ever since I upgraded to FF 38.0, whenever I try to open a link in a new window, (which I do all the time - not a tabs person ;) ) the right hand side scroll bar doesn't show, nor does the new window respond to the scroll wheel on my mouse.  If I open up another instance of FF, and copy/paste the URI from the window without the scroll bar, all is fine, but that's quickly becoming a real pain. I've tried starting FF in Safe Mode - no difference.  Tried uninstalling all of my extensions - still, no difference, and apparently my google-fu is failing me on this one.  Any thoughts, by chance?

Thanks,

Dylan

P.S. On Win 8.1 Pro 64.

Hi, Ever since I upgraded to FF 38.0, whenever I try to open a link in a new window, (which I do all the time - not a tabs person ;) ) the right hand side scroll bar doesn't show, nor does the new window respond to the scroll wheel on my mouse. If I open up another instance of FF, and copy/paste the URI from the window without the scroll bar, all is fine, but that's quickly becoming a real pain. I've tried starting FF in Safe Mode - no difference. Tried uninstalling all of my extensions - still, no difference, and apparently my google-fu is failing me on this one. Any thoughts, by chance? Thanks, Dylan P.S. On Win 8.1 Pro 64.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 15.7.20033
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 17.0 r0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

Eminye Imininingwane

Umnikazi wombuzo

Further info, in case it helps: It looks like the opened window, (i.e. the one missing the scrollbar) is missing a lot of other things, as well - i.e. instead of it looking like every other FF window, it's missing tabs, the back arrow, the reload arrow in the address bar, the search box, the bookmarks star/menu, the download arrow, the home icon, and the right side three lines button that opens all of the "New Window," "New Private Window,"... "Options".. kind of stuff.

Further info, in case it helps: It looks like the opened window, (i.e. the one missing the scrollbar) is missing a lot of other things, as well - i.e. instead of it looking like every other FF window, it's missing tabs, the back arrow, the reload arrow in the address bar, the search box, the bookmarks star/menu, the download arrow, the home icon, and the right side three lines button that opens all of the "New Window," "New Private Window,"... "Options".. kind of stuff.
AlexTs 0 izisombululo 5 izimpendulo
Kuphostiwe

I can't reproduce this bug, but I'm running windows 7 (even though I don't think that makes a difference.) Try to refresh firefox and if that doesn't help create a new profile

I can't reproduce this bug, but I'm running windows 7 (even though I don't think that makes a difference.) Try to [https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings refresh firefox] and if that doesn't help [https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles#w_creating-a-profile create a new profile]
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 159013 izimpendulo
Kuphostiwe

See this article about how to prevent web pages from disabling new window features.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

See this article about how to prevent web pages from disabling new window features. *http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config
jscher2000
  • Top 10 Contributor
8793 izisombululo 71930 izimpendulo
Kuphostiwe

Impendulo Ewusizo

I think this is the third or fourth report I've seen of this today...

Do you use automatic private browsing mode, which generally is set in the Options dialog, Privacy panel, as "Firefox will: Never remember history"? A user with that setting reported getting limited feature windows in that mode and I wonder whether it is a pattern.

Ref: Private Browsing issues: New window is a "pop-up" & Right-clicking bookmarks shows grayed-out options (unsolved)

I think this is the third or fourth report I've seen of this today... Do you use automatic private browsing mode, which generally is set in the Options dialog, Privacy panel, as "Firefox will: Never remember history"? A user with that setting reported getting limited feature windows in that mode and I wonder whether it is a pattern. Ref: [https://support.mozilla.org/questions/1062333 Private Browsing issues: New window is a "pop-up" & Right-clicking bookmarks shows grayed-out options] (unsolved)

Umnikazi wombuzo

Refreshed Firefox as AlexTs suggested, and then @jscher2000 yep, you're onto it. With no Addons installed, and going one by one changing Firefox Options as I usually do, if I set "Firefox will: Never remember history," (as I usually do) I start getting the behavior again. Just to be sure, set it back to "Remember History," and the behavior went back away. "Never Remember" again - behavior comes back. Found a couple of links where it explicitly occurred, and they all had 'target="_blank"' as part of the links that opened with the abbreviated header line and no scroll window, and as I said, this is new to FF 38.0, so presuming it's a fairly recent change.

Refreshed Firefox as AlexTs suggested, and then @jscher2000 yep, you're onto it. With no Addons installed, and going one by one changing Firefox Options as I usually do, if I set "Firefox will: Never remember history," (as I usually do) I start getting the behavior again. Just to be sure, set it back to "Remember History," and the behavior went back away. "Never Remember" again - behavior comes back. Found a couple of links where it explicitly occurred, and they all had 'target="_blank"' as part of the links that opened with the abbreviated header line and no scroll window, and as I said, this is new to FF 38.0, so presuming it's a fairly recent change.
jscher2000
  • Top 10 Contributor
8793 izisombululo 71930 izimpendulo
Kuphostiwe

Hi DylanHunter, thank you for testing.

Seems like a bug, which I can replicate in normal browsing using these steps:

(1) Change the preference that normally diverts new windows to new tabs (uncheck "Open new windows in a new tab instead" in Options>General)

(2) Open my popup test page http://jeffersonscher.com/res/popit.html in a new private window (right-click > "Open Link in New Private Window")

(3) Get these results in Fx 38.0.1 for the links in that page:

(A) target="_blank" - dialog style, which is incorrect (B) window.open() without features - standard chrome, which is correct (C) window.open() with features - dialog style, which is correct

Since the behavior is with the target attribute and not the window.open() method, there aren't any preferences in about:config to address this problem. Other than using tabbed browsing...

Hi DylanHunter, thank you for testing. Seems like a bug, which I can replicate in normal browsing using these steps: (1) Change the preference that normally diverts new windows to new tabs (uncheck "Open new windows in a new tab instead" in Options>General) (2) Open my popup test page http://jeffersonscher.com/res/popit.html in a new private window (right-click > "Open Link in New Private Window") (3) Get these results in Fx 38.0.1 for the links in that page: (A) target="_blank" - dialog style, which is '''incorrect''' (B) window.open() without features - standard chrome, which is correct (C) window.open() with features - dialog style, which is correct Since the behavior is with the target attribute and not the window.open() method, there aren't any preferences in about:config to address this problem. Other than using tabbed browsing...
jscher2000
  • Top 10 Contributor
8793 izisombululo 71930 izimpendulo
Kuphostiwe

By the way, if you Shift+click links with target="_blank" then the new window has the expected chrome. There seems to be some bug with the target attribute in private windows with tabbed browsing turned off.

By the way, if you Shift+click links with target="_blank" then the new window has the expected chrome. There seems to be some bug with the target attribute in private windows with tabbed browsing turned off.
jscher2000
  • Top 10 Contributor
8793 izisombululo 71930 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Here's a brief update:

Work on this bug is in process, but I don't know if the fix will be available in the next few weeks.

Another workaround is to change certain hidden setting related to dialog-style windows. This will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.

Here are the steps:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste feat and pause while the list is filtered

(3) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.

Here's a brief update: Work on this bug is in process, but I don't know if the fix will be available in the next few weeks. Another workaround is to change certain hidden setting related to dialog-style windows. This will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed. Here are the steps: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''feat''' and pause while the list is filtered (3) For every preference that starts with '''dom.disable_window_open_feature.''' if it is not "true", double-click it to switch it to true. You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.
CheetahOBX 0 izisombululo 5 izimpendulo
Kuphostiwe

When I open a new window on the internet.....the right hand scroll bar is not there......but if I left click/right click(I use backwards!) and ask the link window to open in a new window...the scroll bar IS there....please advise....it just started doing that.....both javascripts are listed as "true"....05-29-2015

When I open a new window on the internet.....the right hand scroll bar is not there......but if I left click/right click(I use backwards!) and ask the link window to open in a new window...the scroll bar IS there....please advise....it just started doing that.....both javascripts are listed as "true"....05-29-2015
jscher2000
  • Top 10 Contributor
8793 izisombululo 71930 izimpendulo
Kuphostiwe

Hi CheetahOBX, this thread has all the bits and pieces of the answer, but let me summarize: there is a bug in Firefox 38 with this combination of circumstances:

(1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned off (3) You click a link which launches the link in a new window (because the site coded the link with target="_blank")

The new window opens without menus, toolbar, scroll bars, etc.

Work on this bug is in process, and might be solved next month, but until then there are the currently known workarounds for private window users and any one of them will avoid this problem:

(1) Use tabbed browsing (this is a checkbox under Options/Preferences > General > "Open new windows in a new tab instead");

(2) Shift+click links to open them in a new window with the standard features; or

(3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed.

For #3, here are the steps:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste feat and pause while the list is filtered

(C) For every preference that starts with dom.disable_window_open_feature. if it is not "true", double-click it to switch it to true.

You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.

Hi CheetahOBX, this thread has all the bits and pieces of the answer, but let me summarize: there is a bug in Firefox 38 with this combination of circumstances: (1) You are viewing a page in a private browsing window (2) Tabbed browsing is turned ''off'' (3) You click a link which launches the link in a new window (because the site coded the link with target="_blank") The new window opens without menus, toolbar, scroll bars, etc. Work on this bug is in process, and might be solved next month, but until then there are the currently known workarounds for private window users and any one of them will avoid this problem: (1) Use tabbed browsing (this is a checkbox under Options/Preferences > General > "Open new windows in a new tab instead"); (2) Shift+click links to open them in a new window with the standard features; or (3) Change a bunch of hidden settings as explained below -- this will not require you to make any changes to how you use Firefox, but you might occasionally need to enlarge some small pop-up windows that were sized for a window with no toolbars displayed. ''For #3, here are the steps:'' (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (B) In the search box above the list, type or paste '''feat''' and pause while the list is filtered (C) For every preference that starts with '''dom.disable_window_open_feature.''' if it is not "true", double-click it to switch it to true. You may find that you prefer this anyway, since sites can no longer strip these features out of pop-up windows.
CheetahOBX 0 izisombululo 5 izimpendulo
Kuphostiwe

Thanks for the reply/update!!!

I prefer to do the:

1. LEFT click the link(which give you a drop down list with the "Open In a New Window" option)......and then I RIGHT click that.....it is a little bit cumber-sum.... but I just do not like the "tabs" flaps that open up in "tab"......

I like to be able to see the actual window(s) that are open AND I can read the heading on the windows better!!!

I tried all you stated except part deuce......that is too much stuff....I like it KISS(Keep It Simple S_ _ _ _ _....with all due respect).....

But thank you again!!!

I just knew that something had to be up.....good luck on the fix!!! ♫

Thanks for the reply/update!!! I prefer to do the: 1. LEFT click the link(which give you a drop down list with the "Open In a New Window" option)......and then I RIGHT click that.....it is a little bit cumber-sum.... but I just do not like the "tabs" flaps that open up in "tab"...... I like to be able to see the actual window(s) that are open AND I can read the heading on the windows better!!! I tried all you stated except part deuce......that is too much stuff....I like it KISS(Keep It Simple S_ _ _ _ _....with all due respect)..... But thank you again!!! I just knew that something had to be up.....good luck on the fix!!! ♫
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 159013 izimpendulo
Kuphostiwe

Did you modify at least dom.disable_window_open_feature.scrollbars and set it to true with a double-click if the current value is false (i.e. default)?

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Did you modify at least dom.disable_window_open_feature.scrollbars and set it to true with a double-click if the current value is false (i.e. default)? You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config
CheetahOBX 0 izisombululo 5 izimpendulo
Kuphostiwe

Thanks for the follow up!

I just did this....not sure what it is or supposed to do..... so......I'll keep moosying along......thanks!

Thanks for the follow up! I just did this....not sure what it is or supposed to do..... so......I'll keep moosying along......thanks!
cor-el
  • Top 10 Contributor
  • Moderator
17578 izisombululo 159013 izimpendulo
Kuphostiwe

Setting dom.disable_window_open_feature prefs to true prevents a website from hiding elements in the Firefox user interface. The default for most of them is false, so a website can open a pop-up window and hide the menu bar and the scroll bar and make the location/address bar read-only (Firefox doesn't allow to hide the location/address bar).

Setting dom.disable_window_open_feature prefs to true prevents a website from hiding elements in the Firefox user interface. The default for most of them is false, so a website can open a pop-up window and hide the menu bar and the scroll bar and make the location/address bar read-only (Firefox doesn't allow to hide the location/address bar).