Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Is there any way to disable how the options open since the new update?

  • 6 uphendule
  • 5 zinale nkinga
  • 3 views
  • Igcine ukuphendulwa ngu cor-el

more options

I absolutely hate the way the options opens in a new tab instead of a new window. Is there any way to disable it so that the options opens in a new window like before?

I absolutely hate the way the options opens in a new tab instead of a new window. Is there any way to disable it so that the options opens in a new window like before?

Isisombululo esikhethiwe

The browser.preferences.inContent is no longer supported in Firefox 42 and later (Bug 1140495), so it is not possible to open a standalone window by setting this pref to false.

You can possibly create a button on the Bookmarks Toolbar to the about:preferences page and hold the Shift key and left-click to open the page in a new window.

You can look at the Classic Theme Restorer extension.

  • General UI (1): Open options page (about:preferences) in a window

If that isn't working or the choice is missing then you might be using a theme that isn't supported. You can check that by switching to the default theme.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (6)

more options

You can toggle browser.preferences.inContent to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Thank you so much!!!

more options

This tip worked great when I used it a few months ago. I just upgraded to Firefox 42.0, and now Options opens in a tab again instead of a new window. I checked the about:config page and browser.preferences.inContent is still set to false. Is there any way to change this behavior in version 42.0?

more options

Isisombululo Esikhethiwe

The browser.preferences.inContent is no longer supported in Firefox 42 and later (Bug 1140495), so it is not possible to open a standalone window by setting this pref to false.

You can possibly create a button on the Bookmarks Toolbar to the about:preferences page and hold the Shift key and left-click to open the page in a new window.

You can look at the Classic Theme Restorer extension.

  • General UI (1): Open options page (about:preferences) in a window

If that isn't working or the choice is missing then you might be using a theme that isn't supported. You can check that by switching to the default theme.

more options

Thanks for your help. The Classic Theme Restorer extension did the trick.

more options

You're welcome.

I've changed to solution to my above reply to avoid confusion.