Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Change default search engine to Google will not go away.

  • 5 uphendule
  • 1 inale nkinga
  • 932 views
  • Igcine ukuphendulwa ngu James

more options

Change default search engine to Google will not go away even after changing all search defaults to Google. It's bugging me.

Isisombululo esikhethiwe

If you dismiss the blue bar, Google sets a cookie to remind itself not to show it again. If you block or clear Google cookies, the site keeps showing the bar.

You can use a custom style rule to hide it. Some people have used Adblock Plus or a related add-on. Here's an older thread with suggestions: How do I remove the "Get to Google faster. Switch you default search enging to Google" bar at the top of Firefox?

Added screen shot of the bar for reference

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (5)

more options

Hello,

Please try following the instructions below if you haven't already. If they don't fix your problem, please provide more information about the problem (screenshots are often helpful) so that we can help you.


You can choose from different search providers such as Google, Yahoo or Bing when you search the Internet using Firefox. For more information, see the article Search with the Firefox address bar.

If you want to change the default search engine that Firefox uses,

In Firefox 33 or below:

  1. Move the mouse cursor inside the search box at the top right of the Firefox window and click the down arrow next to the provider's logo.
  2. If you would like to select another search engine, simply pick the engine from the dropdown list.

If you also want to change the order of the search engines, do this:

  1. From the dropdown list, select Manage Search Engines....
  2. In the upcoming window, you have all your search engines listed. To change the order, simply click one search engine and then select Move up or Move down from the buttons on the right side in order to change the order of the search engines.

Starting in Firefox 34:
Note: The following may not apply to localized versions of Firefox.

Use one of these methods to change the default search engine:

  • Click the menu button New Fx Menu and choose Options on Windows or Preferences on Mac or Linux, then select the Search settings panel.
  • Click on the magnifying glass icon in the Search bar, then click on Change Search Settings, as shown here:
search prefs 34

In the Search settings panel that opens, select a different search engine from the drop-down menu (see this screenshot).

Okulungisiwe ngu tjohnson

more options

I've tried this several times. Still get the bitch screen. I'm blocking Google tracking do you think this might have something to do with it?

more options

Rockcop said

I'm blocking Google tracking do you think this might have something to do with it?

It shouldn't. Please provide a screenshot of the screen you are seeing so that we know what you're referring to.

Okulungisiwe ngu tjohnson

more options

Isisombululo Esikhethiwe

If you dismiss the blue bar, Google sets a cookie to remind itself not to show it again. If you block or clear Google cookies, the site keeps showing the bar.

You can use a custom style rule to hide it. Some people have used Adblock Plus or a related add-on. Here's an older thread with suggestions: How do I remove the "Get to Google faster. Switch you default search enging to Google" bar at the top of Firefox?

Added screen shot of the bar for reference

Okulungisiwe ngu jscher2000

more options

Google has been doing that since as early as Firefox 34.0 when Yahoo became the new default search engine in the Search Bar in en-US Firefox.

Okulungisiwe ngu James