Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

every time I launch FireFox, it launches (opens) two sessions of the program

  • 3 uphendule
  • 6 zinale nkinga
  • 6514 views
  • Igcine ukuphendulwa ngu cor-el

more options

I have tried uninstalling and reinstalling the latest version. Also removed all my shortcuts. Don't know what else to try.

Isisombululo esikhethiwe

You can check the home page setting:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Do you get two windows with your home page, or does the second window have something different?


If you inspect the shortcut/icon you use to start Firefox, do you find any extraneous information in the Shortcut Target? right-click the icon > Properties > Shortcut tab. (If the icon is pinned to the Task bar, right-click it, then right-click the Mozilla Firefox item > Properties > Shortcut tab)

For 64-bit Windows 7, the Target should be no more and no less than the following:

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

Note: You may get two windows if you double-click a pinned icon on the Windows Taskbar. I'm not sure exactly when Windows discards the second click and when it executes it.

more options

Thanks for your reply. The shortcut properties shows exactly what you said it should.

I removed the icon from the Taskbar and made sure there were no shortcuts anywhere else. So now FF only starts from the Start Menu. When I right click the Start Menu entry, I get a drop-down with three choices: open new tab open new window new private window When I select “open new tab” and “new private window” it opens only one session FF . When I select “open new window,” two sessions of FF open.

During all this I was very careful not to double-click. I haven’t had any problems with the mouse, this only happens with FF.

“firefox.exe” only exists one place on my computer (C:\Program Files (x86)\Mozilla Firefox). When I launch FF using that execute program, it also opens FF twice – each appears exactly the same.

more options

Isisombululo Esikhethiwe

You can check the home page setting:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart or otherwise have problems with preferences, see: