X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox Stopped Working all together.

Kuphostiwe

So I was using windows 8.1 Firefox 38.0.1 for a long time, and it was working fine, but then it stopped displaying websites correctly, Example Mozilla.org would show up as text, with no CSS or HTML/PHP stylings, nothing but pure text, Then Yahoo.com, then youtube, and eventually every single site would show up as just text, I cleared my Cache, Nothing didnt fix the problem, Refreshed Firefox, Didnt fix the problem, Ran Firefox in Safe Mode, Didnt fix the problem... Uninstalled Firefox, and manually cleaned out everything on my computer linked to firefox/mozilla, reinstalled the beta version (First) that version had the problem, so uninstalled and manually cleaned everything again (Including Registry entries) and installed the standard version, still same problem.

Then thinking maybe its a windows problem, i refreshed windows 8.1, still had same problem with Firefox, and lastly i updated to the Insider Preview of windows 10 (just to be sure...) and its still having problems with firefox...

So I uninstalled and installed Chrome again... but i like firefox better :( does anyone know why this is happening? and how to fix it.

Oh some other issues it was having before it stopped viewing HTML/CSS/PHP, Youtube videos would only work for 5 seconds, then freeze (Every Single Video), HTTPS website wouldn't connect 90% of the time and would actually get an error (Sites including Mozilla.org, and Google.com wouldn't work)

My last 2 clean installs of Firefox had no Plugins installed. and my only Antivirus software is Avast.

So I was using windows 8.1 Firefox 38.0.1 for a long time, and it was working fine, but then it stopped displaying websites correctly, Example Mozilla.org would show up as text, with no CSS or HTML/PHP stylings, nothing but pure text, Then Yahoo.com, then youtube, and eventually every single site would show up as just text, I cleared my Cache, Nothing didnt fix the problem, Refreshed Firefox, Didnt fix the problem, Ran Firefox in Safe Mode, Didnt fix the problem... Uninstalled Firefox, and manually cleaned out everything on my computer linked to firefox/mozilla, reinstalled the beta version (First) that version had the problem, so uninstalled and manually cleaned everything again (Including Registry entries) and installed the standard version, still same problem. Then thinking maybe its a windows problem, i refreshed windows 8.1, still had same problem with Firefox, and lastly i updated to the Insider Preview of windows 10 (just to be sure...) and its still having problems with firefox... So I uninstalled and installed Chrome again... but i like firefox better :( does anyone know why this is happening? and how to fix it. Oh some other issues it was having before it stopped viewing HTML/CSS/PHP, Youtube videos would only work for 5 seconds, then freeze (Every Single Video), HTTPS website wouldn't connect 90% of the time and would actually get an error (Sites including Mozilla.org, and Google.com wouldn't work) My last 2 clean installs of Firefox had no Plugins installed. and my only Antivirus software is Avast.

Okulungisiwe ngu Ablac

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4314 izisombululo 60573 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there?
jscher2000
  • Top 10 Contributor
8838 izisombululo 72242 izimpendulo
Kuphostiwe

I have a hunch. Have you noticed any certificate errors with secure sites? Have you added any exceptions?

avast! 2015 has a feature to scan your web traffic. In order to scan content from secure sites, it needs to present a "fake" certificate to Firefox so it can intercept and decrypt the content. Firefox might not be set up to work with this feature, and therefore distrusts the certificates. Adding an exception for a site generally only works for the main page content because most large sites now spread their various files over a number of servers. This can lead to missing style sheets, scripts, and other essential content.

I should mention that malware also can cause this issue, not just legit security software.

To diagnose this, could you click the padlock icon in the address bar for a few different secure sites, then More Information, then View Certificate, and check the "Issued by" section. Do you see a pattern there of the same issuer? If so, who/what is it?

I have a hunch. Have you noticed any certificate errors with secure sites? Have you added any exceptions? avast! 2015 has a feature to scan your web traffic. In order to scan content from secure sites, it needs to present a "fake" certificate to Firefox so it can intercept and decrypt the content. Firefox might not be set up to work with this feature, and therefore distrusts the certificates. Adding an exception for a site generally only works for the main page content because most large sites now spread their various files over a number of servers. This can lead to missing style sheets, scripts, and other essential content. I should mention that malware also can cause this issue, not just legit security software. To diagnose this, could you click the padlock icon in the address bar for a few different secure sites, then More Information, then View Certificate, and check the "Issued by" section. Do you see a pattern there of the same issuer? If so, who/what is it?