X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

User/Passwords no longer autofilled

Kuphostiwe

Hi, I'm using firefox-37.0.1 on fedora20 and for about the last week or so, input fields that previously would have been autofilled with username and password now do not. I can double-click on the input field to choose a username from a list, but it does not complete with the password when selected.

The username and password are stored in the password manager, but not automatically entered by firefox.

After entering the correct username and password, it also doesn't prompt to store these automatically either.

I really don't have any idea what could have changed to cause this problem.

Any help greatly appreciated. Thanks, Dave

Hi, I'm using firefox-37.0.1 on fedora20 and for about the last week or so, input fields that previously would have been autofilled with username and password now do not. I can double-click on the input field to choose a username from a list, but it does not complete with the password when selected. The username and password are stored in the password manager, but not automatically entered by firefox. After entering the correct username and password, it also doesn't prompt to store these automatically either. I really don't have any idea what could have changed to cause this problem. Any help greatly appreciated. Thanks, Dave

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • DivX Web Player version 1.4.0.233
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • The IcedTea-Web Plugin executes Java applets.
  • The Videos 3.10.1 plugin handles video and audio streams.
  • Shockwave Flash 11.2 r202
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Isisebenziso

  • Firefox 37.0.1
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/37.0.1/Linux/en-US/

Izandiso

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add to Amazon Wish List Button 1.10 (amznUWL2@amazon.com)
  • DownThemAll! 2.0.18.1-signed ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • feedly 16.0.528 (feedly@devhd)
  • LastPass 3.1.95 (support@lastpass.com)
  • Nagios Checker 0.16 ({123b2220-59cb-11db-b0de-0800200c9a66})
  • Pastebin 3.0 (pastebin.com@gmail.com)
  • Pin It Button 1.35 (jid1-YcMV6ngYmQRA2w@jetpack)
  • Screen grab! with Online Upload 1.07 ({29CB7FC4-9DD9-4357-9452-457BD5589D9E})
  • SearchPreview 8.3 ({EF522540-89F5-46b9-B6FE-1829E2B572C6})
  • Status-4-Evar 2015.02.06.23 (status4evar@caligonstudios.com)
  • TinEye Reverse Image Search 1.1 (tineye@ideeinc.com)
  • TinyURL Generator 2.6.1 (tinyurl.addon@fast-chat.co.uk)
  • Tree Style Tab 0.15.2015030601 (treestyletab@piro.sakura.ne.jp)
  • xclear 1.8 (xclear@as-computer.de)
  • Xmarks 4.3.6 (foxmarks@kei.com)
  • Buffer 2.11.2 (jid1-zUyU7TGKwejAyA@jetpack) (Akusebenzi)
  • Clearly 10.2.1.7 (readable@evernote.com) (Akusebenzi)
  • Ghostery 5.4.5 (firefox@ghostery.com) (Akusebenzi)
  • HTML5 Notifications 1.2.4 (html5notifications@paxal.net) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: X.Org -- Gallium 0.4 on AMD JUNIPER
  • adapterDeviceID: Gallium 0.4 on AMD JUNIPER
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org
  • driverDate:
  • driverVersion: 3.0 Mesa 10.3.3
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 4
  • webglRenderer: X.Org -- Gallium 0.4 on AMD JUNIPER
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

Misc

  • Umsebenzisi JS: Yebo
  • Ukufinyeleleka: Cha
cor-el
  • Top 10 Contributor
  • Moderator
17519 izisombululo 158412 izimpendulo
Kuphostiwe

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Edit > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history). *https://support.mozilla.org/kb/Private+Browsing *Edit > Preferences > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use Private Browsing mode" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Umnikazi wombuzo

cor-el said

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).
  • Edit > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"
Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Thanks so much for your help.

I checked that I wasn't in Private Browsing mode. I also restarted in Safe Mode (in safe mode as I type), and not only did firefox not supply the login info for this forum, it also didn't prompt me to save it once entered.

Other ideas?

''cor-el [[#answer-724623|said]]'' <blockquote> Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history). *https://support.mozilla.org/kb/Private+Browsing *Edit > Preferences > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use Private Browsing mode" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes </blockquote> Thanks so much for your help. I checked that I wasn't in Private Browsing mode. I also restarted in Safe Mode (in safe mode as I type), and not only did firefox not supply the login info for this forum, it also didn't prompt me to save it once entered. Other ideas?
cor-el
  • Top 10 Contributor
  • Moderator
17519 izisombululo 158412 izimpendulo
Kuphostiwe

What is the value of the signon.autofillForms pref on the about:config page?

What is the value of the signon.autofillForms pref on the <b>about:config</b> page?

Umnikazi wombuzo

cor-el said

What is the value of the signon.autofillForms pref on the about:config page?

I meant to mention in my initial post that I checked that and the value is 'true'.

I've also visited a handful of other sites that have my user/pass stored in the password manager yet don't autofill them when logging in.

Thank you.

''cor-el [[#answer-724662|said]]'' <blockquote> What is the value of the signon.autofillForms pref on the <b>about:config</b> page? </blockquote> I meant to mention in my initial post that I checked that and the value is 'true'. I've also visited a handful of other sites that have my user/pass stored in the password manager yet don't autofill them when logging in. Thank you.

Okulungisiwe ngu gosssamer

cor-el
  • Top 10 Contributor
  • Moderator
17519 izisombululo 158412 izimpendulo
Kuphostiwe

Is the form or input field has an autocomplete=off attribute then Firefox won't auto-fill the name and password. Firefox will store the name and password if that hasn't happened yet (i.e. currently not visible in the Password Manager).

You can temporarily rename or move the two files (logins.json and key3.db) that deal with the passwords to see if that at least makes Firefox ask to store the name/password. There may be other cases where Firefox doesn't auto-fill names, but as long as you can select them from the drop-down list when you press the down key or type the first letter(s) then you should use that.


You can try to create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Is the form or input field has an autocomplete=off attribute then Firefox won't auto-fill the name and password. Firefox will store the name and password if that hasn't happened yet (i.e. currently not visible in the Password Manager). You can temporarily rename or move the two files (logins.json and key3.db) that deal with the passwords to see if that at least makes Firefox ask to store the name/password. There may be other cases where Firefox doesn't auto-fill names, but as long as you can select them from the drop-down list when you press the down key or type the first letter(s) then you should use that. ---- You can try to create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Umnikazi wombuzo

cor-el said

Is the form or input field has an autocomplete=off attribute then Firefox won't auto-fill the name and password. Firefox will store the name and password if that hasn't happened yet (i.e. currently not visible in the Password Manager). You can temporarily rename or move the two files (logins.json and key3.db) that deal with the passwords to see if that at least makes Firefox ask to store the name/password.

I've done this, and it still doesn't provide user/pass or save them when manually entered again.

There may be other cases where Firefox doesn't auto-fill names, but as long as you can select them from the drop-down list when you press the down key or type the first letter(s) then you should use that.

Just to be clear, it simply is not providing any previously entered user/pass in fields where this used to be done automatically, even after double-clicking in the input field.

You can try to create a new profile as a test to check if your current profile is causing the problem.

I've created a new profile, and it does then prompt to save my user/pass in the same site where it previously does not. It also autofills the user/pass when going back a second time.

Does this mean my only recourse is to rebuild my profile, or are there other possible solutions?

''cor-el [[#answer-724669|said]]'' <blockquote> Is the form or input field has an autocomplete=off attribute then Firefox won't auto-fill the name and password. Firefox will store the name and password if that hasn't happened yet (i.e. currently not visible in the Password Manager). You can temporarily rename or move the two files (logins.json and key3.db) that deal with the passwords to see if that at least makes Firefox ask to store the name/password.</blockquote> I've done this, and it still doesn't provide user/pass or save them when manually entered again. <blockquote>There may be other cases where Firefox doesn't auto-fill names, but as long as you can select them from the drop-down list when you press the down key or type the first letter(s) then you should use that.</blockquote> Just to be clear, it simply is not providing any previously entered user/pass in fields where this used to be done automatically, even after double-clicking in the input field. <blockquote>You can try to create a new profile as a test to check if your current profile is causing the problem.</blockquote> I've created a new profile, and it does then prompt to save my user/pass in the same site where it previously does not. It also autofills the user/pass when going back a second time. Does this mean my only recourse is to rebuild my profile, or are there other possible solutions?
cor-el
  • Top 10 Contributor
  • Moderator
17519 izisombululo 158412 izimpendulo
Kuphostiwe

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

It is possible that there is a problem with the key3.db file (encryption key) and the logins.json file (encrypted names and passwords) in Firefox. You can rename the key3.db file (key3.db.old) and logins.json file (logins.json.old) and rename a possible signons.sqlite file (signons.sqlite.old) or move them to another folder to make it possible to undo the action. You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost. If that has worked then you can remove the renamed files that are no longer needed. Otherwise you can rename the files to their previous names (key3.db and logins.json).

If you see passwords in the Password Manager (Edit > Preferences > Security: Passwords > "Saved Passwords") then you can save the existing passwords with the Password Exporter extension before removing/renaming files and re-import them afterward.

Check that the exported (xml) file has all the names and passwords.

You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences It is possible that there is a problem with the key3.db file (encryption key) and the logins.json file (encrypted names and passwords) in Firefox. You can rename the key3.db file (key3.db.old) and logins.json file (logins.json.old) and rename a possible signons.sqlite file (signons.sqlite.old) or move them to another folder to make it possible to undo the action. You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost. If that has worked then you can remove the renamed files that are no longer needed. Otherwise you can rename the files to their previous names (key3.db and logins.json). If you see passwords in the Password Manager (Edit > Preferences > Security: Passwords > "Saved Passwords") then you can save the existing passwords with the Password Exporter extension before removing/renaming files and re-import them afterward. * Password Exporter: https://addons.mozilla.org/firefox/addon/password-exporter/ Check that the exported (xml) file has all the names and passwords.

Umnikazi wombuzo

cor-el said

You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

The user.js file is dated Nov 2009, and the problem only recently started.

It is possible that there is a problem with the key3.db file (encryption key) and the logins.json file (encrypted names and passwords) in Firefox. You can rename the key3.db file (key3.db.old) and logins.json file (logins.json.old) and rename a possible signons.sqlite file (signons.sqlite.old) or move them to another folder to make it possible to undo the action.

We went through this already, and it doesn't appear to be related to these files. I renamed them and restarted firefox. Accessing a site I know to have previously stored my password now does not.

I also restarted in safe mode with these new key3.db and logins.json files, and it still doesn't save my passwords.

If you see passwords in the Password Manager (Edit > Preferences > Security: Passwords > "Saved Passwords") then you can save the existing passwords with the Password Exporter extension before removing/renaming files and re-import them afterward.

Is there no more troubleshooting that can be done at this point? Is it necessary to export my passwords, create a new profile, then migrate my passwords, bookmarks, history, etc?

What about my open tabs? I have hundreds of open tabs that I can't lose. Do I also just bookmark them and restore them in the new profile?

''cor-el [[#answer-725030|said]]'' <blockquote> You can check for problems with preferences. Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.</blockquote> The user.js file is dated Nov 2009, and the problem only recently started. <blockquote>It is possible that there is a problem with the key3.db file (encryption key) and the logins.json file (encrypted names and passwords) in Firefox. You can rename the key3.db file (key3.db.old) and logins.json file (logins.json.old) and rename a possible signons.sqlite file (signons.sqlite.old) or move them to another folder to make it possible to undo the action.</blockquote> We went through this already, and it doesn't appear to be related to these files. I renamed them and restarted firefox. Accessing a site I know to have previously stored my password now does not. I also restarted in safe mode with these new key3.db and logins.json files, and it still doesn't save my passwords. <blockquote>If you see passwords in the Password Manager (Edit > Preferences > Security: Passwords > "Saved Passwords") then you can save the existing passwords with the Password Exporter extension before removing/renaming files and re-import them afterward.</blockquote> Is there no more troubleshooting that can be done at this point? Is it necessary to export my passwords, create a new profile, then migrate my passwords, bookmarks, history, etc? What about my open tabs? I have hundreds of open tabs that I can't lose. Do I also just bookmark them and restore them in the new profile?
cor-el
  • Top 10 Contributor
  • Moderator
17519 izisombululo 158412 izimpendulo
Kuphostiwe

What is the content of the user.js file (right-click: Open with: Notepad; do not double-click)?

Did you create this user.js file yourself back in 2009?

What is the content of the user.js file (right-click: Open with: Notepad; do not double-click)? Did you create this user.js file yourself back in 2009?

Umnikazi wombuzo

It only contains the following text:

user_pref("yahoo.homepage.dontask", true);

I don't believe I created it.

You'll also recall signon.autofillforms is true.

It only contains the following text: user_pref("yahoo.homepage.dontask", true); I don't believe I created it. You'll also recall signon.autofillforms is true.

Umnikazi wombuzo

Does no one have any other ideas? Or am I missing something in an explanation?

I really don't want to go through the whole profile rebuild process. Does anyone at least able to identify where the actual problem/cause is?

Does no one have any other ideas? Or am I missing something in an explanation? I really don't want to go through the whole profile rebuild process. Does anyone at least able to identify where the actual problem/cause is?